aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2007-02-05 02:25:36 +0800
committersat <sat@FreeBSD.org>2007-02-05 02:25:36 +0800
commitd268f00848daacf22b96f921d3917b96013993cf (patch)
tree396ceac9638f155972d1ff259c0ffc48c83a69ef /audio
parenta5ce2174e90c953624c0eaa7fa1f7d767bae8f17 (diff)
downloadfreebsd-ports-gnome-d268f00848daacf22b96f921d3917b96013993cf.tar.gz
freebsd-ports-gnome-d268f00848daacf22b96f921d3917b96013993cf.tar.zst
freebsd-ports-gnome-d268f00848daacf22b96f921d3917b96013993cf.zip
- /objformat=/s|=.*|=elf| [1]
- Don't build static lib Reported by: pointyhat via kris [1] Approved by: Beech Rintoul <freebsd@alaskaparadise.com> (maintainer)
Diffstat (limited to 'audio')
-rw-r--r--audio/x11amp/Makefile4
-rw-r--r--audio/x11amp/pkg-plist1
2 files changed, 4 insertions, 1 deletions
diff --git a/audio/x11amp/Makefile b/audio/x11amp/Makefile
index ed3221c84211..6d41f9affe73 100644
--- a/audio/x11amp/Makefile
+++ b/audio/x11amp/Makefile
@@ -21,6 +21,7 @@ USE_XLIB= yes
USE_GNOME= gtk12 esound
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-static
CONFIGURE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"
MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"
@@ -30,4 +31,7 @@ post-extract:
@${CP} ${FILESDIR}/main.xpm ${WRKSRC}/x11amp/defskin
@${CHMOD} a+x ${WRKSRC}/ltconfig
+post-patch:
+ @${REINPLACE_CMD} -e '/objformat=/s|=.*|=elf|' ${WRKSRC}/ltconfig
+
.include <bsd.port.post.mk>
diff --git a/audio/x11amp/pkg-plist b/audio/x11amp/pkg-plist
index cd32e9774f32..4a1b235f63de 100644
--- a/audio/x11amp/pkg-plist
+++ b/audio/x11amp/pkg-plist
@@ -3,7 +3,6 @@ bin/x11amp
include/x11amp/configfile.h
include/x11amp/plugin.h
include/x11amp/x11ampctrl.h
-lib/libx11amp.a
lib/libx11amp.la
lib/libx11amp.so
lib/libx11amp.so.9