aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-10-24 00:06:54 +0800
committermiwi <miwi@FreeBSD.org>2011-10-24 00:06:54 +0800
commite4afd85f7dd12f7c7b8e8c36dc10efbae883e774 (patch)
tree39c1660b32bcf2296b3145c48dd9afecb4bbcf2d /audio
parent74bbbefe826faa7138ef0478a052e847fdd41ba2 (diff)
downloadfreebsd-ports-gnome-e4afd85f7dd12f7c7b8e8c36dc10efbae883e774.tar.gz
freebsd-ports-gnome-e4afd85f7dd12f7c7b8e8c36dc10efbae883e774.tar.zst
freebsd-ports-gnome-e4afd85f7dd12f7c7b8e8c36dc10efbae883e774.zip
- Fix build
PR: 161591 Submitted by: Guido Falsi <mad@madpilot.net>
Diffstat (limited to 'audio')
-rw-r--r--audio/xmms2/Makefile4
-rw-r--r--audio/xmms2/files/patch-wafadmin-Task.py18
2 files changed, 18 insertions, 4 deletions
diff --git a/audio/xmms2/Makefile b/audio/xmms2/Makefile
index 5ea1a239975c..b3f0101680e9 100644
--- a/audio/xmms2/Makefile
+++ b/audio/xmms2/Makefile
@@ -63,10 +63,6 @@ OPTIONS= AIRPLAY "Support output via Airport Express" off \
.include <bsd.port.pre.mk>
-.if defined(PACKAGE_BUILDING)
-BROKEN= fails to build on pointyhat: runaway process
-.endif
-
.if defined(XMMS2_SLAVE)
EXCLUDE+= --without-xmms2d
diff --git a/audio/xmms2/files/patch-wafadmin-Task.py b/audio/xmms2/files/patch-wafadmin-Task.py
new file mode 100644
index 000000000000..6e7553a31e1f
--- /dev/null
+++ b/audio/xmms2/files/patch-wafadmin-Task.py
@@ -0,0 +1,18 @@
+--- wafadmin/Task.py.orig 2010-02-19 18:43:54.000000000 +0100
++++ wafadmin/Task.py 2011-10-14 14:36:57.000663231 +0200
+@@ -47,6 +47,7 @@
+ import Build, Runner, Utils, Node, Logs, Options
+ from Logs import debug, warn, error
+ from Constants import *
++import time
+
+ algotype = NORMAL
+ #algotype = JOBCONTROL
+@@ -406,6 +407,7 @@
+ def call_run(self):
+ if self.can_retrieve_cache():
+ return 0
++ time.sleep(0.02)
+ return self.run()
+
+ def run(self):