aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authordim <dim@FreeBSD.org>2016-09-13 03:41:12 +0800
committerdim <dim@FreeBSD.org>2016-09-13 03:41:12 +0800
commitf00871ac5b947a9c9e5cfe3a8fb0f6665d898835 (patch)
treeaa252f0f8a2a9cedd73fe3929650a3353280acec /audio
parent77b230c39e2bfe58c0e72ff46899c2105a3241f8 (diff)
downloadfreebsd-ports-gnome-f00871ac5b947a9c9e5cfe3a8fb0f6665d898835.tar.gz
freebsd-ports-gnome-f00871ac5b947a9c9e5cfe3a8fb0f6665d898835.tar.zst
freebsd-ports-gnome-f00871ac5b947a9c9e5cfe3a8fb0f6665d898835.zip
Fix build of audio/clementine-player with clang 3.9.0
Clang 3.9.0 has a new warning about undefined template variables, which is triggered by including cryptopp headers in the spotify blob downloader: In file included from /wrkdirs/usr/ports/audio/clementine-player/work/Clementine-1.3.1/src/internet/spotify/spotifyblobdownloader.cpp:43: /usr/local/include/cryptopp/pkcspad.h:74:53: error: instantiation of variable 'CryptoPP::PKCS_DigestDecoration<CryptoPP::SHA512>::decoration' required here, but no definition is available [-Werror,-Wundefined-var-template] return HashIdentifier(PKCS_DigestDecoration<H>::decoration, PKCS_DigestDecoration<H>::length); ^ This warning could be silenced by hacking on cryptopp, but just suppress it for now. Approved by: sbruno (maintainer) PR: 212343 MFH: 2016Q3
Diffstat (limited to 'audio')
-rw-r--r--audio/clementine-player/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/audio/clementine-player/Makefile b/audio/clementine-player/Makefile
index ebcfb7d3cc49..0d301975f568 100644
--- a/audio/clementine-player/Makefile
+++ b/audio/clementine-player/Makefile
@@ -198,4 +198,10 @@ VISUALISATION_CMAKE_OFF=-DENABLE_VISUALISATIONS=OFF
WIIMOTEDEV_CMAKE_ON= -DENABLE_WIIMOTEDEV=ON
WIIMOTEDEV_CMAKE_OFF= -DENABLE_WIIMOTEDEV=OFF
+.include <bsd.port.pre.mk>
+
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 39
+CXXFLAGS+= -Wno-undefined-var-template
+.endif
+
.include <bsd.port.mk>