aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2012-07-23 07:23:59 +0800
committerdougb <dougb@FreeBSD.org>2012-07-23 07:23:59 +0800
commitf1c77bf62fae9c35b8af1d993c00277b5c80860c (patch)
tree4340b2026c7c38e24a07317c8ba6bded8fdc03e8 /audio
parent801feb0362b1fb617ebc8b0be5acef69e99f6d7f (diff)
downloadfreebsd-ports-gnome-f1c77bf62fae9c35b8af1d993c00277b5c80860c.tar.gz
freebsd-ports-gnome-f1c77bf62fae9c35b8af1d993c00277b5c80860c.tar.zst
freebsd-ports-gnome-f1c77bf62fae9c35b8af1d993c00277b5c80860c.zip
For the ports that are maintained by ports@ that have pkgconfig as their
only USE_GNOME feature, convert to a BUILD_DEPENDS. This avoids both the bug of the bogus run depend introduced by bsd.gnome.mk, and also avoids needlessly pulling that file in.
Diffstat (limited to 'audio')
-rw-r--r--audio/lv2core/Makefile3
-rw-r--r--audio/slv2/Makefile4
2 files changed, 4 insertions, 3 deletions
diff --git a/audio/lv2core/Makefile b/audio/lv2core/Makefile
index ba8226235614..2a3a6a5d738e 100644
--- a/audio/lv2core/Makefile
+++ b/audio/lv2core/Makefile
@@ -16,9 +16,10 @@ COMMENT= LV2 Core Package
LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/COPYING
+BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
+
USE_BZIP2= yes
USE_PYTHON_BUILD= yes
-USE_GNOME= pkgconfig
MAKE_JOBS_SAFE= yes
.include <bsd.port.pre.mk>
diff --git a/audio/slv2/Makefile b/audio/slv2/Makefile
index cb744d57bcc1..046c2b8b4f5f 100644
--- a/audio/slv2/Makefile
+++ b/audio/slv2/Makefile
@@ -16,13 +16,13 @@ COMMENT= LV2 Application Support Library
LICENSE= GPLv2 # (or later)
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= ${LOCALBASE}/include/lv2.h:${PORTSDIR}/audio/lv2core
+BUILD_DEPENDS= ${LOCALBASE}/include/lv2.h:${PORTSDIR}/audio/lv2core \
+ pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= jack.0:${PORTSDIR}/audio/jack \
rdf.0:${PORTSDIR}/textproc/redland
USE_BZIP2= yes
USE_PYTHON_BUILD= yes
-USE_GNOME= pkgconfig
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes