aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-09-03 17:47:31 +0800
committertijl <tijl@FreeBSD.org>2014-09-03 17:47:31 +0800
commitfb703fad58b592f84c010648954789294f6ee3ba (patch)
tree00c58c6b2c03764bf64dd790d4a53c116f6473b3 /audio
parentb43bbc74a2ffad327a594000046a4b06ca141386 (diff)
downloadfreebsd-ports-gnome-fb703fad58b592f84c010648954789294f6ee3ba.tar.gz
freebsd-ports-gnome-fb703fad58b592f84c010648954789294f6ee3ba.tar.zst
freebsd-ports-gnome-fb703fad58b592f84c010648954789294f6ee3ba.zip
- Add missing -lm
- Add USES=libtool
Diffstat (limited to 'audio')
-rw-r--r--audio/extace/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/audio/extace/Makefile b/audio/extace/Makefile
index 6e55a48ce2c7..e59d0e03940c 100644
--- a/audio/extace/Makefile
+++ b/audio/extace/Makefile
@@ -12,17 +12,17 @@ COMMENT= Audio visualization plugin for the X Window System
LIB_DEPENDS= libfftw3.so:${PORTSDIR}/math/fftw3
-USES= pathfix pkgconfig
+USES= libtool pathfix pkgconfig
USE_GNOME= esound gnomehier gtk20
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib -lm
PLIST_FILES= bin/extace \
share/gnome/apps/Multimedia/extace.desktop
post-patch:
- @${REINPLACE_CMD} -e 's|^CFLAGS=|#CFLAGS=|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|^LIBS =|#LIBS =|g' ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} '/^CFLAGS="-O2/d' ${WRKSRC}/configure
+ @${REINPLACE_CMD} '/^LIBS =/s/$$/ @LIBS@/' ${WRKSRC}/src/Makefile.in
.include <bsd.port.mk>