aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2010-09-28 18:49:27 +0800
committerehaupt <ehaupt@FreeBSD.org>2010-09-28 18:49:27 +0800
commit0e09f8e601eec744a2bdc96f050fe032750da551 (patch)
tree25384064b6c82640f88195995165e110d0f5dc64 /audio
parentcf303d22f5e10675b75c386da434f45749f189d1 (diff)
downloadfreebsd-ports-gnome-0e09f8e601eec744a2bdc96f050fe032750da551.tar.gz
freebsd-ports-gnome-0e09f8e601eec744a2bdc96f050fe032750da551.tar.zst
freebsd-ports-gnome-0e09f8e601eec744a2bdc96f050fe032750da551.zip
Provide patches to make it build on amd64.
Diffstat (limited to 'audio')
-rw-r--r--audio/festalon/Makefile3
-rw-r--r--audio/festalon/files/patch-src__cputest.c48
-rw-r--r--audio/festalon/files/patch-src__filter.h11
3 files changed, 61 insertions, 1 deletions
diff --git a/audio/festalon/Makefile b/audio/festalon/Makefile
index 20003b6f948d..ccf9f1779991 100644
--- a/audio/festalon/Makefile
+++ b/audio/festalon/Makefile
@@ -20,11 +20,12 @@ LIB_DEPENDS+= samplerate.1:${PORTSDIR}/audio/libsamplerate
USE_AUTOTOOLS= libtool:22
USE_BZIP2= yes
+
MAKE_JOBS_SAFE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
-ONLY_FOR_ARCHS= i386 powerpc
+ONLY_FOR_ARCHS= i386 amd64 powerpc
.include <bsd.port.pre.mk>
diff --git a/audio/festalon/files/patch-src__cputest.c b/audio/festalon/files/patch-src__cputest.c
new file mode 100644
index 000000000000..313a06a7d842
--- /dev/null
+++ b/audio/festalon/files/patch-src__cputest.c
@@ -0,0 +1,48 @@
+--- ./src/cputest.c.orig 2005-02-28 01:26:01.000000000 +0100
++++ ./src/cputest.c 2010-09-28 11:21:52.000000000 +0200
+@@ -31,18 +31,33 @@
+ {
+ #ifdef ARCH_X86
+ int rval;
++#ifdef __x86_64__
++ int64_t eax, ebx, ecx, edx;
++#else
+ int eax, ebx, ecx, edx;
++#endif
+ char vendor[13] = "UnknownVndr";
+
+ __asm__ __volatile__ (
+ /* See if CPUID instruction is supported ... */
+ /* ... Get copies of EFLAGS into eax and ecx */
+- "pushf\n\t"
+ #ifdef __x86_64__
++ "pushf\n\t"
++ "pop %0\n\t"
++ "mov %0, %1\n\t"
++
++ /* ... Toggle the ID bit in one copy and store */
++ /* to the EFLAGS reg */
++ "xor $0x200000, %0\n\t"
++ "push %0\n\t"
++ "popf\n\t"
++
++ /* ... Get the (hopefully modified) EFLAGS */
++ "pushf\n\t"
+ "pop %0\n\t"
+ #else
++ "pushf\n\t"
+ "popl %0\n\t"
+-#endif
+ "movl %0, %1\n\t"
+
+ /* ... Toggle the ID bit in one copy and store */
+@@ -53,9 +68,6 @@
+
+ /* ... Get the (hopefully modified) EFLAGS */
+ "pushf\n\t"
+-#ifdef __x86_64__
+- "pop %0\n\t"
+-#else
+ "popl %0\n\t"
+ #endif
+ : "=a" (eax), "=c" (ecx)
diff --git a/audio/festalon/files/patch-src__filter.h b/audio/festalon/files/patch-src__filter.h
new file mode 100644
index 000000000000..d8796d68c072
--- /dev/null
+++ b/audio/festalon/files/patch-src__filter.h
@@ -0,0 +1,11 @@
+--- ./src/filter.h.orig 2010-09-28 11:22:11.000000000 +0200
++++ ./src/filter.h 2010-09-28 11:22:33.000000000 +0200
+@@ -20,6 +20,8 @@
+
+ #ifdef ARCH_X86
+ int16 coeffs_i16[NCOEFFS] __attribute__ ((aligned (8)));
++ #elif __x86_64__
++ int16 coeffs_i16[NCOEFFS] __attribute__ ((aligned (8)));
+ #elif ARCH_POWERPC
+ int16 coeffs_i16[NCOEFFS] __attribute__ ((aligned (16)));
+ #endif