aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authored <ed@FreeBSD.org>2009-03-10 20:11:47 +0800
committered <ed@FreeBSD.org>2009-03-10 20:11:47 +0800
commit0f32421a804600dec9b3d97fdeca0ce853147784 (patch)
tree006a37aa9b403398ffc008ab53eaafb77028c5b3 /audio
parentdecfb9ff026e86c5f7af7985d0acc43df73f689e (diff)
downloadfreebsd-ports-gnome-0f32421a804600dec9b3d97fdeca0ce853147784.tar.gz
freebsd-ports-gnome-0f32421a804600dec9b3d97fdeca0ce853147784.tar.zst
freebsd-ports-gnome-0f32421a804600dec9b3d97fdeca0ce853147784.zip
Unbreak libsndfile build when octave is installed.
If octave is installed on the system, libsndfile wants to build octave support, which only seems to cause compiler errors. If we really want octave support, we should add a proper switch to the port. PR: ports/131647
Diffstat (limited to 'audio')
-rw-r--r--audio/libsndfile/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/audio/libsndfile/Makefile b/audio/libsndfile/Makefile
index 8ff42dfc3acd..eecbadfc7a4b 100644
--- a/audio/libsndfile/Makefile
+++ b/audio/libsndfile/Makefile
@@ -17,7 +17,8 @@ USE_GNOME= gnomehack gnometarget pkgconfig
GNU_CONFIGURE= yes
USE_GMAKE= yes
CONFIGURE_ARGS= --disable-gcc-pipe \
- --disable-sqlite
+ --disable-sqlite \
+ --disable-octave
CONFIGURE_ENV= CPPFLAGS="-isystem /usr/include -isystem ${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
USE_LDCONFIG= yes