aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-06-04 06:31:54 +0800
committerpav <pav@FreeBSD.org>2005-06-04 06:31:54 +0800
commit1131118f9d7877e06f082085410d8de1f593918a (patch)
treecda02560b2558ac5b024f8952e8c8d0e8f6b01f4 /audio
parent54af6f24dc954b8fb0ae6092b4e27ffa26a73cf2 (diff)
downloadfreebsd-ports-gnome-1131118f9d7877e06f082085410d8de1f593918a.tar.gz
freebsd-ports-gnome-1131118f9d7877e06f082085410d8de1f593918a.tar.zst
freebsd-ports-gnome-1131118f9d7877e06f082085410d8de1f593918a.zip
- Update to 1.1.3
PR: ports/81848 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Diffstat (limited to 'audio')
-rw-r--r--audio/ccaudio/Makefile19
-rw-r--r--audio/ccaudio/distinfo4
-rw-r--r--audio/ccaudio/files/patch-config:ltmain.sh15
-rw-r--r--audio/ccaudio/files/patch-src:dtmf.cpp13
-rw-r--r--audio/ccaudio/pkg-descr3
-rw-r--r--audio/ccaudio2/Makefile19
-rw-r--r--audio/ccaudio2/distinfo4
-rw-r--r--audio/ccaudio2/files/patch-config:ltmain.sh15
-rw-r--r--audio/ccaudio2/files/patch-src:dtmf.cpp13
-rw-r--r--audio/ccaudio2/pkg-descr3
10 files changed, 26 insertions, 82 deletions
diff --git a/audio/ccaudio/Makefile b/audio/ccaudio/Makefile
index b7167e530637..d8c3c90b824c 100644
--- a/audio/ccaudio/Makefile
+++ b/audio/ccaudio/Makefile
@@ -6,22 +6,19 @@
#
PORTNAME= ccaudio
-PORTVERSION= 1.1.1
-PORTREVISION= 0
+PORTVERSION= 1.1.3
CATEGORIES= audio
-MASTER_SITES= ${MASTER_SITE_GNU:S/$/:gnu/} \
- ${MASTER_SITE_SOURCEFORGE:S/$/:sf/}
-MASTER_SITE_SUBDIR= ccaudio/:gnu \
- bayonne/:sf
-DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:gnu,sf
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gnutelephony
MAINTAINER= ports@FreeBSD.org
COMMENT= C++ class framework for manipulating audio files
-LIB_DEPENDS= ccgnu2-1.1.0:${PORTSDIR}/devel/commoncpp
+LIB_DEPENDS= ccgnu2-1.2.1:${PORTSDIR}/devel/commoncpp
USE_GNOME= gnometarget
-GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+USE_LIBTOOL_VER= 15
INSTALL_TARGET= install man
INSTALLS_SHLIB= yes
@@ -29,4 +26,8 @@ MAN3= Audio.3cc AudioCodec.3cc AudioCopy.3cc AudioFile.3cc \
AudioSample.3cc AudioTone.3cc CDAudio.3cc DTMFDetect.3cc \
LinearSample.3cc
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|<stdint\.h>|<stdlib.h>|g' ${WRKSRC}/src/dtmf.cpp
+
.include <bsd.port.mk>
diff --git a/audio/ccaudio/distinfo b/audio/ccaudio/distinfo
index 5f87d4edbe3d..4edc1ace2891 100644
--- a/audio/ccaudio/distinfo
+++ b/audio/ccaudio/distinfo
@@ -1,2 +1,2 @@
-MD5 (ccaudio-1.1.1.tar.gz) = 946f04524af6050b104bf40895291921
-SIZE (ccaudio-1.1.1.tar.gz) = 340256
+MD5 (ccaudio-1.1.3.tar.gz) = d8995ab5ed5d4b3817efabf9c151ddfc
+SIZE (ccaudio-1.1.3.tar.gz) = 349183
diff --git a/audio/ccaudio/files/patch-config:ltmain.sh b/audio/ccaudio/files/patch-config:ltmain.sh
deleted file mode 100644
index 2aeb7ae8998b..000000000000
--- a/audio/ccaudio/files/patch-config:ltmain.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- config/ltmain.sh.orig Fri Feb 20 17:25:13 2004
-+++ config/ltmain.sh Fri Feb 20 17:25:25 2004
-@@ -5428,10 +5428,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false ; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/audio/ccaudio/files/patch-src:dtmf.cpp b/audio/ccaudio/files/patch-src:dtmf.cpp
deleted file mode 100644
index 48d1c35a3e3e..000000000000
--- a/audio/ccaudio/files/patch-src:dtmf.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/dtmf.cpp.orig Wed Jul 23 19:52:40 2003
-+++ src/dtmf.cpp Fri Mar 12 09:08:50 2004
-@@ -27,9 +27,9 @@
- //
-
- #include <math.h>
--#include <stdint.h>
- #include <string.h>
- #include <stdio.h>
-+#include <stdlib.h>
- #include <time.h>
- #include <fcntl.h>
- #include "audio.h"
diff --git a/audio/ccaudio/pkg-descr b/audio/ccaudio/pkg-descr
index 0dab234f6115..b98289e9d351 100644
--- a/audio/ccaudio/pkg-descr
+++ b/audio/ccaudio/pkg-descr
@@ -3,5 +3,4 @@ access audio files. This library is optimized for DSP frame presentation
and for merging audio from multiple sources. Support is provided for many
common and popular sound file formats such as .au, .wav/RIFF, etc.
-- David Sugar
-dyfet@gnu.org
+WWW: http://www.gnutelephony.org/
diff --git a/audio/ccaudio2/Makefile b/audio/ccaudio2/Makefile
index b7167e530637..d8c3c90b824c 100644
--- a/audio/ccaudio2/Makefile
+++ b/audio/ccaudio2/Makefile
@@ -6,22 +6,19 @@
#
PORTNAME= ccaudio
-PORTVERSION= 1.1.1
-PORTREVISION= 0
+PORTVERSION= 1.1.3
CATEGORIES= audio
-MASTER_SITES= ${MASTER_SITE_GNU:S/$/:gnu/} \
- ${MASTER_SITE_SOURCEFORGE:S/$/:sf/}
-MASTER_SITE_SUBDIR= ccaudio/:gnu \
- bayonne/:sf
-DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:gnu,sf
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gnutelephony
MAINTAINER= ports@FreeBSD.org
COMMENT= C++ class framework for manipulating audio files
-LIB_DEPENDS= ccgnu2-1.1.0:${PORTSDIR}/devel/commoncpp
+LIB_DEPENDS= ccgnu2-1.2.1:${PORTSDIR}/devel/commoncpp
USE_GNOME= gnometarget
-GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+USE_LIBTOOL_VER= 15
INSTALL_TARGET= install man
INSTALLS_SHLIB= yes
@@ -29,4 +26,8 @@ MAN3= Audio.3cc AudioCodec.3cc AudioCopy.3cc AudioFile.3cc \
AudioSample.3cc AudioTone.3cc CDAudio.3cc DTMFDetect.3cc \
LinearSample.3cc
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|<stdint\.h>|<stdlib.h>|g' ${WRKSRC}/src/dtmf.cpp
+
.include <bsd.port.mk>
diff --git a/audio/ccaudio2/distinfo b/audio/ccaudio2/distinfo
index 5f87d4edbe3d..4edc1ace2891 100644
--- a/audio/ccaudio2/distinfo
+++ b/audio/ccaudio2/distinfo
@@ -1,2 +1,2 @@
-MD5 (ccaudio-1.1.1.tar.gz) = 946f04524af6050b104bf40895291921
-SIZE (ccaudio-1.1.1.tar.gz) = 340256
+MD5 (ccaudio-1.1.3.tar.gz) = d8995ab5ed5d4b3817efabf9c151ddfc
+SIZE (ccaudio-1.1.3.tar.gz) = 349183
diff --git a/audio/ccaudio2/files/patch-config:ltmain.sh b/audio/ccaudio2/files/patch-config:ltmain.sh
deleted file mode 100644
index 2aeb7ae8998b..000000000000
--- a/audio/ccaudio2/files/patch-config:ltmain.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- config/ltmain.sh.orig Fri Feb 20 17:25:13 2004
-+++ config/ltmain.sh Fri Feb 20 17:25:25 2004
-@@ -5428,10 +5428,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false ; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/audio/ccaudio2/files/patch-src:dtmf.cpp b/audio/ccaudio2/files/patch-src:dtmf.cpp
deleted file mode 100644
index 48d1c35a3e3e..000000000000
--- a/audio/ccaudio2/files/patch-src:dtmf.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/dtmf.cpp.orig Wed Jul 23 19:52:40 2003
-+++ src/dtmf.cpp Fri Mar 12 09:08:50 2004
-@@ -27,9 +27,9 @@
- //
-
- #include <math.h>
--#include <stdint.h>
- #include <string.h>
- #include <stdio.h>
-+#include <stdlib.h>
- #include <time.h>
- #include <fcntl.h>
- #include "audio.h"
diff --git a/audio/ccaudio2/pkg-descr b/audio/ccaudio2/pkg-descr
index 0dab234f6115..b98289e9d351 100644
--- a/audio/ccaudio2/pkg-descr
+++ b/audio/ccaudio2/pkg-descr
@@ -3,5 +3,4 @@ access audio files. This library is optimized for DSP frame presentation
and for merging audio from multiple sources. Support is provided for many
common and popular sound file formats such as .au, .wav/RIFF, etc.
-- David Sugar
-dyfet@gnu.org
+WWW: http://www.gnutelephony.org/