aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2002-02-15 00:59:45 +0800
committernaddy <naddy@FreeBSD.org>2002-02-15 00:59:45 +0800
commit1d626a969bdc3d5bbfcfecb62d4c72f1aad6b2d1 (patch)
tree1f42d1627e1bbff4ee70d4d4e53c28d05de7bfbf /audio
parente48946c9a292286bbb1f8b4c3db5c686ce58f9f4 (diff)
downloadfreebsd-ports-gnome-1d626a969bdc3d5bbfcfecb62d4c72f1aad6b2d1.tar.gz
freebsd-ports-gnome-1d626a969bdc3d5bbfcfecb62d4c72f1aad6b2d1.tar.zst
freebsd-ports-gnome-1d626a969bdc3d5bbfcfecb62d4c72f1aad6b2d1.zip
Disable some asserts() that assume implementation characteristics
of glibc iconv().
Diffstat (limited to 'audio')
-rw-r--r--audio/vorbis-tools/Makefile2
-rw-r--r--audio/vorbis-tools/files/patch-share::iconvert.c29
2 files changed, 30 insertions, 1 deletions
diff --git a/audio/vorbis-tools/Makefile b/audio/vorbis-tools/Makefile
index 35428c0f959f..040b291a6d48 100644
--- a/audio/vorbis-tools/Makefile
+++ b/audio/vorbis-tools/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vorbis-tools
PORTVERSION= 1.0.r3
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 2
CATEGORIES= audio
MASTER_SITES= http://www.xiph.org/ogg/vorbis/download/ \
diff --git a/audio/vorbis-tools/files/patch-share::iconvert.c b/audio/vorbis-tools/files/patch-share::iconvert.c
new file mode 100644
index 000000000000..407ea9d47a91
--- /dev/null
+++ b/audio/vorbis-tools/files/patch-share::iconvert.c
@@ -0,0 +1,29 @@
+
+$FreeBSD$
+
+--- share/iconvert.c.orig Wed Dec 19 03:57:31 2001
++++ share/iconvert.c Thu Feb 14 16:52:41 2002
+@@ -105,10 +105,12 @@
+ obl = utflen;
+ for (;;) {
+ k = iconv(cd1, &ib, &ibl, &ob, &obl);
++#if 0 /* mistaken assumptions */
+ assert((!k && !ibl) ||
+ (k == (size_t)(-1) && errno == E2BIG && ibl && obl < 6) ||
+ (k == (size_t)(-1) &&
+ (errno == EILSEQ || errno == EINVAL) && ibl));
++#endif
+ if (!ibl)
+ break;
+ if (obl < 6) {
+@@ -216,8 +218,10 @@
+ }
+ }
+ k = iconv(cd2, 0, 0, &ob, &obl);
++#if 0
+ assert(!k);
+ assert(!obl);
++#endif
+ *ob = '\0';
+
+ free(utfbuf);
>Update to 1.8.2nakai1999-12-286-8/+6 * jade can't work with optimize (like -O2 -mpentium).vanilla1999-12-272-0/+26 * Adding xls2xml version 1.0.0.steve1999-12-279-0/+77 * Adding cole version 2.0.1steve1999-12-277-0/+81 * Adding pstotext version 2.1steve1999-12-271-0/+1 * Adding gtkdiff version 1.0.1.steve1999-12-276-0/+37 * Adding se-ispell version 1.2.1.steve1999-12-277-0/+44 * hevea version 1.04steve1999-12-266-0/+81 * Update to version 0.7.2.steve1999-12-259-19/+26 * Update to 1.8.0nakai1999-12-246-6/+22 * Prefer w3m over lynx, it's table handling is superior.nik1999-12-241-2/+2 * Update to v1.49.kuriyama1999-12-222-5/+5 * Update Maintainer email addressjedgar1999-12-221-1/+1 * Correct MASTER_SITESjedgar1999-12-221-2/+2 * Update to reflect new apache install locations.billf1999-12-112-39/+39 * Put back the dict->cdict change, which was deliberate and requested by thekris1999-12-112-2/+2 * Fix install filename from cdict to dictflathill1999-12-112-2/+2 * Moving tkdiff port from misc to textproc. tkdiff is a Tcl/Tk frontendsteve1999-12-107-0/+42 * Don't install ispell.el - it is already in emacs-20.4 (same author version)jmz1999-12-084-17/+121 * Upgrade to v1.48.kuriyama1999-12-053-33/+51 * New location on MASTER_SITE.steve1999-12-052-2/+2 * Update to 3.1.7.kuriyama1999-12-044-22/+12 * Fix build problems with Gcc 2.95.2 (i.e., 4-CURRENT).obrien1999-12-024-0/+10 * Activate the diffstat port.steve1999-11-271-0/+1 * Initial import of diffstat version 1.27.steve1999-11-277-0/+60 * Update to v1.46.kuriyama1999-11-233-5/+13 * upgrade to 1.1ache1999-11-202-2/+2 * upgrade to 1.0ache1999-11-192-5/+7 * add p5-Text-CSV_XSache1999-11-191-0/+1 * Comma separated values manipulationsache1999-11-195-0/+35 * Don't conflict with dict portkris1999-11-152-2/+2 * Update to version 2.4.steve1999-11-145-27/+58 * Update to 19991105 version of XT.kuriyama1999-11-103-8/+8 * s/MASTER_SITE_CPAN/MASTER_SITE_PERL_CPAN/kuriyama1999-11-101-1/+1 * Activate p5-XML-DOM.kuriyama1999-11-071-0/+1 * Perl module for building DOM Level 1 compliant document structureskuriyama1999-11-075-0/+36 * Update to 0.18.4.kuriyama1999-11-073-541/+219 * Update to v1.5.kuriyama1999-11-073-258/+295 * I forgot to update "Version required" header.kuriyama1999-11-061-1/+1 * Use LIB_DEPENDS not BUILD_DEPENDScpiazza1999-11-061-1/+1 * Update to version 0.14 which makes it compatible with GNU grep 2.3cpiazza1999-11-062-4/+6 * Update to v2.27.kuriyama1999-11-032-5/+7 * Upgrade to v3.1.6.kuriyama1999-11-036-10/+18 * Upgrade to 19991102 version.kuriyama1999-11-032-3/+3 * Update to 0.5.14-bw6cpiazza1999-10-314-6/+6 * Upgrade to 3.1.3billf1999-10-294-108/+52 * Welcome Text::Template, a perl(ick!) module.billf1999-10-281-0/+1 * Import Text::Template v1.20billf1999-10-285-0/+37 * Update to v1.4.kuriyama1999-10-273-67/+248 * Keep an eye on this port.obrien1999-10-271-0/+3 * upgrade to 0.8.7cmharo1999-10-272-4/+13 * Adopt ports I care about.obrien1999-10-261-0/+3 * 19991008 version of XT.kuriyama1999-10-264-7/+9 * Remove josh@quick.net as MAINTAINER. Email to josh@quick.net hasfenner1999-10-222-4/+0 * Remove "tcs".kuriyama1999-10-191-1/+0 * Activate tcs.kuriyama1999-10-191-0/+1 * Update to version 0.13cpiazza1999-10-162-4/+4 * Catch up to moving directory of java/jfc.kuriyama1999-10-161-3/+1 * Minor update:jmz1999-10-163-6/+21 * PR: ports/14303nakai1999-10-148-12/+20 * Remove a dead MASTER_SITE and update the WWW entry in the DESCR file.steve1999-10-112-4/+2 * Activate xpcpiazza1999-10-061-0/+1 * XP is an XML 1.0 parser written in Java. It is fully conforming: itcpiazza1999-10-065-0/+263 * Activate code2htmldan1999-10-031-0/+1 * Welcome code2html into its new (and rightful) home in textproc. Code2htmldan1999-10-035-0/+44 * Added "%%LOCALBASE%%/share/mule/info" into site-start.eltaoka1999-09-291-0/+1 * Update {java,perl}2html to 0.6.3dan1999-09-284-4/+4 * Update c2html to version 0.6.3dan1999-09-282-2/+2 * preserve file modesache1999-09-271-1/+1 * For some reason with the latest libtool this port no longer builds itssteve1999-09-201-0/+1 * Remove .depend in post-extract because trap.h doesn't exist on FreeBSD/Alphasteve1999-09-201-0/+3 * Update to version 0.12.cpiazza1999-09-202-5/+6 * Update master site.wosch1999-09-191-1/+1 * Update to version 2.0.steve1999-09-194-10/+65 * Enforce random pkg/COMMENT rules, including the one that states Emacshoek1999-09-181-1/+1 * Resolve many 301 Moved Permanently URLs in DESCR.fenner1999-09-181-1/+1 * Fix categories after repo-copy (I could have sworn I had done this...)cpiazza1999-09-181-1/+1 * Activate lattecpiazza1999-09-101-0/+1 * Import of latte.cpiazza1999-09-105-0/+143 * Upgrade to 1.1.1.tg1999-09-092-4/+4 * Update MAINTAINER's email addresscpiazza1999-09-091-1/+1 * Upgrade to 7.53, and as a result, unbreak.max1999-09-084-30/+24 * Distfile changed, update checksum.tg1999-09-071-1/+1 * Upgrade to v3.1.5.kuriyama1999-09-064-10/+10 * Upgrade to v2.26.kuriyama1999-09-063-4/+12 * Upgrade to v2.0.15.kuriyama1999-09-063-4/+160 * sar->sarepache1999-09-041-1/+1 * upgrade to sarep-0.5ache1999-09-044-15/+14 * Add WWW:dirk1999-09-032-0/+4 * Upgrade to 3.0.8.tg1999-08-312-3/+3 * FreeBSD.ORG -> FreeBSD.orgmharo1999-08-3126-38/+38 * $Id$ -> $FreeBSD$peter1999-08-3171-71/+71 * Use RUN_DEPENDS, not BUILD_DEPENDS.kuriyama1999-08-281-2/+2 * env -> ${SETENV}mharo1999-08-282-4/+4 * echo -> ${ECHO} or ${ECHO_MSG} and in some cases, move echo stuffmharo1999-08-286-25/+25 * echo -> ${ECHO} or ${ECHO_MSG} and in some cases, move echo stuffmharo1999-08-281-1/+1 * Update to version 0.28.2.1cpiazza1999-08-275-28/+88 * Add catalog file for package.kuriyama1999-08-271-1/+1 * Upgrade to v1.44.kuriyama1999-08-262-6/+6 * Upgrade to v2.0.14.kuriyama1999-08-263-22/+66 * Add expat.dirk1999-08-261-1/+2 * Initial import of expat, adirk1999-08-2611-0/+104 * Change Id->FreeBSD.obrien1999-08-251-1/+1 * Upgrade to 0.90.3, which is really change for the sake of change for us.billf1999-08-252-3/+3 * Upgrade to 19990822 version.kuriyama1999-08-242-4/+4 * awk -> ${AWK}mharo1999-08-231-2/+2 * Change all ports that need a new gcc on 3.x to use USE_NEWGCC.cpiazza1999-08-231-9/+3 * chmod -> ${CHMOD}mharo1999-08-2310-28/+28 * Update to version 1.4.0.steve1999-08-228-62/+42 * Fix a typo (psttoimg -> pstoimg).cpiazza1999-08-211-2/+2 * Upgrade to v1.43.kuriyama1999-08-203-35/+40 * Update to 19990813 version (without changing DISTNAME).kuriyama1999-08-193-4/+5 * Change MAINTAINER: josh@quick.net -> ade@lovett.comsheldonh1999-08-191-2/+2 * egcc/eg++ have been renamed to gcc295/g++295. Changecpiazza1999-08-181-5/+5 * Mail to the maintainer's address bounces. Assign to ports@freebsd.org .sheldonh1999-08-171-2/+2 * Portlint.jmz1999-08-131-1/+0 * Use MLINKS for buildhash.1, findaffix.1, munchlist.1, tryaffix.1 and unsq.1jmz1999-08-131-16/+16 * Use lynx instead of lynx-current.cpiazza1999-08-071-2/+2 * Re-enforce caps, no period. An "exceptions" file has been createdhoek1999-08-031-1/+1 * Use -pthread not -libc_rbillf1999-08-021-0/+90 * Activate randcpiazza1999-08-011-1/+2 * Import of rand, a cat-like utility that displays the lines of a filecpiazza1999-08-015-0/+29 * Update to version 0.95b.steve1999-08-013-5/+9 * Upgrade to v0.17.4 and sort PLIST.kuriyama1999-07-313-248/+393 * Update 0.10 -> 0.11:sheldonh1999-07-302-4/+4 * Upgrade to v2.0.13.kuriyama1999-07-303-238/+137 * upgrade to 0.10jmg1999-07-302-4/+4 * Upgrade to 1.1.0.tg1999-07-292-7/+7 * Replace the MASTER_SITE which I removed after using a stupid browser tosheldonh1999-07-291-2/+3 * make this port build by upgrading to 0.9jmg1999-07-292-4/+4 * Upgrade 0.7 -> 0.8:sheldonh1999-07-282-6/+5 * Upgrade 0.3 -> 0.7:sheldonh1999-07-272-6/+5 * Update to version 0.5.14-bw2.obrien1999-07-244-6/+8 * Activate gdict.kris1999-07-221-1/+2 * GTK app which queries a dictionary server and returns a word definition.kris1999-07-228-0/+96 * Update to 19990708 version (without changing DISTNAME).kuriyama1999-07-202-4/+4 * Add WWW:. Reference fmt(1). Minor reformatting to keep this within 24 lines.hoek1999-07-171-5/+8 * Activate freegrep.sheldonh1999-07-081-1/+2 * Import Jamie Howard's grep(1) implementation under BSD-friendly licensesheldonh1999-07-086-0/+42 * Updgrade to 1.42.kuriyama1999-07-073-12/+18 * Don't be verbose for ``make fetch''.obrien1999-07-061-2/+2 * On the Alpha nsgmls coredumps while building the documentation for thissteve1999-07-052-2/+10 * Make this quieter on the simple ``make fetch''.obrien1999-07-051-2/+4 * Fix instances of "This is ...."hoek1999-07-031-1/+1 * Fix a probrem which occurs if you specify WRKDIRPREFIX variable.sada1999-07-021-7/+11 * 100% pure Java publishing framework servletkuriyama1999-07-016-0/+230 * Activate cocoon.kuriyama1999-07-011-1/+2 * new ports/{java,irc,x11-server}, dependency sweep #2billf1999-06-292-4/+4 * Change /usr/local/bin/perl to ${PERL} for all cases that are needed.cpiazza1999-06-291-1/+7 * Change latex2html to use ${PERL} instead of /usr/local/bin/perl.cpiazza1999-06-281-1/+4 * Remove trailing spaces, and any periods that were hidden by them.hoek1999-06-281-1/+1 * Upgrade to v2.0.11.kuriyama1999-06-272-8/+6 * Fix some 80+ character COMMENTs that turned-up in the recent pkg/COMMENThoek1999-06-271-1/+1 * #4/4 enforcing Caps, no periodhoek1999-06-2728-28/+28 * XSLT (XSL Transformations) implementation.kuriyama1999-06-256-0/+547 * Activate lotusxsl.kuriyama1999-06-251-1/+2 * XSL Transformations (XSLT) implementation in Java.kuriyama1999-06-246-0/+68 * Activate xt.kuriyama1999-06-241-1/+2 * Fix fof jdk1.1.8.kuriyama1999-06-231-2/+2 * egcs barfs when desctructors take arguments.steve1999-06-231-0/+11 * s/String/string/g so this builds again.steve1999-06-232-0/+22 * Add more MASTER_SITEs, clean up a extra '\' that no-one noticed, clean upbillf1999-06-163-5/+9 * Upgrade to 0.5.14, which now (regretfully) adds a X dependency.billf1999-06-166-16/+56 * Add docbook-310 to catalog list.shige1999-06-151-5/+11 * Fix shared library problem (soname not specified).chuckr1999-06-131-1/+1 * Upgrade to v3.1.4.kuriyama1999-06-124-12/+12 * The jfc port has moved from devel to lang.steve1999-06-101-2/+2 * Bump the version number to reflect the changed dependencies.nik1999-06-091-2/+2 * Did you know that there exists http://www.DocBook.org/ ? However, it ishoek1999-06-081-0/+3 * Get this to build again on -current boxes with egcs.steve1999-06-071-0/+11 * Activate the perl2html port.steve1999-06-071-1/+2 * Initial import of perl2html version 0.6.1.steve1999-06-076-0/+66 * Remove the test to create ${PREFIX}/share/info/dir as it is nowmharo1999-06-066-15/+3 * Upgrade to 0.90.2, add MASTER_SITE_TEX_CTAN, try some logic with thebillf1999-06-052-5/+14 * Depend on the textproc/docbook meta-port, instead of explicitly listingnik1999-06-041-2/+2 * Add WWW:hoek1999-06-031-0/+2 * Take over as maintainer.chuckr1999-06-031-2/+2 * Update sp port to 1.3. Changing the format a bit, too. John Fieber,chuckr1999-06-038-16/+207 * Upgrade to version 3.1.2billf1999-06-012-5/+8 * Upgrade to v3.1.3.kuriyama1999-05-314-12/+12 * Update to version 0.6.1.steve1999-05-293-10/+10 * Update to version 0.6.1.steve1999-05-293-15/+10 * Add more MASTER_SITES entries and add python to CATEGORIESnectar1999-05-291-3/+7 * Activate py-mx{DateTime,Stack,TextTools,Tools}.tg1999-05-261-1/+2 * New port py-mxTextTools, some tools for fast text processing in Python.tg1999-05-266-0/+95 * WWW homepage has changed.kuriyama1999-05-242-3/+3 * XML for Java parser.kuriyama1999-05-215-0/+770 * Activate xml4j.kuriyama1999-05-211-1/+2 * Upgrade to v2.23.kuriyama1999-05-203-5/+12 * Moved textproc/tuc to converters/tuctaoka1999-05-191-2/+1 * Update to 2.22 to fix checksum mismatch.asami1999-05-112-5/+6 * update to version 0.5mharo1999-05-073-9/+14 * nclayton -> nik in the MAINTAINER line. That'll teach me to preparenik1999-05-063-8/+8 * Update to version 0.5.steve1999-05-054-15/+14 * Upgrade to 2.20.tg1999-05-042-4/+4 * Remove EXTRACT_SUFX and BUILD_DEPENDS, and add USE_ZIP instead. Correctnik1999-05-031-4/+3 * Add BUILD_DEPENDS=unzip and some fixes.kuriyama1999-05-031-3/+5 * I *LOVE* WWW:mharo1999-05-03