aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2005-07-20 04:56:50 +0800
committerkrion <krion@FreeBSD.org>2005-07-20 04:56:50 +0800
commit20644c3db7826e75b56f3aabe2a5c4248694d547 (patch)
treea6ceb8e0e1f66c7f8f2c9eae1902dd83e287e4b8 /audio
parenta6bb4dbf65bd81820b4d96722b8fa38abe0097b1 (diff)
downloadfreebsd-ports-gnome-20644c3db7826e75b56f3aabe2a5c4248694d547.tar.gz
freebsd-ports-gnome-20644c3db7826e75b56f3aabe2a5c4248694d547.tar.zst
freebsd-ports-gnome-20644c3db7826e75b56f3aabe2a5c4248694d547.zip
Add libmikmod support by default.
OPTIONize. PR: ports/82671 Submitted by: Ports Fury
Diffstat (limited to 'audio')
-rw-r--r--audio/sdl_mixer/Makefile30
1 files changed, 20 insertions, 10 deletions
diff --git a/audio/sdl_mixer/Makefile b/audio/sdl_mixer/Makefile
index 9c7daf3a17d9..d914c2185684 100644
--- a/audio/sdl_mixer/Makefile
+++ b/audio/sdl_mixer/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sdl_mixer
PORTVERSION= 1.2.6
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://www.libsdl.org/projects/SDL_mixer/release/
DISTNAME= SDL_mixer-${PORTVERSION}
@@ -14,11 +15,7 @@ DISTNAME= SDL_mixer-${PORTVERSION}
MAINTAINER= krion@FreeBSD.org
COMMENT= A sample multi-channel audio mixer library
-LIB_DEPENDS= vorbis.3:${PORTSDIR}/audio/libvorbis \
- smpeg.1:${PORTSDIR}/multimedia/smpeg
-
USE_SDL= sdl
-USE_REINPLACE= yes
USE_GMAKE= yes
USE_LIBTOOL_VER=15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
@@ -26,15 +23,28 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
INSTALLS_SHLIB= yes
+OPTIONS= MIKMOD "Enable MOD music via libMikMod" on \
+ VORBIS "Enable Ogg Vorbis music" on \
+ SMPEG "Enable MP3 music via SMPEG" on
+
.include <bsd.port.pre.mk>
-.if defined(WITH_MIKMOD)
-LIB_DEPENDS+= mikmod.2:${PORTSDIR}/audio/libmikmod
+.if defined(WITHOUT_MIKMOD)
+CONFIGURE_ARGS+= --disable-music-libmikmod
+.else
+LIB_DEPENDS= mikmod.2:${PORTSDIR}/audio/libmikmod
.endif
-post-configure:
- @${REINPLACE_CMD} -e \
- 's|^deplibs_check_method=.*|deplibs_check_method=pass_all|' \
- ${WRKSRC}/libtool
+.if defined(WITHOUT_VORBIS)
+CONFIGURE_ARGS+= --disable-music-ogg
+.else
+LIB_DEPENDS+= vorbis.3:${PORTSDIR}/audio/libvorbis
+.endif
+
+.if defined(WITHOUT_SMPEG)
+CONFIGURE_ARGS+= --disable-music-mp3
+.else
+LIB_DEPENDS+= smpeg.1:${PORTSDIR}/multimedia/smpeg
+.endif
.include <bsd.port.post.mk>