aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-06-29 03:41:21 +0800
committerjylefort <jylefort@FreeBSD.org>2005-06-29 03:41:21 +0800
commit46d6f7c1173c14ae9455c40ccf45781e2ea9c3cc (patch)
tree037d88687b02064004a5c98fc142205fb0cde67d /audio
parenta83cd4864639739f0f8f4acbe5329d8858c30747 (diff)
downloadfreebsd-ports-gnome-46d6f7c1173c14ae9455c40ccf45781e2ea9c3cc.tar.gz
freebsd-ports-gnome-46d6f7c1173c14ae9455c40ccf45781e2ea9c3cc.tar.zst
freebsd-ports-gnome-46d6f7c1173c14ae9455c40ccf45781e2ea9c3cc.zip
Add xmms-xymms.
XymMS is an XMMS input plugin capable of playing Sega Genesis GYM files by rendering FM, DAC, and PSG signals through emulation of the YM2612 and SN76496 sound chips found in the video game console. It supports zlib compression and decompression, and other various settings for output quality, etc. You can compress and decompress files along with updating ID tags using the File Info window. WWW: http://sourceforge.net/projects/xymms/ PR: ports/82697 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/xmms-xymms/Makefile39
-rw-r--r--audio/xmms-xymms/distinfo2
-rw-r--r--audio/xmms-xymms/pkg-descr11
-rw-r--r--audio/xmms-xymms/pkg-message3
5 files changed, 56 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 8eaf68695e02..268dfb604a17 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -548,6 +548,7 @@
SUBDIR += xmms-volnorm
SUBDIR += xmms-wma
SUBDIR += xmms-xf86audio
+ SUBDIR += xmms-xymms
SUBDIR += xmp
SUBDIR += xmpeg3
SUBDIR += xmradio
diff --git a/audio/xmms-xymms/Makefile b/audio/xmms-xymms/Makefile
new file mode 100644
index 000000000000..3840a0d96d64
--- /dev/null
+++ b/audio/xmms-xymms/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: xmms-xymms
+# Date created: 27 Jun 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xymms
+DISTVERSION= 0.9.1
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= xmms-
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= Sega Genesis GYM plugin for XMMS
+
+BUILD_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
+RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
+
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+USE_INC_LIBTOOL_VER=13
+USE_GNOME= gtk12
+
+CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" LDFLAGS="${PTHREAD_LIBS}"
+
+PLIST_FILES= lib/xmms/Input/libxymms.so %%EXAMPLESDIR%%/sample.gym
+PLIST_DIRS= %%EXAMPLESDIR%%
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-D_REENTRANT||' ${WRKSRC}/src/Makefile.in
+
+post-install:
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/samples/sample.gym ${EXAMPLESDIR}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/audio/xmms-xymms/distinfo b/audio/xmms-xymms/distinfo
new file mode 100644
index 000000000000..bff630d55530
--- /dev/null
+++ b/audio/xmms-xymms/distinfo
@@ -0,0 +1,2 @@
+MD5 (xymms-0.9.1.tar.gz) = 12124425a66ea127b21ea7f291ba34dc
+SIZE (xymms-0.9.1.tar.gz) = 199645
diff --git a/audio/xmms-xymms/pkg-descr b/audio/xmms-xymms/pkg-descr
new file mode 100644
index 000000000000..cd2d63603a1a
--- /dev/null
+++ b/audio/xmms-xymms/pkg-descr
@@ -0,0 +1,11 @@
+XymMS is an XMMS input plugin capable of playing Sega Genesis GYM files by
+rendering FM, DAC, and PSG signals through emulation of the YM2612 and SN76496
+sound chips found in the video game console. It supports zlib compression and
+decompression, and other various settings for output quality, etc. You can
+compress and decompress files along with updating ID tags using the File Info
+window.
+
+WWW: http://sourceforge.net/projects/xymms/
+
+- ehaupt
+ehaupt@critical.ch
diff --git a/audio/xmms-xymms/pkg-message b/audio/xmms-xymms/pkg-message
new file mode 100644
index 000000000000..4824c4dfb78e
--- /dev/null
+++ b/audio/xmms-xymms/pkg-message
@@ -0,0 +1,3 @@
+===============================================================================
+Additional .gym files can be found at http://www.zophar.net/gym/
+===============================================================================