aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorchinsan <chinsan@FreeBSD.org>2008-01-26 11:01:59 +0800
committerchinsan <chinsan@FreeBSD.org>2008-01-26 11:01:59 +0800
commit512b13e721726945a1c90241cb692406c325dfc1 (patch)
tree356b9642ac67c68abb423c8c3703f2c082d5945e /audio
parentbd5603f83d66ca2229b415c6c74a1761dc7c7552 (diff)
downloadfreebsd-ports-gnome-512b13e721726945a1c90241cb692406c325dfc1.tar.gz
freebsd-ports-gnome-512b13e721726945a1c90241cb692406c325dfc1.tar.zst
freebsd-ports-gnome-512b13e721726945a1c90241cb692406c325dfc1.zip
dir2ogg is a python script which converts mp3, m4a, wma and wav files into
OGG Vorbis format. It was inspired by the perl script mp32ogg. WWW: http://jak-linux.org/projects/dir2ogg/
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/dir2ogg/Makefile47
-rw-r--r--audio/dir2ogg/distinfo3
-rw-r--r--audio/dir2ogg/pkg-descr4
4 files changed, 55 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 0367829fd510..617a910b7d79 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -112,6 +112,7 @@
SUBDIR += dekagen
SUBDIR += denemo
SUBDIR += dino
+ SUBDIR += dir2ogg
SUBDIR += discid
SUBDIR += dream
SUBDIR += drumpiler
diff --git a/audio/dir2ogg/Makefile b/audio/dir2ogg/Makefile
new file mode 100644
index 000000000000..d3a5d6bc4ffa
--- /dev/null
+++ b/audio/dir2ogg/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: dir2ogg
+# Date created: 2008/01/26
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= dir2ogg
+PORTVERSION= 0.11.1
+CATEGORIES= audio
+MASTER_SITES= http://jak-linux.org/projects/dir2ogg/0.11/ \
+ LOCAL/chinsan
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Command-line {wav,mp3,m4a} to ogg converter
+
+RUN_DEPENDS= faad:${PORTSDIR}/audio/faad \
+ mutagen-inspect:${PORTSDIR}/audio/py-mutagen \
+ mplayer:${PORTSDIR}/multimedia/mplayer
+
+USE_PYTHON= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/dir2ogg
+.if !defined(NOPORTDOCS)
+PLIST_DIRS= ${DOCSDIR_REL}
+PLIST_FILES+= ${DOCSDIR_REL}/README \
+ ${DOCSDIR_REL}/NEWS
+.endif
+
+DOCS= README NEWS
+MAN1= dir2ogg.1
+
+post-patch:
+ @${REINPLACE_CMD} -e '1 s/python/env python/' ${WRKSRC}/dir2ogg
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/dir2ogg ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/dir2ogg.1 ${MAN1PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/dir2ogg/distinfo b/audio/dir2ogg/distinfo
new file mode 100644
index 000000000000..407fae678d96
--- /dev/null
+++ b/audio/dir2ogg/distinfo
@@ -0,0 +1,3 @@
+MD5 (dir2ogg-0.11.1.tar.gz) = 67fe28061c1759eb5dd8a867a152ad74
+SHA256 (dir2ogg-0.11.1.tar.gz) = d917bdc501e73e690ac931978323b4dc432ee5aa64a1be19a5c24cd3a85b73c4
+SIZE (dir2ogg-0.11.1.tar.gz) = 18468
diff --git a/audio/dir2ogg/pkg-descr b/audio/dir2ogg/pkg-descr
new file mode 100644
index 000000000000..13978992428b
--- /dev/null
+++ b/audio/dir2ogg/pkg-descr
@@ -0,0 +1,4 @@
+dir2ogg is a python script which converts mp3, m4a, wma and wav files into
+OGG Vorbis format. It was inspired by the perl script mp32ogg.
+
+WWW: http://jak-linux.org/projects/dir2ogg/