aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2007-03-29 20:53:34 +0800
committerehaupt <ehaupt@FreeBSD.org>2007-03-29 20:53:34 +0800
commit6428ab0aeda45cc83c1a1ec931c9b4b4aab002df (patch)
tree57873f85ca3b141003051277d47be540164a2f3a /audio
parent39b49e297af006116ff7a1e93f514fc7edd09cf9 (diff)
downloadfreebsd-ports-gnome-6428ab0aeda45cc83c1a1ec931c9b4b4aab002df.tar.gz
freebsd-ports-gnome-6428ab0aeda45cc83c1a1ec931c9b4b4aab002df.tar.zst
freebsd-ports-gnome-6428ab0aeda45cc83c1a1ec931c9b4b4aab002df.zip
- Cleanup objformat-removal fallout
- Use USE_LDCONFIG instead of INSTALLS_SHLIB Approved by: portmgr (pav; implicit)
Diffstat (limited to 'audio')
-rw-r--r--audio/xmms-real-random/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/audio/xmms-real-random/Makefile b/audio/xmms-real-random/Makefile
index 9935e5f756ea..207db4c3297b 100644
--- a/audio/xmms-real-random/Makefile
+++ b/audio/xmms-real-random/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms
USE_GMAKE= yes
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
USE_X_PREFIX= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
@@ -31,5 +31,6 @@ PLIST_FILES= lib/xmms/General/libreal_random.la \
post-patch:
@${REINPLACE_CMD} -e 's#-lpthread#${PTHREAD_LIBS}#' \
-e 's#gcc#$${CC}#' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/objformat=/s|=.*|=elf|' ${WRKSRC}/configure
.include <bsd.port.mk>