aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2013-06-03 02:07:32 +0800
committermva <mva@FreeBSD.org>2013-06-03 02:07:32 +0800
commit6da288e4174d5c20555e54ec224bb6b19522f84d (patch)
tree3d7b312a7855214188aaf26f1654622b36972108 /audio
parent6f5b0aac4093ff9aeabf9995b1d881fb29cf709a (diff)
downloadfreebsd-ports-gnome-6da288e4174d5c20555e54ec224bb6b19522f84d.tar.gz
freebsd-ports-gnome-6da288e4174d5c20555e54ec224bb6b19522f84d.tar.zst
freebsd-ports-gnome-6da288e4174d5c20555e54ec224bb6b19522f84d.zip
- Fix broken patch from ports/178343, which might lead to broken OSS output
PR: ports/178895 Submitted by: Green Dog <fiziologus@gmail.com>
Diffstat (limited to 'audio')
-rw-r--r--audio/openal-soft/Makefile2
-rw-r--r--audio/openal-soft/files/patch-Alc-ALu.c4
2 files changed, 3 insertions, 3 deletions
diff --git a/audio/openal-soft/Makefile b/audio/openal-soft/Makefile
index 6a55639cc575..50029de5059f 100644
--- a/audio/openal-soft/Makefile
+++ b/audio/openal-soft/Makefile
@@ -2,7 +2,7 @@
PORTNAME= openal-soft
PORTVERSION= 1.15.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://kcat.strangesoft.net/openal-releases/
diff --git a/audio/openal-soft/files/patch-Alc-ALu.c b/audio/openal-soft/files/patch-Alc-ALu.c
index 5e673f703562..75b767f31d96 100644
--- a/audio/openal-soft/files/patch-Alc-ALu.c
+++ b/audio/openal-soft/files/patch-Alc-ALu.c
@@ -26,12 +26,12 @@
{ return aluF2I(val)+2147483648u; }
static __inline ALshort aluF2S(ALfloat val)
-{ return aluF2I(val)>>16; }
-+{ return aluF2I(val)>>9; }
++{ return aluF2I25(val)>>9; }
static __inline ALushort aluF2US(ALfloat val)
{ return aluF2S(val)+32768; }
static __inline ALbyte aluF2B(ALfloat val)
-{ return aluF2I(val)>>24; }
-+{ return aluF2I(val)>>17; }
++{ return aluF2I25(val)>>17; }
static __inline ALubyte aluF2UB(ALfloat val)
{ return aluF2B(val)+128; }