aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2015-09-11 03:42:05 +0800
committernaddy <naddy@FreeBSD.org>2015-09-11 03:42:05 +0800
commit6eea0a44a6d3230486980f164591082134c18dda (patch)
tree816e8e25fc4ab8a77472a952d93290805b5a440f /audio
parent933f4bc8fd16662d3442694d2f8638ef22d8587a (diff)
downloadfreebsd-ports-gnome-6eea0a44a6d3230486980f164591082134c18dda.tar.gz
freebsd-ports-gnome-6eea0a44a6d3230486980f164591082134c18dda.tar.zst
freebsd-ports-gnome-6eea0a44a6d3230486980f164591082134c18dda.zip
Fix oggenc crash on raw file close, channel integer overflow, and
division by zero. PR: 202941 Submitted by: junovitch Obtained from: https://trac.xiph.org/changeset/19117 Obtained from: Fedora vorbis-tools Git (commit 63a1a62d) Security: CVE-2014-9638 Security: CVE-2014-9639 Security: a35f415d-572a-11e5-b0a4-f8b156b6dcc8 MFH: 2015Q3
Diffstat (limited to 'audio')
-rw-r--r--audio/vorbis-tools/Makefile2
-rw-r--r--audio/vorbis-tools/files/patch-oggenc_audio.c62
-rw-r--r--audio/vorbis-tools/files/patch-oggenc_oggenc.c21
3 files changed, 82 insertions, 3 deletions
diff --git a/audio/vorbis-tools/Makefile b/audio/vorbis-tools/Makefile
index 9a480815f3c2..bb1963fb2e87 100644
--- a/audio/vorbis-tools/Makefile
+++ b/audio/vorbis-tools/Makefile
@@ -3,7 +3,7 @@
PORTNAME= vorbis-tools
PORTVERSION= 1.4.0
-PORTREVISION= 9
+PORTREVISION= 10
PORTEPOCH= 3
CATEGORIES= audio
MASTER_SITES= http://downloads.xiph.org/releases/vorbis/
diff --git a/audio/vorbis-tools/files/patch-oggenc_audio.c b/audio/vorbis-tools/files/patch-oggenc_audio.c
index 067475093247..2a68741017fb 100644
--- a/audio/vorbis-tools/files/patch-oggenc_audio.c
+++ b/audio/vorbis-tools/files/patch-oggenc_audio.c
@@ -1,6 +1,14 @@
--- oggenc/audio.c.orig 2010-03-24 08:27:14 UTC
+++ oggenc/audio.c
-@@ -245,8 +245,8 @@ static int aiff_permute_matrix[6][6] =
+@@ -13,6 +13,7 @@
+ #include <config.h>
+ #endif
+
++#include <limits.h>
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
+@@ -245,12 +246,13 @@ static int aiff_permute_matrix[6][6] =
int aiff_open(FILE *in, oe_enc_opt *opt, unsigned char *buf, int buflen)
{
int aifc; /* AIFC or AIFF? */
@@ -11,7 +19,12 @@
unsigned char buf2[8];
aiff_fmt format;
aifffile *aiff = malloc(sizeof(aifffile));
-@@ -269,9 +269,9 @@ int aiff_open(FILE *in, oe_enc_opt *opt,
+ int i;
++ long channels;
+
+ if(buf[11]=='C')
+ aifc=1;
+@@ -269,19 +271,25 @@ int aiff_open(FILE *in, oe_enc_opt *opt,
return 0; /* Weird common chunk */
}
@@ -24,3 +37,48 @@
{
fprintf(stderr, _("Warning: Unexpected EOF in reading AIFF header\n"));
return 0;
+ }
+
+- format.channels = READ_U16_BE(buffer);
++ format.channels = channels = READ_U16_BE(buffer);
+ format.totalframes = READ_U32_BE(buffer+2);
+ format.samplesize = READ_U16_BE(buffer+6);
+ format.rate = (int)read_IEEE80(buffer+8);
+
++ if(channels <= 0L || SHRT_MAX < channels)
++ {
++ fprintf(stderr, _("Warning: Unsupported count of channels in AIFF header\n"));
++ return 0;
++ }
++
+ aiff->bigendian = 1;
+
+ if(aifc)
+@@ -412,6 +420,7 @@ int wav_open(FILE *in, oe_enc_opt *opt,
+ wav_fmt format;
+ wavfile *wav = malloc(sizeof(wavfile));
+ int i;
++ long channels;
+
+ /* Ok. At this point, we know we have a WAV file. Now we have to detect
+ * whether we support the subtype, and we have to find the actual data
+@@ -449,12 +458,18 @@ int wav_open(FILE *in, oe_enc_opt *opt,
+ }
+
+ format.format = READ_U16_LE(buf);
+- format.channels = READ_U16_LE(buf+2);
++ format.channels = channels = READ_U16_LE(buf+2);
+ format.samplerate = READ_U32_LE(buf+4);
+ format.bytespersec = READ_U32_LE(buf+8);
+ format.align = READ_U16_LE(buf+12);
+ format.samplesize = READ_U16_LE(buf+14);
+
++ if(channels <= 0L || SHRT_MAX < channels)
++ {
++ fprintf(stderr, _("Warning: Unsupported count of channels in WAV header\n"));
++ return 0;
++ }
++
+ if(format.format == -2) /* WAVE_FORMAT_EXTENSIBLE */
+ {
+ if(len<40)
diff --git a/audio/vorbis-tools/files/patch-oggenc_oggenc.c b/audio/vorbis-tools/files/patch-oggenc_oggenc.c
new file mode 100644
index 000000000000..2ae1d255f2b3
--- /dev/null
+++ b/audio/vorbis-tools/files/patch-oggenc_oggenc.c
@@ -0,0 +1,21 @@
+--- oggenc/oggenc.c.orig 2010-03-26 07:07:07 UTC
++++ oggenc/oggenc.c
+@@ -97,6 +97,8 @@ int main(int argc, char **argv)
+ .3,-1,
+ 0,0,0.f,
+ 0, 0, 0, 0, 0};
++ input_format raw_format = {NULL, 0, raw_open, wav_close, "raw",
++ N_("RAW file reader")};
+
+ int i;
+
+@@ -239,9 +241,6 @@ int main(int argc, char **argv)
+
+ if(opt.rawmode)
+ {
+- input_format raw_format = {NULL, 0, raw_open, wav_close, "raw",
+- N_("RAW file reader")};
+-
+ enc_opts.rate=opt.raw_samplerate;
+ enc_opts.channels=opt.raw_channels;
+ enc_opts.samplesize=opt.raw_samplesize;