aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2004-05-15 00:38:09 +0800
committerlofi <lofi@FreeBSD.org>2004-05-15 00:38:09 +0800
commit787580556ea5ff93c9dbf44de8340383813da9c3 (patch)
treee47b2c0070e5a4f2c33949373298a1582b505c68 /audio
parent62531af818a5bdc91689e6e20e85cbc29ec90bd3 (diff)
downloadfreebsd-ports-gnome-787580556ea5ff93c9dbf44de8340383813da9c3.tar.gz
freebsd-ports-gnome-787580556ea5ff93c9dbf44de8340383813da9c3.tar.zst
freebsd-ports-gnome-787580556ea5ff93c9dbf44de8340383813da9c3.zip
Enforce linking against a threads lib on -STABLE.
Diffstat (limited to 'audio')
-rw-r--r--audio/libshout2/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/audio/libshout2/Makefile b/audio/libshout2/Makefile
index 5ddeb2b6fa43..1152aeed3e9c 100644
--- a/audio/libshout2/Makefile
+++ b/audio/libshout2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libshout2
PORTVERSION= 2.0
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= audio net
MASTER_SITES= http://www.icecast.org/files/libshout/
@@ -27,6 +27,16 @@ USE_LIBTOOL_VER=13
CONFLICTS= libshout-1.0.7
USE_REINPLACE= yes
+.include <bsd.port.pre.mk>
+
+## Megacrude hack to make the shared lib link against libc_r on -STABLE.
+## If anybody finds a way to do it with -pthread, let me know.
+
+.if ${OSVERSION} < 500016
+CONFIGURE_ENV= CFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-lc_r -L${LOCALBASE}/lib"
+.endif
+
pre-configure:
@ ${REINPLACE_CMD} -e "s|-ffast-math||g" ${WRKSRC}/configure
@@ -34,4 +44,4 @@ post-configure:
@ ${REINPLACE_CMD} -e "s|pkgconfigdir =.*|pkgconfigdir = ${PREFIX}/libdata/pkgconfig|g" \
${WRKSRC}/Makefile
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>