aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2008-03-13 22:51:35 +0800
committerpav <pav@FreeBSD.org>2008-03-13 22:51:35 +0800
commit7e76bfa607f9d2fa62c03bcd588019d0d4cff0d9 (patch)
tree67f27f2b9a17469980263bd5cbb7f75886caf5f1 /audio
parente274bddea42e147890f6df87da4071402fc07bb2 (diff)
downloadfreebsd-ports-gnome-7e76bfa607f9d2fa62c03bcd588019d0d4cff0d9.tar.gz
freebsd-ports-gnome-7e76bfa607f9d2fa62c03bcd588019d0d4cff0d9.tar.zst
freebsd-ports-gnome-7e76bfa607f9d2fa62c03bcd588019d0d4cff0d9.zip
gbemol is a graphical frontend for the Music Player Daemon (MPD) it is
written in C and uses the GTK+ toolkit for it's interface. WWW: http://gbemol.sourceforge.net/ PR: ports/120960 Submitted by: Thomas M. Hermann <tmh.public@gmail.com>
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/gbemol/Makefile29
-rw-r--r--audio/gbemol/distinfo3
-rw-r--r--audio/gbemol/pkg-descr4
-rw-r--r--audio/gbemol/pkg-plist4
5 files changed, 41 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 373bc2a14785..b3263497c7e0 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -187,6 +187,7 @@
SUBDIR += funktrackergold
SUBDIR += gai-album
SUBDIR += gai-visual-audio
+ SUBDIR += gbemol
SUBDIR += gbsplay
SUBDIR += gdam
SUBDIR += gdrdao
diff --git a/audio/gbemol/Makefile b/audio/gbemol/Makefile
new file mode 100644
index 000000000000..86ddd7b559f8
--- /dev/null
+++ b/audio/gbemol/Makefile
@@ -0,0 +1,29 @@
+# New ports collection Makefile for: gbemol
+# Date created: 2008-02-21
+# Whom: Thomas M. Hermann <tmh.public@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gbemol
+PORTVERSION= 0.3.1
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= tmh.public@gmail.com
+COMMENT= Graphical frontend for the Music Player Daemon
+
+LIB_DEPENDS= mpd:${PORTSDIR}/audio/libmpd \
+ curl.4:${PORTSDIR}/ftp/curl \
+ xml2.5:${PORTSDIR}/textproc/libxml2
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gtk20
+
+post-patch:
+ @${CHMOD} a+x ${WRKSRC}/install-sh
+ @${REINPLACE_CMD} -e 's,$$(DATADIRNAME)/locale,share/locale,' ${WRKSRC}/po/Makefile.in.in
+
+.include <bsd.port.mk>
diff --git a/audio/gbemol/distinfo b/audio/gbemol/distinfo
new file mode 100644
index 000000000000..351d58c40315
--- /dev/null
+++ b/audio/gbemol/distinfo
@@ -0,0 +1,3 @@
+MD5 (gbemol-0.3.1.tar.gz) = 640e26c7455f9201807ca658ef28885f
+SHA256 (gbemol-0.3.1.tar.gz) = d11cddd1564cc2cf855e88cbaee15d4c702b1dced580033d7f8262fe5ff009e0
+SIZE (gbemol-0.3.1.tar.gz) = 438656
diff --git a/audio/gbemol/pkg-descr b/audio/gbemol/pkg-descr
new file mode 100644
index 000000000000..4774a44b861a
--- /dev/null
+++ b/audio/gbemol/pkg-descr
@@ -0,0 +1,4 @@
+gbemol is a graphical frontend for the Music Player Daemon (MPD) it is
+written in C and uses the GTK+ toolkit for it's interface.
+
+WWW: http://gbemol.sourceforge.net/
diff --git a/audio/gbemol/pkg-plist b/audio/gbemol/pkg-plist
new file mode 100644
index 000000000000..b2ab696356c0
--- /dev/null
+++ b/audio/gbemol/pkg-plist
@@ -0,0 +1,4 @@
+bin/gbemol
+share/pixmaps/gbemol.png
+share/applications/gbemol.desktop
+@dirrmtry share/applications