aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2006-04-06 14:29:24 +0800
committermi <mi@FreeBSD.org>2006-04-06 14:29:24 +0800
commit7fb14cbd342ebd6aaee908f9782d4b5faa17596c (patch)
tree4df71dce974b01f85718bb93d10cb84d267aea08 /audio
parent70d21fad95bab001de07fbef00bba494dc6a2a38 (diff)
downloadfreebsd-ports-gnome-7fb14cbd342ebd6aaee908f9782d4b5faa17596c.tar.gz
freebsd-ports-gnome-7fb14cbd342ebd6aaee908f9782d4b5faa17596c.tar.zst
freebsd-ports-gnome-7fb14cbd342ebd6aaee908f9782d4b5faa17596c.zip
Do not run-depend on festival -- it really ought to be the other way
around. For festlex-cmu use the 2004 version found in the 1.95 directory, so that it works with audio/festival. The others did not change since 1999. Stop the silly practice of extracting into ${WRKDIR} and copying into destination -- extract directly. Replace @dirrm with @dirrmtry in a few places and unbreak by adding more of same. The same should be applied to other audio/fest* ports, but these are enough to get the English-only speech out of festival.
Diffstat (limited to 'audio')
-rw-r--r--audio/festlex-cmu/Makefile15
-rw-r--r--audio/festlex-cmu/distinfo8
-rw-r--r--audio/festlex-cmu/pkg-plist6
-rw-r--r--audio/festlex-poslex/Makefile14
-rw-r--r--audio/festlex-poslex/pkg-plist2
-rw-r--r--audio/festvox-kal16/Makefile12
-rw-r--r--audio/festvox-kal16/pkg-plist4
7 files changed, 21 insertions, 40 deletions
diff --git a/audio/festlex-cmu/Makefile b/audio/festlex-cmu/Makefile
index 2558d6d07b48..6e4201cb314f 100644
--- a/audio/festlex-cmu/Makefile
+++ b/audio/festlex-cmu/Makefile
@@ -8,30 +8,21 @@
#
PORTNAME= festlex-cmu
-PORTVERSION= 1.4.1
+PORTVERSION= 1.95
CATEGORIES= audio accessibility
MASTER_SITES= ${MASTER_SITE_FESTIVAL}
MASTER_SITE_SUBDIR= ${PORTVERSION}
DISTNAME= festlex_CMU
DIST_SUBDIR= festival
+EXTRACT_ONLY=
MAINTAINER= ports@FreeBSD.org
COMMENT= CMU American English pronunciation dictionary for Festival
-RUN_DEPENDS= festival:${PORTSDIR}/audio/festival
-
-WRKSRC= ${WRKDIR}/festival
-
NO_BUILD= yes
-
FHOME= ${PREFIX}/share/festival
-post-extract:
- @ ${CHMOD} -R a+r ${WRKSRC}
- @ ${FIND} ${WRKSRC} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
-
do-install:
- ${MKDIR} ${FHOME}
- cd ${WRKSRC} && ${CP} -pPR * ${FHOME}
+ ${TAR} -C ${FHOME:H} -xzvpf ${_DISTDIR}/${_DISTFILES}
.include <bsd.port.mk>
diff --git a/audio/festlex-cmu/distinfo b/audio/festlex-cmu/distinfo
index 18578e80d9c6..0c594698997a 100644
--- a/audio/festlex-cmu/distinfo
+++ b/audio/festlex-cmu/distinfo
@@ -1,5 +1,3 @@
-$NetBSD: md5,v 1.2 1999/10/11 16:30:53 proff Exp $
-
-MD5 (festival/festlex_CMU.tar.gz) = a3ffcd09dcbf1306fdef3c84c1c521d6
-SIZE (festival/festlex_CMU.tar.gz) = 1697709
-SHA256 (festival/festlex_CMU.tar.gz) = b485c1e8e8e265e335aa99f083963496fa64b34a314050b10d589e942e10c963
+MD5 (festival/festlex_CMU.tar.gz) = 86a765c48d6b64134b28af45affec1bf
+SHA256 (festival/festlex_CMU.tar.gz) = 507295934b4e205bcd242e0d56c15ee9b8a9401ad4ee6796d998ba2e40be4693
+SIZE (festival/festlex_CMU.tar.gz) = 1749300
diff --git a/audio/festlex-cmu/pkg-plist b/audio/festlex-cmu/pkg-plist
index f710a8721ded..a55bed3bef4f 100644
--- a/audio/festlex-cmu/pkg-plist
+++ b/audio/festlex-cmu/pkg-plist
@@ -8,5 +8,7 @@ share/festival/lib/dicts/cmu/cmudict-0.4.diff
share/festival/lib/dicts/cmu/cmu2ft
share/festival/lib/dicts/cmu/cmudict_extensions.scm
share/festival/lib/dicts/cmu/COPYING
-@dirrm share/festival/lib/dicts/cmu
-@dirrm share/festival/lib/dicts
+@dirrmtry share/festival/lib/dicts/cmu
+@dirrmtry share/festival/lib/dicts
+@dirrmtry share/festival/lib
+@dirrmtry share/festival
diff --git a/audio/festlex-poslex/Makefile b/audio/festlex-poslex/Makefile
index 78e8995be899..c736909f2727 100644
--- a/audio/festlex-poslex/Makefile
+++ b/audio/festlex-poslex/Makefile
@@ -9,29 +9,21 @@
PORTNAME= festlex-poslex
PORTVERSION= 1.4.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio accessibility
MASTER_SITES= ${MASTER_SITE_FESTIVAL}
MASTER_SITE_SUBDIR= ${PORTVERSION}
DISTNAME= festlex_POSLEX
DIST_SUBDIR= festival
+EXTRACT_ONLY=
MAINTAINER= ports@FreeBSD.org
COMMENT= English lexicon for Festival
-RUN_DEPENDS= festival:${PORTSDIR}/audio/festival
-
-WRKSRC= ${WRKDIR}/festival
-
NO_BUILD= yes
-
FHOME= ${PREFIX}/share/festival
-post-extract:
- @ ${CHMOD} -R a+r ${WRKSRC}
- @ ${FIND} ${WRKSRC} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
-
do-install:
- cd ${WRKSRC} && ${CP} -pPR * ${FHOME}
+ ${TAR} -C ${FHOME:H} -xzvpf ${_DISTDIR}/${_DISTFILES}
.include <bsd.port.mk>
diff --git a/audio/festlex-poslex/pkg-plist b/audio/festlex-poslex/pkg-plist
index b93e5a39d1a9..a1d4453e0cbf 100644
--- a/audio/festlex-poslex/pkg-plist
+++ b/audio/festlex-poslex/pkg-plist
@@ -3,3 +3,5 @@ share/festival/lib/dicts/wsj.wp39.poslexR
share/festival/lib/dicts/wsj.wp39.tri.ngrambin
share/festival/lib/dicts/COPYING.poslex
@dirrmtry share/festival/lib/dicts
+@dirrmtry share/festival/lib
+@dirrmtry share/festival
diff --git a/audio/festvox-kal16/Makefile b/audio/festvox-kal16/Makefile
index b8c51cacaac6..c14fc635c370 100644
--- a/audio/festvox-kal16/Makefile
+++ b/audio/festvox-kal16/Makefile
@@ -14,6 +14,7 @@ MASTER_SITES= ${MASTER_SITE_FESTIVAL}
MASTER_SITE_SUBDIR= 1.4.1
DISTNAME= festvox_kallpc16k
DIST_SUBDIR= festival
+EXTRACT_ONLY=
MAINTAINER= ports@FreeBSD.org
COMMENT= American English male voice, sampled at 16 kHz, for Festival
@@ -22,22 +23,13 @@ RUN_DEPENDS= \
${LOCALBASE}/share/festival/lib/dicts/wsj.wp39.poslexR:${PORTSDIR}/audio/festlex-poslex \
${LOCALBASE}/share/festival/lib/dicts/cmu/cmulex.scm:${PORTSDIR}/audio/festlex-cmu
-BROKEN= Incomplete pkg-plist
-
-WRKSRC= ${WRKDIR}/festival
-
CONFLICTS= festvox-kal8-*
NO_BUILD= yes
FHOME= ${PREFIX}/share/festival
-post-extract:
- @ ${CHMOD} -R a+r ${WRKSRC}
- @ ${FIND} ${WRKSRC} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
-
do-install:
- ${MKDIR} ${FHOME}
- cd ${WRKSRC} && ${CP} -pPR * ${FHOME}
+ ${TAR} -C ${FHOME:H} -xvzpf ${_DISTDIR}/${_DISTFILES}
.include <bsd.port.mk>
diff --git a/audio/festvox-kal16/pkg-plist b/audio/festvox-kal16/pkg-plist
index dfd696b86aec..2299a8f2cf25 100644
--- a/audio/festvox-kal16/pkg-plist
+++ b/audio/festvox-kal16/pkg-plist
@@ -6,3 +6,7 @@ share/festival/lib/voices/english/kal_diphone/festvox/kal_diphone.scm
share/festival/lib/voices/english/kal_diphone/festvox/kaldurtreeZ.scm
@dirrm share/festival/lib/voices/english/kal_diphone/festvox
@dirrm share/festival/lib/voices/english/kal_diphone
+@dirrmtry share/festival/lib/voices/english
+@dirrmtry share/festival/lib/voices
+@dirrmtry share/festival/lib
+@dirrmtry share/festival