aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>2000-03-07 19:39:46 +0800
committertg <tg@FreeBSD.org>2000-03-07 19:39:46 +0800
commit8a4649ddce0e2bb060a286d504e473dd38677c68 (patch)
tree43ae151758e169448a92893bc0e368f353fef485 /audio
parent0b1ef35242e198196c3cfe6f520b83e90c2c10b2 (diff)
downloadfreebsd-ports-gnome-8a4649ddce0e2bb060a286d504e473dd38677c68.tar.gz
freebsd-ports-gnome-8a4649ddce0e2bb060a286d504e473dd38677c68.tar.zst
freebsd-ports-gnome-8a4649ddce0e2bb060a286d504e473dd38677c68.zip
New port pysol-sound-server. Despite its name, it's a rather generic
Python extension module that plays WAVs together with MP3 or MOD background music. PR: 16608 Submitted by: Maxim Sobolev <sobomax@altavista.net>
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/pysol-sound-server/Makefile22
-rw-r--r--audio/pysol-sound-server/distinfo1
-rw-r--r--audio/pysol-sound-server/files/patch-aa13
-rw-r--r--audio/pysol-sound-server/pkg-comment1
-rw-r--r--audio/pysol-sound-server/pkg-descr7
-rw-r--r--audio/pysol-sound-server/pkg-plist1
7 files changed, 46 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 0ec39f977835..c291a53405a4 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -56,6 +56,7 @@
SUBDIR += nspmod
SUBDIR += play
SUBDIR += playmidi
+ SUBDIR += pysol-sound-server
SUBDIR += radio
SUBDIR += raproxy
SUBDIR += replay
diff --git a/audio/pysol-sound-server/Makefile b/audio/pysol-sound-server/Makefile
new file mode 100644
index 000000000000..ce5d26df0214
--- /dev/null
+++ b/audio/pysol-sound-server/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: pysol-sound-server
+# Version required: 2.10
+# Date created: 7 January 2000
+# Whom: Maxim Sobolev
+#
+# $FreeBSD$
+#
+
+DISTNAME= pysol-sound-server-2.10
+CATEGORIES= audio games
+MASTER_SITES= http://wildsau.idv.uni-linz.ac.at/mfx/download/pysol/pysol-sound-server/
+
+MAINTAINER= sobomax@altavista.net
+
+LIB_DEPENDS= SDL-1.0.2:${PORTSDIR}/devel/sdl \
+ smpeg-0.3.0:${PORTSDIR}/graphics/smpeg
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= X11BASE="${X11BASE}"
+
+.include <bsd.port.mk>
diff --git a/audio/pysol-sound-server/distinfo b/audio/pysol-sound-server/distinfo
new file mode 100644
index 000000000000..d8921daa36f5
--- /dev/null
+++ b/audio/pysol-sound-server/distinfo
@@ -0,0 +1 @@
+MD5 (pysol-sound-server-2.10.tar.gz) = 65d3ec95166707fe9e97d863e038b245
diff --git a/audio/pysol-sound-server/files/patch-aa b/audio/pysol-sound-server/files/patch-aa
new file mode 100644
index 000000000000..b0135171bf20
--- /dev/null
+++ b/audio/pysol-sound-server/files/patch-aa
@@ -0,0 +1,13 @@
+--- configure.orig Tue Feb 1 01:08:47 2000
++++ configure Tue Feb 1 01:13:24 2000
+@@ -5,8 +5,8 @@
+ SDL_CFLAGS=`$SDL_CONFIG --cflags`
+ SDL_LIBS=`$SDL_CONFIG --libs`
+
+-SMPEG_CFLAGS=""
+-SMPEG_LIBS="-lsmpeg"
++SMPEG_CFLAGS="-I""$X11BASE""/include"
++SMPEG_LIBS="-L""$X11BASE""/lib -lsmpeg"
+
+ sed -e "s|@SDL_VERSION@|$SDL_VERSION|g" -e "s|@SDL_CFLAGS@|$SDL_CFLAGS|g" -e "s|@SDL_LIBS@|$SDL_LIBS|g" -e "s|@SMPEG_CFLAGS@|$SMPEG_CFLAGS|g" -e "s|@SMPEG_LIBS@|$SMPEG_LIBS|g" < Setup.pre.in > Setup.in
+
diff --git a/audio/pysol-sound-server/pkg-comment b/audio/pysol-sound-server/pkg-comment
new file mode 100644
index 000000000000..542eaba834d2
--- /dev/null
+++ b/audio/pysol-sound-server/pkg-comment
@@ -0,0 +1 @@
+Python extension module to play sounds and background music
diff --git a/audio/pysol-sound-server/pkg-descr b/audio/pysol-sound-server/pkg-descr
new file mode 100644
index 000000000000..bb29c4002c10
--- /dev/null
+++ b/audio/pysol-sound-server/pkg-descr
@@ -0,0 +1,7 @@
+A Python extension module that plays WAV samples together with MP3
+or MOD background music.
+
+- Maxim Sobolev
+sobomax@altavista.net
+
+WWW: http://pysol.tsx.org/
diff --git a/audio/pysol-sound-server/pkg-plist b/audio/pysol-sound-server/pkg-plist
new file mode 100644
index 000000000000..2df268a835eb
--- /dev/null
+++ b/audio/pysol-sound-server/pkg-plist
@@ -0,0 +1 @@
+lib/python1.5/site-packages/pysolsoundservermodule.so