aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-07-28 23:36:22 +0800
committerpav <pav@FreeBSD.org>2004-07-28 23:36:22 +0800
commit8fb0b3f2f3ec0260329718a75bce150a0d19943d (patch)
treeff98e212e33d9c9836a39a29010c161f9b7fe7d2 /audio
parent0c69888fe962c7d1d80dd3c3156a3b7634dcd9d4 (diff)
downloadfreebsd-ports-gnome-8fb0b3f2f3ec0260329718a75bce150a0d19943d.tar.gz
freebsd-ports-gnome-8fb0b3f2f3ec0260329718a75bce150a0d19943d.tar.zst
freebsd-ports-gnome-8fb0b3f2f3ec0260329718a75bce150a0d19943d.zip
Add musicbox-tag-editor, a really simple Gtk2 mp3 tag editor.
-tag-editor suffix is added to binary to differentiate it from already existing audio/musicbox. PR: ports/69637 Submitted by: Jean-Yves Lefort <jylefort@brutele.be>
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/musicbox-tag-editor/Makefile33
-rw-r--r--audio/musicbox-tag-editor/distinfo2
-rw-r--r--audio/musicbox-tag-editor/pkg-descr7
-rw-r--r--audio/musicbox-tag-editor/pkg-plist6
5 files changed, 49 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index cb484a241ee8..73ad5eaae17d 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -236,6 +236,7 @@
SUBDIR += muse
SUBDIR += musepack
SUBDIR += musicbox
+ SUBDIR += musicbox-tag-editor
SUBDIR += musicbrainz
SUBDIR += musiccontrol
SUBDIR += musicpd
diff --git a/audio/musicbox-tag-editor/Makefile b/audio/musicbox-tag-editor/Makefile
new file mode 100644
index 000000000000..847ac8adef83
--- /dev/null
+++ b/audio/musicbox-tag-editor/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: MusicBox
+# Date created: 26 Jul 2004
+# Whom: Jean-Yves Lefort <jylefort@brutele.be>
+#
+# $FreeBSD$
+#
+
+PORTNAME= musicbox-tag-editor
+PORTVERSION= 0.2.3
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= musicbox
+DISTNAME= musicbox-${PORTVERSION}
+
+MAINTAINER= jylefort@brutele.be
+COMMENT= A simple GTK+ audio tag editor
+
+LIB_DEPENDS= tag:${PORTSDIR}/audio/taglib
+
+USE_X_PREFIX= yes
+USE_GNOME= gnomehack gnomeprefix libglade2
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+# do not conflict with audio/musicbox
+CONFIGURE_ARGS= --program-suffix=-tag-editor
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/share/pixmaps|${PREFIX}/share/gnome/pixmaps|' ${WRKSRC}/data/musicbox.glade
+ @${REINPLACE_CMD} -e 's|Exec=musicbox|Exec=musicbox-tag-editor|' ${WRKSRC}/data/musicbox.desktop
+
+.include <bsd.port.mk>
diff --git a/audio/musicbox-tag-editor/distinfo b/audio/musicbox-tag-editor/distinfo
new file mode 100644
index 000000000000..f32a13e5ee80
--- /dev/null
+++ b/audio/musicbox-tag-editor/distinfo
@@ -0,0 +1,2 @@
+MD5 (musicbox-0.2.3.tar.gz) = 03f9eb2c446debd1e187d472c05dcad8
+SIZE (musicbox-0.2.3.tar.gz) = 96339
diff --git a/audio/musicbox-tag-editor/pkg-descr b/audio/musicbox-tag-editor/pkg-descr
new file mode 100644
index 000000000000..cdeeb91a7ffb
--- /dev/null
+++ b/audio/musicbox-tag-editor/pkg-descr
@@ -0,0 +1,7 @@
+Musicbox is a simple one-file-at-a-time audio tag editor. It can edit
+ID3, Vorbis and FLAC tags via the TagLib library.
+
+WWW: http://projects.subpop.net/musicbox/
+
+- Jean-Yves Lefort
+jylefort@brutele.be
diff --git a/audio/musicbox-tag-editor/pkg-plist b/audio/musicbox-tag-editor/pkg-plist
new file mode 100644
index 000000000000..a1562c726020
--- /dev/null
+++ b/audio/musicbox-tag-editor/pkg-plist
@@ -0,0 +1,6 @@
+bin/musicbox-tag-editor
+share/gnome/applications/musicbox.desktop
+share/gnome/musicbox/edit.pl
+share/gnome/musicbox/musicbox.glade
+share/gnome/pixmaps/musicbox.png
+@dirrm share/gnome/musicbox