aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2010-04-11 14:45:51 +0800
committerstas <stas@FreeBSD.org>2010-04-11 14:45:51 +0800
commit91057de6e13443a98d9f8d691f964b5f577aadac (patch)
treec7a65224c7a8cd86dcc5bad20cadd74f832d3f14 /audio
parent69b5f41a7f8bf23b844ed5ccba375f105aba4496 (diff)
downloadfreebsd-ports-gnome-91057de6e13443a98d9f8d691f964b5f577aadac.tar.gz
freebsd-ports-gnome-91057de6e13443a98d9f8d691f964b5f577aadac.tar.zst
freebsd-ports-gnome-91057de6e13443a98d9f8d691f964b5f577aadac.zip
- Fix build.
Diffstat (limited to 'audio')
-rw-r--r--audio/muse/Makefile4
-rw-r--r--audio/muse/files/patch-src::jmixer.cpp9
2 files changed, 0 insertions, 13 deletions
diff --git a/audio/muse/Makefile b/audio/muse/Makefile
index dcc629b6e566..915a6afa30d3 100644
--- a/audio/muse/Makefile
+++ b/audio/muse/Makefile
@@ -35,10 +35,6 @@ OPTIONS= X11 "Build with X11 support" on \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 800501
-BROKEN= does not build
-.endif
-
.if defined(WITHOUT_X11)
PKGNAMESUFFIX= -nox11
CONFIGURE_ARGS+=--without-x --with-rubik
diff --git a/audio/muse/files/patch-src::jmixer.cpp b/audio/muse/files/patch-src::jmixer.cpp
index 3a4c6ab41341..bd8ef1fd8ff0 100644
--- a/audio/muse/files/patch-src::jmixer.cpp
+++ b/audio/muse/files/patch-src::jmixer.cpp
@@ -25,12 +25,3 @@
#include <sys/types.h>
#include <sys/wait.h>
#include <termios.h>
-@@ -640,7 +640,7 @@
- /* this is the function selecting files for the scandir
- on freebsd systems you should change the following line to:
- int selector(struct dirent *dir) { */
--int selector(const struct dirent *dir) {
-+int selector(struct dirent *dir) {
- if( strncasecmp(dir->d_name+strlen(dir->d_name)-4,".mp3",4)==0
- #ifdef HAVE_VORBIS
- || strncasecmp(dir->d_name+strlen(dir->d_name)-4,".ogg",4)==0