aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-03-07 02:44:46 +0800
committermiwi <miwi@FreeBSD.org>2007-03-07 02:44:46 +0800
commit97837c9bdfc70b5ce8b40f3a3be0c6672ad50f94 (patch)
treeeeae89db6d3692891ec001c375e77037b3e57df1 /audio
parent4426a18db4396ab17d264822f24c9f25d1241576 (diff)
downloadfreebsd-ports-gnome-97837c9bdfc70b5ce8b40f3a3be0c6672ad50f94.tar.gz
freebsd-ports-gnome-97837c9bdfc70b5ce8b40f3a3be0c6672ad50f94.tar.zst
freebsd-ports-gnome-97837c9bdfc70b5ce8b40f3a3be0c6672ad50f94.zip
Specimen is an open source, MIDI controllable audio sampler. Features include:
- Up to 64 patches with 8 notes of polyphony each - Fast, high quality pitch scaling - Linear ADSR volume envelopes - MIDI/jack-transport syncable LFOs - Low pass filter with resonance - A variety of direction-independent playback modes - A zoomable sample editor for loop and play points - Portamento WWW: http://zhevny.com/specimen/ PR: ports/109986 Submitted by: trasz <trasz at pin.if.uz.zgora.pl>
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/specimen/Makefile26
-rw-r--r--audio/specimen/distinfo3
-rw-r--r--audio/specimen/files/patch-configure10
-rw-r--r--audio/specimen/files/patch-src-Makefile.in40
-rw-r--r--audio/specimen/files/patch-src-driver.c12
-rw-r--r--audio/specimen/files/patch-src-specimen.c17
-rw-r--r--audio/specimen/pkg-descr12
-rw-r--r--audio/specimen/pkg-plist9
9 files changed, 130 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 20b03e333351..6d7d363f070d 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -581,6 +581,7 @@
SUBDIR += soundtouch
SUBDIR += soundtracker
SUBDIR += sox
+ SUBDIR += specimen
SUBDIR += speex
SUBDIR += sphinx
SUBDIR += spiralloops
diff --git a/audio/specimen/Makefile b/audio/specimen/Makefile
new file mode 100644
index 000000000000..1ba57c08eb98
--- /dev/null
+++ b/audio/specimen/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: specimen
+# Date created: 2007-03-06
+# Whom: trasz <trasz@pin.if.uz.zgora.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= specimen
+DISTVERSION= 0.5.2-rc1
+CATEGORIES= audio
+MASTER_SITES= http://zhevny.com/specimen/files/
+
+MAINTAINER= trasz@pin.if.uz.zgora.pl
+COMMENT= MIDI controllable audio sampler
+
+LIB_DEPENDS= phat.0:${PORTSDIR}/x11-toolkits/phat \
+ jack.0:${PORTSDIR}/audio/jack \
+ samplerate.1:${PORTSDIR}/audio/libsamplerate \
+ sndfile.1:${PORTSDIR}/audio/libsndfile \
+ lash.2:${PORTSDIR}/audio/lash
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= libxml2 libgnomecanvas
+
+.include <bsd.port.mk>
diff --git a/audio/specimen/distinfo b/audio/specimen/distinfo
new file mode 100644
index 000000000000..60e3391896eb
--- /dev/null
+++ b/audio/specimen/distinfo
@@ -0,0 +1,3 @@
+MD5 (specimen-0.5.2-rc1.tar.gz) = b2e1c0b1f78f3c4b465f2afcbd7e6066
+SHA256 (specimen-0.5.2-rc1.tar.gz) = fc6cb639fde03aa7f6c4bf4892ef71a06d907b7f0052aba3cb0ea25c2b3b3517
+SIZE (specimen-0.5.2-rc1.tar.gz) = 264412
diff --git a/audio/specimen/files/patch-configure b/audio/specimen/files/patch-configure
new file mode 100644
index 000000000000..62ab2a4fd4bc
--- /dev/null
+++ b/audio/specimen/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Tue Feb 6 23:13:49 2007
++++ configure Tue Mar 6 13:02:40 2007
+@@ -6276,6 +6276,7 @@
+
+ # print build summary
+
++config_error=no
+
+ # are we good to go?
+
diff --git a/audio/specimen/files/patch-src-Makefile.in b/audio/specimen/files/patch-src-Makefile.in
new file mode 100644
index 000000000000..5843c306faa4
--- /dev/null
+++ b/audio/specimen/files/patch-src-Makefile.in
@@ -0,0 +1,40 @@
+--- src/Makefile.in.orig Tue Feb 6 23:13:50 2007
++++ src/Makefile.in Tue Mar 6 13:07:39 2007
+@@ -51,9 +51,9 @@
+ am__installdirs = "$(DESTDIR)$(bindir)"
+ binPROGRAMS_INSTALL = $(INSTALL_PROGRAM)
+ PROGRAMS = $(bin_PROGRAMS)
+-am_specimen_OBJECTS = alsadriver.$(OBJEXT) jackdriver.$(OBJEXT) \
++am_specimen_OBJECTS = jackdriver.$(OBJEXT) \
+ mixer.$(OBJEXT) sample.$(OBJEXT) driver.$(OBJEXT) \
+- midi.$(OBJEXT) patch.$(OBJEXT) specimen.$(OBJEXT) \
++ patch.$(OBJEXT) specimen.$(OBJEXT) \
+ beef.$(OBJEXT) maths.$(OBJEXT) ticks.$(OBJEXT) adsr.$(OBJEXT) \
+ lfo.$(OBJEXT) sync.$(OBJEXT) lashdriver.$(OBJEXT)
+ specimen_OBJECTS = $(am_specimen_OBJECTS)
+@@ -189,8 +189,8 @@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+ SUBDIRS = gui
+-specimen_SOURCES = alsadriver.c jackdriver.c mixer.c mixer.h sample.c \
+-sample.h driver.c driver.h midi.c midi.h patch.c patch.h specimen.c \
++specimen_SOURCES = jackdriver.c mixer.c mixer.h sample.c \
++sample.h driver.c driver.h midi.h patch.c patch.h specimen.c \
+ specimen.h beef.c beef.h maths.c maths.h ticks.c ticks.h adsr.c adsr.h \
+ lfo.c lfo.h sync.c sync.h control.h lashdriver.h lashdriver.c
+
+@@ -301,14 +301,12 @@
+ -rm -f *.tab.c
+
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/adsr.Po@am__quote@
+-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/alsadriver.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/beef.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/driver.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/jackdriver.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/lashdriver.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/lfo.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/maths.Po@am__quote@
+-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/midi.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/mixer.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/patch.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/sample.Po@am__quote@
diff --git a/audio/specimen/files/patch-src-driver.c b/audio/specimen/files/patch-src-driver.c
new file mode 100644
index 000000000000..e33df591f271
--- /dev/null
+++ b/audio/specimen/files/patch-src-driver.c
@@ -0,0 +1,12 @@
+--- src/driver.c.orig Tue Mar 6 13:09:22 2007
++++ src/driver.c Tue Mar 6 13:09:35 2007
+@@ -7,8 +7,7 @@
+
+ /* available drivers */
+ extern Driver jack_driver;
+-extern Driver alsa_driver;
+-static Driver* drivers[] = { &jack_driver, &alsa_driver, NULL };
++static Driver* drivers[] = { &jack_driver, NULL };
+
+ /* number of drivers available (we set this var in driver_init ( ) */
+ static int ndrivers = 0;
diff --git a/audio/specimen/files/patch-src-specimen.c b/audio/specimen/files/patch-src-specimen.c
new file mode 100644
index 000000000000..f6999f9ac981
--- /dev/null
+++ b/audio/specimen/files/patch-src-specimen.c
@@ -0,0 +1,17 @@
+--- src/specimen.c.orig Tue Mar 6 13:10:22 2007
++++ src/specimen.c Tue Mar 6 13:10:29 2007
+@@ -48,14 +48,12 @@
+ }
+
+ /* start */
+- midi_start();
+ driver_start(0, forced_instance_name);
+ lashdriver_start();
+
+ gtk_main();
+
+ /* stop */
+- midi_stop();
+ driver_stop();
+
+ /* destructors */
diff --git a/audio/specimen/pkg-descr b/audio/specimen/pkg-descr
new file mode 100644
index 000000000000..f0b54f5facf0
--- /dev/null
+++ b/audio/specimen/pkg-descr
@@ -0,0 +1,12 @@
+Specimen is an open source, MIDI controllable audio sampler. Features include:
+
+ - Up to 64 patches with 8 notes of polyphony each
+ - Fast, high quality pitch scaling
+ - Linear ADSR volume envelopes
+ - MIDI/jack-transport syncable LFOs
+ - Low pass filter with resonance
+ - A variety of direction-independent playback modes
+ - A zoomable sample editor for loop and play points
+ - Portamento
+
+WWW: http://zhevny.com/specimen/
diff --git a/audio/specimen/pkg-plist b/audio/specimen/pkg-plist
new file mode 100644
index 000000000000..7bed850585d9
--- /dev/null
+++ b/audio/specimen/pkg-plist
@@ -0,0 +1,9 @@
+bin/specimen
+%%DATADIR%%/pixmaps/open.png
+%%DATADIR%%/pixmaps/play.png
+%%DATADIR%%/pixmaps/stop.png
+%%DATADIR%%/pixmaps/panic.png
+%%DATADIR%%/pixmaps/specimen.png
+%%DATADIR%%/pixmaps/specimen_small.png
+@dirrm %%DATADIR%%/pixmaps
+@dirrm %%DATADIR%%