aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2017-08-12 23:56:09 +0800
committerriggs <riggs@FreeBSD.org>2017-08-12 23:56:09 +0800
commita08ed5bb3bd46059cba2f7e3d2791c920c2daa80 (patch)
treedd2a1c8c335dcb2319328356d15e8ec177b42171 /audio
parentcfd88fdb922f74bf51ecc854a52dd42b38b8f885 (diff)
downloadfreebsd-ports-gnome-a08ed5bb3bd46059cba2f7e3d2791c920c2daa80.tar.gz
freebsd-ports-gnome-a08ed5bb3bd46059cba2f7e3d2791c920c2daa80.tar.zst
freebsd-ports-gnome-a08ed5bb3bd46059cba2f7e3d2791c920c2daa80.zip
New port: audio/py-gmusicproxy streams from Google Play Music to any player
PR: 220363 Submitted by: erisianash@gmail.com (maintainer)
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/py-gmusicproxy/Makefile31
-rw-r--r--audio/py-gmusicproxy/distinfo3
-rw-r--r--audio/py-gmusicproxy/pkg-descr14
4 files changed, 49 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index fc363fe19a09..e897b1930b29 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -636,6 +636,7 @@
SUBDIR += py-eyed3
SUBDIR += py-fmoo-audiotools
SUBDIR += py-gmusicapi
+ SUBDIR += py-gmusicproxy
SUBDIR += py-hsaudiotag
SUBDIR += py-id3
SUBDIR += py-karaoke
diff --git a/audio/py-gmusicproxy/Makefile b/audio/py-gmusicproxy/Makefile
new file mode 100644
index 000000000000..85b736e83068
--- /dev/null
+++ b/audio/py-gmusicproxy/Makefile
@@ -0,0 +1,31 @@
+# Created by: Ashley Chase <erisianash@gmail.com>
+# $FreeBSD$
+
+PORTNAME= gmusicproxy
+PORTVERSION= 1.0.8
+DISTVERSIONPREFIX= v
+CATEGORIES= audio python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= erisianash@gmail.com
+COMMENT= Proxy for streaming Google Play Music using any media-player
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}appdirs>=1.3.0:devel/py-appdirs \
+ ${PYTHON_PKGNAMEPREFIX}gmusicapi>=10.1.0:audio/py-gmusicapi \
+ ${PYTHON_PKGNAMEPREFIX}netifaces>=-0.10.4:net/py-netifaces \
+ ${PYTHON_PKGNAMEPREFIX}xdg>=0.25:devel/py-xdg \
+ ${PYTHON_PKGNAMEPREFIX}eyed3>=0.7.8:audio/py-eyed3 \
+ ${PYTHON_PKGNAMEPREFIX}daemon>=2.0.5:devel/py-daemon
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+USE_GITHUB= yes
+GH_ACCOUNT= diraimondo
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/audio/py-gmusicproxy/distinfo b/audio/py-gmusicproxy/distinfo
new file mode 100644
index 000000000000..38d50731a121
--- /dev/null
+++ b/audio/py-gmusicproxy/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1497955248
+SHA256 (diraimondo-gmusicproxy-v1.0.8_GH0.tar.gz) = d22141d5d8b854bc1583948c79269db39a0daf54dd11c89262a5ba25c02be088
+SIZE (diraimondo-gmusicproxy-v1.0.8_GH0.tar.gz) = 31956
diff --git a/audio/py-gmusicproxy/pkg-descr b/audio/py-gmusicproxy/pkg-descr
new file mode 100644
index 000000000000..d373176ebc80
--- /dev/null
+++ b/audio/py-gmusicproxy/pkg-descr
@@ -0,0 +1,14 @@
+This program permits the use of Google Play Music with All Access
+subscription with any music player that is able to stream MP3 files and to
+manage M3U playlists (e.g., MPD server, VLC, ...). It can work also with a
+free account without All Access extras.
+
+This project is based on the great Unofficial Google Play Music API
+(gmusicapi) of Simon Weber: it already permits to create URLs to stream the
+tracks as regular MP3 but they expire in 1 minute! Keeping this proxy
+running, it can generate persistent local URLs that never expire and that
+can be used in any media-player.
+
+This project is not supported nor endorsed by Google. Its aim is not the
+abuse of the service but the one to improve the access to it. I'm not
+responsible of its misuse.