aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2017-11-12 18:11:32 +0800
committeryuri <yuri@FreeBSD.org>2017-11-12 18:11:32 +0800
commitac9b9476ae0e27e008f7d7a0df6e053e73c46a54 (patch)
tree7bc2d3b55da46ef7640bae02462c0bc4aac851e2 /audio
parent541970241476762b3bc5d54241418a720e35213b (diff)
downloadfreebsd-ports-gnome-ac9b9476ae0e27e008f7d7a0df6e053e73c46a54.tar.gz
freebsd-ports-gnome-ac9b9476ae0e27e008f7d7a0df6e053e73c46a54.tar.zst
freebsd-ports-gnome-ac9b9476ae0e27e008f7d7a0df6e053e73c46a54.zip
audio/tap-plugins-lv2: Removed unused SIMD flags.
Also, moved patches under files/ PR: 223614 Submitted by: Jan Beich <jbeich@FreeBSD.org> Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D13051
Diffstat (limited to 'audio')
-rw-r--r--audio/tap-plugins-lv2/Makefile8
-rw-r--r--audio/tap-plugins-lv2/files/patch-Makefile.mk13
-rw-r--r--audio/tap-plugins-lv2/files/patch-dynamics_tap__dynamics.c11
3 files changed, 26 insertions, 6 deletions
diff --git a/audio/tap-plugins-lv2/Makefile b/audio/tap-plugins-lv2/Makefile
index 16118f14e9e0..5c0837e8630c 100644
--- a/audio/tap-plugins-lv2/Makefile
+++ b/audio/tap-plugins-lv2/Makefile
@@ -7,7 +7,7 @@ PORTREVISION= 1
CATEGORIES= audio
PKGNAMESUFFIX= -lv2
-MAINTAINER= yuri@rawbw.com
+MAINTAINER= yuri@FreeBSD.org
COMMENT= LV2 port for the TAP (Tom's Audio Processing) plugins
LICENSE= GPLv2
@@ -21,11 +21,7 @@ GH_ACCOUNT= moddevices
GH_PROJECT= tap-lv2
GH_TAGNAME= de26a3c
-post-patch:
- @${REINPLACE_CMD} -e 's| -O3||; s| -Wl,-O1||; s| -fstrength-reduce||; s| -Wl,--strip-all||' \
- ${WRKSRC}/Makefile.mk
- @${REINPLACE_CMD} -e 's|^inline$$||' \
- ${WRKSRC}/dynamics/tap_dynamics.c
+MAKE_ENV+= NOOPT=true
post-install:
@${STRIP_CMD} \
diff --git a/audio/tap-plugins-lv2/files/patch-Makefile.mk b/audio/tap-plugins-lv2/files/patch-Makefile.mk
new file mode 100644
index 000000000000..75805fbd9116
--- /dev/null
+++ b/audio/tap-plugins-lv2/files/patch-Makefile.mk
@@ -0,0 +1,13 @@
+--- Makefile.mk.orig 2016-01-25 10:55:48 UTC
++++ Makefile.mk
+@@ -3,8 +3,8 @@
+ CC ?= gcc
+
+ # flags
+-CFLAGS += -O3 -funroll-loops -ffast-math -fomit-frame-pointer -fstrength-reduce -Wall -Werror -fPIC -DPIC -I../utils
+-LDFLAGS += -shared -Wl,-O1 -Wl,--as-needed -Wl,--no-undefined -Wl,--strip-all -lm -lrt
++CFLAGS += -funroll-loops -ffast-math -fomit-frame-pointer -Wall -Werror -fPIC -DPIC -I../utils
++LDFLAGS += -shared -Wl,--as-needed -Wl,--no-undefined -lm -lrt
+
+ ifneq ($(NOOPT),true)
+ CFLAGS += -mtune=generic -msse -msse2 -mfpmath=sse
diff --git a/audio/tap-plugins-lv2/files/patch-dynamics_tap__dynamics.c b/audio/tap-plugins-lv2/files/patch-dynamics_tap__dynamics.c
new file mode 100644
index 000000000000..dffd38651826
--- /dev/null
+++ b/audio/tap-plugins-lv2/files/patch-dynamics_tap__dynamics.c
@@ -0,0 +1,11 @@
+--- dynamics/tap_dynamics.c.orig 2016-01-25 10:55:48 UTC
++++ dynamics/tap_dynamics.c
+@@ -267,7 +267,7 @@ rms_env_process(rms_env *r, const rms_t
+
+
+
+-inline
++
+ float
+ get_table_gain(int mode, float level) {
+