aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2017-11-15 16:08:12 +0800
committeryuri <yuri@FreeBSD.org>2017-11-15 16:08:12 +0800
commitb5ccabed2f617244fc9ced132260e20e2a18ad5f (patch)
tree2a42e2b5e98794aa2f3c76d97bb4a92f45b01a0a /audio
parent22b79ae6bb05409b8fb256a84e182c897859e32a (diff)
downloadfreebsd-ports-gnome-b5ccabed2f617244fc9ced132260e20e2a18ad5f.tar.gz
freebsd-ports-gnome-b5ccabed2f617244fc9ced132260e20e2a18ad5f.tar.zst
freebsd-ports-gnome-b5ccabed2f617244fc9ced132260e20e2a18ad5f.zip
New port: audio/eq10q-lv2: Parametric equalizer LV2 audio plugin
PR: 222113 Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D12846
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/eq10q-lv2/Makefile28
-rw-r--r--audio/eq10q-lv2/distinfo3
-rw-r--r--audio/eq10q-lv2/files/patch-CMakeLists.txt13
-rw-r--r--audio/eq10q-lv2/files/patch-dsp_filter.h23
-rw-r--r--audio/eq10q-lv2/files/patch-dsp_vu.h11
-rw-r--r--audio/eq10q-lv2/pkg-descr19
-rw-r--r--audio/eq10q-lv2/pkg-plist58
8 files changed, 156 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 995ab005bf92..b470f2ab3ee6 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -128,6 +128,7 @@
SUBDIR += emms
SUBDIR += enscribe
SUBDIR += epos-devel
+ SUBDIR += eq10q-lv2
SUBDIR += esound
SUBDIR += espeak
SUBDIR += esperanza
diff --git a/audio/eq10q-lv2/Makefile b/audio/eq10q-lv2/Makefile
new file mode 100644
index 000000000000..2f746ca9d5aa
--- /dev/null
+++ b/audio/eq10q-lv2/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= eq10q
+DISTVERSION= 2.2
+CATEGORIES= audio
+MASTER_SITES= SF/${PORTNAME}
+PKGNAMESUFFIX= -lv2
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Parametric equalizer LV2 audio plugin
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= lv2>0:audio/lv2
+LIB_DEPENDS= libfftw3.so:math/fftw3 \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
+
+USES= cmake:outsource dos2unix localbase:ldflags pkgconfig
+USE_GNOME= glib20 gtk20 gtkmm24 gdkpixbuf2 atkmm cairo cairomm pangomm
+DOS2UNIX_FILES= dsp/vu.h
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/pow10(/pow(10,/g' \
+ ${WRKSRC}/gui/widgets/*.cpp
+
+.include <bsd.port.mk>
diff --git a/audio/eq10q-lv2/distinfo b/audio/eq10q-lv2/distinfo
new file mode 100644
index 000000000000..d0c1b3c9a275
--- /dev/null
+++ b/audio/eq10q-lv2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1504743992
+SHA256 (eq10q-2.2.tar.gz) = 337f4c703ba31902565faad1cd450cf0312ad5a48dc499661277f287b662b09a
+SIZE (eq10q-2.2.tar.gz) = 797991
diff --git a/audio/eq10q-lv2/files/patch-CMakeLists.txt b/audio/eq10q-lv2/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..4a3c13d07191
--- /dev/null
+++ b/audio/eq10q-lv2/files/patch-CMakeLists.txt
@@ -0,0 +1,13 @@
+--- CMakeLists.txt.orig 2016-12-11 12:07:48 UTC
++++ CMakeLists.txt
+@@ -2,8 +2,8 @@
+ cmake_minimum_required(VERSION 2.8)
+ PROJECT(eq10q)
+
+-##ADD_DEFINITIONS(-Wall -O3 -fPIC -finline-functions -finline-functions-called-once -msse -mfpmath=sse -std=c99)
+-set(CMAKE_C_FLAGS "-Wall -O3 -fPIC -finline-functions -finline-functions-called-once -msse -mfpmath=sse -std=c99")
++##ADD_DEFINITIONS(-Wall -fPIC -finline-functions -finline-functions-called-once -msse -mfpmath=sse -std=c99)
++set(CMAKE_C_FLAGS "-Wall -fPIC -finline-functions -msse -mfpmath=sse -std=c99")
+ #set(CMAKE_C_FLAGS "-Wall -O0 -g -fPIC -finline-functions -finline-functions-called-once -msse -mfpmath=sse -std=c99")
+
+ set(CMAKE_CXX_FLAGS "-Wall -fPIC -std=c++11")
diff --git a/audio/eq10q-lv2/files/patch-dsp_filter.h b/audio/eq10q-lv2/files/patch-dsp_filter.h
new file mode 100644
index 000000000000..e91e0dbec3a3
--- /dev/null
+++ b/audio/eq10q-lv2/files/patch-dsp_filter.h
@@ -0,0 +1,23 @@
+--- dsp/filter.h.orig 2016-12-11 12:07:54 UTC
++++ dsp/filter.h
+@@ -237,13 +237,13 @@ static inline void calcCoefs(Filter *fil
+ double G12 = G1 * G1;
+
+ //Digital filter
+- double F = fabsf(G2 - GB2);// + 0.00000001f; ///TODO akest petit num sumat en teoria no hi va pero he detectat div by 0
+- double G00 = fabsf(G2 - 1.0);// + 0.00000001f; ///TODO akest petit num sumat en teoria no hi va pero he detectat div by 0
+- double F00 = fabsf(GB2 - 1.0);// + 0.00000001f; ///TODO akest petit num sumat en teoria no hi va pero he detectat div by 0
+- double G01 = fabsf(G2 - G1);// + 0.00000001f; ///TODO akest petit num sumat en teoria no hi va pero he detectat div by 0
+- double G11 = fabsf(G2 - G12);// + 0.00000001f; ///TODO akest petit num sumat en teoria no hi va pero he detectat div by 0
+- double F01 = fabsf(GB2 - G1);// + 0.00000001f; ///TODO akest petit num sumat en teoria no hi va pero he detectat div by 0
+- double F11 = fabsf(GB2 - G12);// + 0.00000001f; ///TODO akest petit num sumat en teoria no hi va pero he detectat div by 0
++ double F = fabs(G2 - GB2);// + 0.00000001f; ///TODO akest petit num sumat en teoria no hi va pero he detectat div by 0
++ double G00 = fabs(G2 - 1.0);// + 0.00000001f; ///TODO akest petit num sumat en teoria no hi va pero he detectat div by 0
++ double F00 = fabs(GB2 - 1.0);// + 0.00000001f; ///TODO akest petit num sumat en teoria no hi va pero he detectat div by 0
++ double G01 = fabs(G2 - G1);// + 0.00000001f; ///TODO akest petit num sumat en teoria no hi va pero he detectat div by 0
++ double G11 = fabs(G2 - G12);// + 0.00000001f; ///TODO akest petit num sumat en teoria no hi va pero he detectat div by 0
++ double F01 = fabs(GB2 - G1);// + 0.00000001f; ///TODO akest petit num sumat en teoria no hi va pero he detectat div by 0
++ double F11 = fabs(GB2 - G12);// + 0.00000001f; ///TODO akest petit num sumat en teoria no hi va pero he detectat div by 0
+ double W2 = sqrtf(G11 / G00) * tanf(w0/2.0) * tanf(w0/2.0);
+
+ //Bandwidth condition
diff --git a/audio/eq10q-lv2/files/patch-dsp_vu.h b/audio/eq10q-lv2/files/patch-dsp_vu.h
new file mode 100644
index 000000000000..9f2250a7e759
--- /dev/null
+++ b/audio/eq10q-lv2/files/patch-dsp_vu.h
@@ -0,0 +1,11 @@
+--- dsp/vu.h.orig 2016-12-11 12:07:54 UTC
++++ dsp/vu.h
+@@ -49,7 +49,7 @@ static inline void resetVU(Vu *vu)
+ //Inputs a sample to VU
+ static inline void SetSample(Vu *vu, float sample)
+ {
+- vu->vu_value = fabsf(sample);
++ vu->vu_value = fabs(sample);
+ vu->vu_max = vu->vu_value > vu->vu_max ? vu->vu_value : vu->vu_max;
+ }
+
diff --git a/audio/eq10q-lv2/pkg-descr b/audio/eq10q-lv2/pkg-descr
new file mode 100644
index 000000000000..63c576fad025
--- /dev/null
+++ b/audio/eq10q-lv2/pkg-descr
@@ -0,0 +1,19 @@
+EQ10Q is an audio plugin bundle over the LV2 standard, implementing a powerful
+and flexible parametric equalizer and more.
+
+All audio processing developed in this project is written in C language and
+highly optimized focusing on DSP load reduction yet keeping a superb audio
+quality, the audio engine is always working in 64 bits floating point maths but
+interfacing with LV2 ports using the standard 32 bits numbers. We believe that
+a good plugin is not completely useful without a full featured graphical user
+interface (GUI) that provides the correct way to set it up. For this reason,
+each plugin distributed in this bundle is supplied with a nice GUI. These GUI's
+are written in C++ and Gtkmm libraries to gain a great control over the
+graphics.
+
+The project is licensed under GPL so feel free to copy, redistribute and modify.
+Although, if your are really convinced of doing some possible interesting
+changes in the source code, please mail me and we can discuss about
+incorporating your awesome ideas in the main project.
+
+WWW: http://eq10q.sourceforge.net
diff --git a/audio/eq10q-lv2/pkg-plist b/audio/eq10q-lv2/pkg-plist
new file mode 100644
index 000000000000..5cf402f65180
--- /dev/null
+++ b/audio/eq10q-lv2/pkg-plist
@@ -0,0 +1,58 @@
+lib/lv2/sapistaEQv2.lv2/bassup.so
+lib/lv2/sapistaEQv2.lv2/bassup.ttl
+lib/lv2/sapistaEQv2.lv2/compressor.so
+lib/lv2/sapistaEQv2.lv2/compressor.ttl
+lib/lv2/sapistaEQv2.lv2/compressor_sc.so
+lib/lv2/sapistaEQv2.lv2/compressor_sc.ttl
+lib/lv2/sapistaEQv2.lv2/compressor_stereo.so
+lib/lv2/sapistaEQv2.lv2/compressor_stereo.ttl
+lib/lv2/sapistaEQv2.lv2/compressor_stereo_sc.so
+lib/lv2/sapistaEQv2.lv2/compressor_stereo_sc.ttl
+lib/lv2/sapistaEQv2.lv2/eq10qm.so
+lib/lv2/sapistaEQv2.lv2/eq10qm.ttl
+lib/lv2/sapistaEQv2.lv2/eq10qs.so
+lib/lv2/sapistaEQv2.lv2/eq10qs.ttl
+lib/lv2/sapistaEQv2.lv2/eq1qm.so
+lib/lv2/sapistaEQv2.lv2/eq1qm.ttl
+lib/lv2/sapistaEQv2.lv2/eq1qs.so
+lib/lv2/sapistaEQv2.lv2/eq1qs.ttl
+lib/lv2/sapistaEQv2.lv2/eq4qm.so
+lib/lv2/sapistaEQv2.lv2/eq4qm.ttl
+lib/lv2/sapistaEQv2.lv2/eq4qs.so
+lib/lv2/sapistaEQv2.lv2/eq4qs.ttl
+lib/lv2/sapistaEQv2.lv2/eq6qm.so
+lib/lv2/sapistaEQv2.lv2/eq6qm.ttl
+lib/lv2/sapistaEQv2.lv2/eq6qs.so
+lib/lv2/sapistaEQv2.lv2/eq6qs.ttl
+lib/lv2/sapistaEQv2.lv2/gate.so
+lib/lv2/sapistaEQv2.lv2/gate.ttl
+lib/lv2/sapistaEQv2.lv2/gate_stereo.so
+lib/lv2/sapistaEQv2.lv2/gate_stereo.ttl
+lib/lv2/sapistaEQv2.lv2/gui/bassup_gui.so
+lib/lv2/sapistaEQv2.lv2/gui/combopix/hishelf.png
+lib/lv2/sapistaEQv2.lv2/gui/combopix/hpf.png
+lib/lv2/sapistaEQv2.lv2/gui/combopix/loshelf.png
+lib/lv2/sapistaEQv2.lv2/gui/combopix/lpf.png
+lib/lv2/sapistaEQv2.lv2/gui/combopix/notch.png
+lib/lv2/sapistaEQv2.lv2/gui/combopix/peak.png
+lib/lv2/sapistaEQv2.lv2/gui/dynamics_gui.so
+lib/lv2/sapistaEQv2.lv2/gui/eq10q_gui.so
+lib/lv2/sapistaEQv2.lv2/gui/icons/logobassup.png
+lib/lv2/sapistaEQv2.lv2/gui/icons/logodynamics.png
+lib/lv2/sapistaEQv2.lv2/gui/icons/logoeq10q.png
+lib/lv2/sapistaEQv2.lv2/gui/knobs/fader_dark.png
+lib/lv2/sapistaEQv2.lv2/gui/knobs/fader_white.png
+lib/lv2/sapistaEQv2.lv2/gui/knobs/knob2_25px.png
+lib/lv2/sapistaEQv2.lv2/gui/knobs/knob2_28px.png
+lib/lv2/sapistaEQv2.lv2/gui/knobs/knob2_32px.png
+lib/lv2/sapistaEQv2.lv2/gui/knobs/knob2_35px.png
+lib/lv2/sapistaEQv2.lv2/gui/knobs/knob_bassup_165px.png
+lib/lv2/sapistaEQv2.lv2/gui/knobs/knob_bassup_84px.png
+lib/lv2/sapistaEQv2.lv2/gui/knobs/knob_green_84px.png
+lib/lv2/sapistaEQv2.lv2/gui/knobs/mixer_knob.xcf
+lib/lv2/sapistaEQv2.lv2/gui/matrix_ms_gui.so
+lib/lv2/sapistaEQv2.lv2/lr2ms.ttl
+lib/lv2/sapistaEQv2.lv2/manifest.ttl
+lib/lv2/sapistaEQv2.lv2/matrix_lr2ms.so
+lib/lv2/sapistaEQv2.lv2/matrix_ms2lr.so
+lib/lv2/sapistaEQv2.lv2/ms2lr.ttl