aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2014-12-09 05:18:45 +0800
committerrene <rene@FreeBSD.org>2014-12-09 05:18:45 +0800
commitb6012d8dc6f1e474434fc704a20723fb76cdf852 (patch)
treef4128648b9168b07dd52f304922a34da33fe2ef1 /audio
parent4cd2b9383f84054ecd85688f64e658c7070dd956 (diff)
downloadfreebsd-ports-gnome-b6012d8dc6f1e474434fc704a20723fb76cdf852.tar.gz
freebsd-ports-gnome-b6012d8dc6f1e474434fc704a20723fb76cdf852.tar.zst
freebsd-ports-gnome-b6012d8dc6f1e474434fc704a20723fb76cdf852.zip
audio/py-mpd2: update to 0.5.4
Ensure all Python files are installed as executable.
Diffstat (limited to 'audio')
-rw-r--r--audio/py-mpd2/Makefile24
-rw-r--r--audio/py-mpd2/distinfo4
2 files changed, 19 insertions, 9 deletions
diff --git a/audio/py-mpd2/Makefile b/audio/py-mpd2/Makefile
index d5b3191b3e4b..30da580a87f2 100644
--- a/audio/py-mpd2/Makefile
+++ b/audio/py-mpd2/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mpd2
-PORTVERSION= 0.5.3
+PORTVERSION= 0.5.4
CATEGORIES= audio python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= python-${PORTNAME}-${PORTVERSION}
@@ -16,7 +16,7 @@ USE_GITHUB= yes
GH_ACCOUNT= Mic92
GH_PROJECT= python-${PORTNAME}
GH_TAGNAME= v${PORTVERSION}
-GH_COMMIT= cfeb3b5
+GH_COMMIT= 504bcb1
USES= shebangfix python
SHEBANG_FILES= examples/helloworld.py
@@ -28,13 +28,17 @@ OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
OPTIONS_DEFINE= DOCS EXAMPLES
DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
-PORTDOCS_1= generate_command_reference.py index.rst changes.rst
+PORTDOCS_1= commands_header.txt index.rst changes.rst
PORTDOCS_2= topics/advanced.rst topics/commands.rst \
topics/getting-started.rst topics/logging.rst
-PORTDOCS= ${PORTDOCS_1} ${PORTDOCS_2}
+PORTDOCS_3= generate_command_reference.py
+PORTDOCS= ${PORTDOCS_1} ${PORTDOCS_2} ${PORTDOCS_3}
EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
-PORTEXAMPLES= helloworld.py locking.py logger.py
-PLIST_DIRSTRY= ${DOCSDIR}/topics
+PORTEXAMPLES_1= errorhandling.py helloworld.py idle.py locking.py logger.py \
+ multitags.py randomqueue.py stats.py stickers.py
+PORTEXAMPLES_2= summary.txt
+PORTEXAMPLES= ${PORTEXAMPLES_1} ${PORTEXAMPLES_2}
+PLIST_DIRS= ${DOCSDIR}/topics
post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}/topics
@@ -44,9 +48,15 @@ post-install:
.for f in ${PORTDOCS_2}
${INSTALL_DATA} ${WRKSRC}/doc/${f} ${STAGEDIR}${DOCSDIR}/topics
.endfor
+.for f in ${PORTDOCS_3}
+ ${INSTALL_SCRIPT} ${WRKSRC}/doc/${f} ${STAGEDIR}${DOCSDIR}
+.endfor
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
-.for f in ${PORTEXAMPLES}
+.for f in ${PORTEXAMPLES_1}
${INSTALL_SCRIPT} ${WRKSRC}/examples/${f} ${STAGEDIR}${EXAMPLESDIR}
.endfor
+.for f in ${PORTEXAMPLES_2}
+ ${INSTALL_DATA} ${WRKSRC}/examples/${f} ${STAGEDIR}${EXAMPLESDIR}
+.endfor
.include <bsd.port.mk>
diff --git a/audio/py-mpd2/distinfo b/audio/py-mpd2/distinfo
index ae4953e4a177..d412e4f1f023 100644
--- a/audio/py-mpd2/distinfo
+++ b/audio/py-mpd2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (python-mpd2-0.5.3.tar.gz) = 280a0c108e688ff778bb983f7db926515bcb195b2bdc33a3262036f803fff906
-SIZE (python-mpd2-0.5.3.tar.gz) = 40511
+SHA256 (python-mpd2-0.5.4.tar.gz) = e032e6f8db2a0a745580eb635dc9f85934d36d818167d328b6525e9227d81ff0
+SIZE (python-mpd2-0.5.4.tar.gz) = 45563