aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2017-05-06 15:39:30 +0800
committermiwi <miwi@FreeBSD.org>2017-05-06 15:39:30 +0800
commitccc30fdbcbd43f113efa2f72ed4e5d4607142c40 (patch)
treeff79a8fb72880096d043b8c0c443073f87fbc7b9 /audio
parent9ee5a28bcbd5245642ceb8573f2dcb56f1031d7f (diff)
downloadfreebsd-ports-gnome-ccc30fdbcbd43f113efa2f72ed4e5d4607142c40.tar.gz
freebsd-ports-gnome-ccc30fdbcbd43f113efa2f72ed4e5d4607142c40.tar.zst
freebsd-ports-gnome-ccc30fdbcbd43f113efa2f72ed4e5d4607142c40.zip
hsaudiotag is a pure Python library that lets you read metadata (bitrate,
sample rate, duration and tags) from mp3, mp4, wma, ogg, flac and aiff files. It can only read tags, not write to them, but unlike more complete libraries (like Mutagen), it is BSD licensed, making it suitable for most projects. It is also backed by a nifty test suite. WWW: http://hg.hardcoded.net/hsaudiotag PR: 214493 Submitted by: Yuri Victorovich <yuri@rawbw.com>
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/py-hsaudiotag/Makefile19
-rw-r--r--audio/py-hsaudiotag/distinfo3
-rw-r--r--audio/py-hsaudiotag/pkg-descr7
4 files changed, 30 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 275e1c8bcedb..2a342b29400b 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -627,6 +627,7 @@
SUBDIR += py-eyed3
SUBDIR += py-fmoo-audiotools
SUBDIR += py-gmusicapi
+ SUBDIR += py-hsaudiotag
SUBDIR += py-id3
SUBDIR += py-karaoke
SUBDIR += py-mad
diff --git a/audio/py-hsaudiotag/Makefile b/audio/py-hsaudiotag/Makefile
new file mode 100644
index 000000000000..3f19b83d5a6f
--- /dev/null
+++ b/audio/py-hsaudiotag/Makefile
@@ -0,0 +1,19 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= hsaudiotag
+PORTVERSION= 1.1.1
+CATEGORIES= audio python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Read metdata (tags) of mp3, mp4, wma, ogg, flac and aiff files
+
+LICENSE= BSD3CLAUSE
+
+USES= python:2
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/audio/py-hsaudiotag/distinfo b/audio/py-hsaudiotag/distinfo
new file mode 100644
index 000000000000..31b6403d1b5c
--- /dev/null
+++ b/audio/py-hsaudiotag/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1479091794
+SHA256 (hsaudiotag-1.1.1.tar.gz) = 48b57c6a00b0ed2bb906850ac42390740ff5b83a222c09a2d3dea28b44a80f96
+SIZE (hsaudiotag-1.1.1.tar.gz) = 16409
diff --git a/audio/py-hsaudiotag/pkg-descr b/audio/py-hsaudiotag/pkg-descr
new file mode 100644
index 000000000000..f06ef1ec3f71
--- /dev/null
+++ b/audio/py-hsaudiotag/pkg-descr
@@ -0,0 +1,7 @@
+hsaudiotag is a pure Python library that lets you read metadata (bitrate,
+sample rate, duration and tags) from mp3, mp4, wma, ogg, flac and aiff files.
+It can only read tags, not write to them, but unlike more complete libraries
+(like Mutagen), it is BSD licensed, making it suitable for most projects.
+It is also backed by a nifty test suite.
+
+WWW: http://hg.hardcoded.net/hsaudiotag