aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2007-03-17 07:01:13 +0800
committernaddy <naddy@FreeBSD.org>2007-03-17 07:01:13 +0800
commitcdc8332183c602c4fd30e483c4b8da085704a3d7 (patch)
tree41e89b68ab7898983f84bc8bf2bf56ddfd78b10e /audio
parenta43e64e87e6696004668b885ad57e7df0d5c7148 (diff)
downloadfreebsd-ports-gnome-cdc8332183c602c4fd30e483c4b8da085704a3d7.tar.gz
freebsd-ports-gnome-cdc8332183c602c4fd30e483c4b8da085704a3d7.tar.zst
freebsd-ports-gnome-cdc8332183c602c4fd30e483c4b8da085704a3d7.zip
Add Josh Coalson's patches that allow building vorbis-tools on either side
of the FLAC 1.1.2/1.1.3 API divide. No package changes.
Diffstat (limited to 'audio')
-rw-r--r--audio/vorbis-tools/Makefile7
-rw-r--r--audio/vorbis-tools/distinfo3
-rw-r--r--audio/vorbis-tools/files/patch-configure.ac (renamed from audio/vorbis-tools/files/patch-configure)16
-rw-r--r--audio/vorbis-tools/files/patch-ogg123_Makefile.am26
-rw-r--r--audio/vorbis-tools/files/patch-ogg123_Makefile.in23
5 files changed, 39 insertions, 36 deletions
diff --git a/audio/vorbis-tools/Makefile b/audio/vorbis-tools/Makefile
index 08e3aa507f7e..c50e132a8ac6 100644
--- a/audio/vorbis-tools/Makefile
+++ b/audio/vorbis-tools/Makefile
@@ -12,6 +12,10 @@ PORTEPOCH= 3
CATEGORIES= audio
MASTER_SITES= http://downloads.xiph.org/releases/vorbis/
+PATCH_SITES= http://sites.inka.de/~mips/unix/distfiles/
+PATCHFILES= vorbis-tools-1.1.1-flac-1.1.3.patch
+PATCH_DIST_STRIP=-p1
+
MAINTAINER= naddy@FreeBSD.org
COMMENT= Play, encode, and manage Ogg Vorbis files
@@ -21,8 +25,9 @@ LIB_DEPENDS= ao.3:${PORTSDIR}/audio/libao \
speex.1:${PORTSDIR}/audio/speex \
vorbis.3:${PORTSDIR}/audio/libvorbis
+USE_AUTOTOOLS= aclocal:19 autoconf:259 automake:19 libtool:15
USE_GETTEXT= yes
-GNU_CONFIGURE= yes
+ACLOCAL_ARGS= -I ${LOCALBASE}/share/aclocal
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-vcut
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/audio/vorbis-tools/distinfo b/audio/vorbis-tools/distinfo
index 9439b6059ef6..b8ea1961c4ff 100644
--- a/audio/vorbis-tools/distinfo
+++ b/audio/vorbis-tools/distinfo
@@ -1,3 +1,6 @@
MD5 (vorbis-tools-1.1.1.tar.gz) = 47845fd76f5f2354a3619c4097575487
SHA256 (vorbis-tools-1.1.1.tar.gz) = 617b4aa69e600c215b34fa3fd5764bc1d9d205d9d7d9fe7812bde7ec956fcaad
SIZE (vorbis-tools-1.1.1.tar.gz) = 948837
+MD5 (vorbis-tools-1.1.1-flac-1.1.3.patch) = 98f5ea16ff8ebd69b9ff3b25fad8dd30
+SHA256 (vorbis-tools-1.1.1-flac-1.1.3.patch) = 578b1ff0a76e73e1aa41f65b77ba76add35574b1d74de6b34bb6bab1cf6c2106
+SIZE (vorbis-tools-1.1.1-flac-1.1.3.patch) = 19301
diff --git a/audio/vorbis-tools/files/patch-configure b/audio/vorbis-tools/files/patch-configure.ac
index da6c3614fc45..3ddc0379e808 100644
--- a/audio/vorbis-tools/files/patch-configure
+++ b/audio/vorbis-tools/files/patch-configure.ac
@@ -1,17 +1,9 @@
$FreeBSD$
---- configure.orig Fri Jul 19 16:18:55 2002
-+++ configure Sat Sep 20 16:11:32 2003
-@@ -5410,6 +5410,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-@@ -7244,7 +7245,7 @@
+--- configure.ac.orig
++++ configure.ac
+@@ -51,7 +51,7 @@
;;
*)
DEBUG="-g"
@@ -20,7 +12,7 @@ $FreeBSD$
PROFILE="-g -p"
;;
esac
-@@ -7267,8 +7268,8 @@
+@@ -74,8 +74,8 @@
;;
*)
DEBUG="-g -Wall -fsigned-char"
diff --git a/audio/vorbis-tools/files/patch-ogg123_Makefile.am b/audio/vorbis-tools/files/patch-ogg123_Makefile.am
new file mode 100644
index 000000000000..e2cb6bad7aaa
--- /dev/null
+++ b/audio/vorbis-tools/files/patch-ogg123_Makefile.am
@@ -0,0 +1,26 @@
+
+$FreeBSD$
+
+--- ogg123/Makefile.am.orig
++++ ogg123/Makefile.am
+@@ -16,7 +16,7 @@
+
+ datadir = @datadir@
+ localedir = $(datadir)/locale
+-DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
++DEFS = -DSYSCONFDIR=\"$(sysconfdir)\" -DLOCALEDIR=\"$(localedir)\" @DEFS@
+
+ docdir = $(datadir)/doc/$(PACKAGE)-$(VERSION)
+ mandir = @MANDIR@
+@@ -44,10 +44,9 @@
+ $(flac_sources) $(speex_sources)
+
+ man_MANS = ogg123.1
+-doc_DATA = ogg123rc-example
+
+ EXTRA_ogg123_SOURCES = \
+- $(man_MANS) $(doc_DATA)
++ $(man_MANS)
+
+ debug:
+ $(MAKE) all CFLAGS="@DEBUG@"
diff --git a/audio/vorbis-tools/files/patch-ogg123_Makefile.in b/audio/vorbis-tools/files/patch-ogg123_Makefile.in
deleted file mode 100644
index 4bbf36eb88e3..000000000000
--- a/audio/vorbis-tools/files/patch-ogg123_Makefile.in
+++ /dev/null
@@ -1,23 +0,0 @@
-
-$FreeBSD$
-
---- ogg123/Makefile.in.orig
-+++ ogg123/Makefile.in
-@@ -129,7 +129,7 @@
- CYGPATH_W = @CYGPATH_W@
- DATADIRNAME = @DATADIRNAME@
- DEBUG = @DEBUG@
--DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
-+DEFS = -DSYSCONFDIR=\"$(sysconfdir)\" -DLOCALEDIR=\"$(localedir)\" @DEFS@
- DEPDIR = @DEPDIR@
- ECHO = @ECHO@
- ECHO_C = @ECHO_C@
-@@ -599,7 +599,7 @@
-
- info-am:
-
--install-data-am: install-docDATA install-man
-+install-data-am: install-man
-
- install-exec-am: install-binPROGRAMS
-