aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2013-10-31 20:56:19 +0800
committerarved <arved@FreeBSD.org>2013-10-31 20:56:19 +0800
commitce9df3f90e4540bc029c92231ee88f9605c387fe (patch)
tree7dec4eb2a2c353eea2f3b39b0883afbc482aac83 /audio
parentd25f1d9f924c4fe8c37efbc179e5da2ea347caef (diff)
downloadfreebsd-ports-gnome-ce9df3f90e4540bc029c92231ee88f9605c387fe.tar.gz
freebsd-ports-gnome-ce9df3f90e4540bc029c92231ee88f9605c387fe.tar.zst
freebsd-ports-gnome-ce9df3f90e4540bc029c92231ee88f9605c387fe.zip
Support Stagedir
Diffstat (limited to 'audio')
-rw-r--r--audio/ladspa/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/audio/ladspa/Makefile b/audio/ladspa/Makefile
index 240b5b3d047a..995fc2bb4ca2 100644
--- a/audio/ladspa/Makefile
+++ b/audio/ladspa/Makefile
@@ -16,11 +16,10 @@ LICENSE_FILE= ${WRKSRC}/doc/COPYING
WRKSRC= ${WRKDIR}/ladspa_sdk
USES= gmake
-NO_STAGE= yes
USE_LDCONFIG= yes
PROGRAM_FILES= analyseplugin applyplugin listplugins
PLUGIN_FILES= amp.so delay.so filter.so noise.so sine.so
-PLUGIN_DIR?= ${PREFIX}/lib/ladspa/
+PLUGIN_DIR?= ${STAGEDIR}${PREFIX}/lib/ladspa/
MAKEFILE= makefile
ALL_TARGET= targets
BUILD_WRKSRC= ${WRKSRC}/src
@@ -31,9 +30,9 @@ post-patch:
${WRKSRC}/src/makefile
do-install:
- @${INSTALL_DATA} ${WRKSRC}/src/ladspa.h ${PREFIX}/include
+ @${INSTALL_DATA} ${WRKSRC}/src/ladspa.h ${STAGEDIR}${PREFIX}/include
.for file in ${PROGRAM_FILES}
- @${INSTALL_PROGRAM} ${WRKSRC}/bin/${file} ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/bin/${file} ${STAGEDIR}${PREFIX}/bin
.endfor
@${MKDIR} ${PLUGIN_DIR}
.for file in ${PLUGIN_FILES}