aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2011-12-27 12:23:04 +0800
committerrm <rm@FreeBSD.org>2011-12-27 12:23:04 +0800
commitd7b1856de119fd1168dd2dfc9515ee242620a1d1 (patch)
tree8437e71d05cb895092aa3afcb1818b1dc2db9e5f /audio
parent9bfbb68d86051eb61e8888a8494fcb35518da1e8 (diff)
downloadfreebsd-ports-gnome-d7b1856de119fd1168dd2dfc9515ee242620a1d1.tar.gz
freebsd-ports-gnome-d7b1856de119fd1168dd2dfc9515ee242620a1d1.tar.zst
freebsd-ports-gnome-d7b1856de119fd1168dd2dfc9515ee242620a1d1.zip
- add patch to fix itunes 10.5.2 compatibility
PR: 163632 Submitted by: Mark Foster <mark at foster dot cc> (maintainer) Approved by: novel (mentor, implicit)
Diffstat (limited to 'audio')
-rw-r--r--audio/firefly/Makefile2
-rw-r--r--audio/firefly/files/patch-plugins_out-daap.c24
2 files changed, 25 insertions, 1 deletions
diff --git a/audio/firefly/Makefile b/audio/firefly/Makefile
index c8065cce1aef..fe173189ecec 100644
--- a/audio/firefly/Makefile
+++ b/audio/firefly/Makefile
@@ -6,7 +6,7 @@
PORTNAME= firefly
PORTVERSION= 1696
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= audio
MASTER_SITES= http://nightlies.fireflymediaserver.org/nightlies/svn-${PORTVERSION}/ \
http://www.magnesium.net/~mdf/distfiles/
diff --git a/audio/firefly/files/patch-plugins_out-daap.c b/audio/firefly/files/patch-plugins_out-daap.c
new file mode 100644
index 000000000000..2bd59918b114
--- /dev/null
+++ b/audio/firefly/files/patch-plugins_out-daap.c
@@ -0,0 +1,24 @@
+--- src/plugins/out-daap.c 2007-10-13 15:10:06.000000000 -0700
++++ src/plugins/out-daap.c.new 2011-10-16 18:08:53.207764000 -0700
+@@ -1392,11 +1393,9 @@
+
+ size = sizeof(servername);
+ pi_server_name(servername,&size);
+- // supports_update = conf_get_int("daap","supports_update",1);
++ supports_update = pi_conf_get_int("daap","supports_update",1);
+
+ actual_length=139 + (int) strlen(servername);
+- if(!supports_update)
+- actual_length -= 9;
+
+ if(actual_length > sizeof(server_info)) {
+ pi_log(E_FATAL,"Server name too long.\n");
+@@ -1434,6 +1433,8 @@
+ current += dmap_add_int(current,"msdc",1); /* 12 */
+
+ if(supports_update)
++ current += dmap_add_char(current,"msup",1); /* 9 */
++ else
+ current += dmap_add_char(current,"msup",0); /* 9 */
+
+ out_daap_output_start(pwsc,ppi,actual_length);