aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authormich <mich@FreeBSD.org>2008-02-21 18:06:25 +0800
committermich <mich@FreeBSD.org>2008-02-21 18:06:25 +0800
commite0bd48b4c02abb9811e10a97b87dae86bf3853c1 (patch)
tree4d1c4602dc5193ad871e845a6afe085c0f6849db /audio
parentc18cff780690983eaea7612dc9d9daaa23d1f3cd (diff)
downloadfreebsd-ports-gnome-e0bd48b4c02abb9811e10a97b87dae86bf3853c1.tar.gz
freebsd-ports-gnome-e0bd48b4c02abb9811e10a97b87dae86bf3853c1.tar.zst
freebsd-ports-gnome-e0bd48b4c02abb9811e10a97b87dae86bf3853c1.zip
- add option to compile with libvisual support
PR: ports/120381 Submitted by: Björn Kön <bkoenig@alpha-tierchen.de>
Diffstat (limited to 'audio')
-rw-r--r--audio/amarok-kde4/Makefile12
-rw-r--r--audio/amarok/Makefile12
2 files changed, 20 insertions, 4 deletions
diff --git a/audio/amarok-kde4/Makefile b/audio/amarok-kde4/Makefile
index 3dc5e1a83bbe..1831514158d1 100644
--- a/audio/amarok-kde4/Makefile
+++ b/audio/amarok-kde4/Makefile
@@ -28,11 +28,13 @@ USE_GETTEXT= yes
USE_SDL= sdl
USE_RUBY= yes
USE_LDCONFIG= yes
+USE_GNOME=
INSTALLS_ICONS= yes
OPTIONS= GPOD "iPod support" on \
NJB "Creative Nomad and Dell support" on \
MTP "MTP device support" on \
+ LIBVISUAL "libvisual support" off \
OPENGL "OpenGL support" on \
AMAZON "Amazon cover fetching support" on \
MYSQL "Use MySQL as collection backend" off \
@@ -43,8 +45,7 @@ OPTIONS= GPOD "iPod support" on \
CONFIGURE_ARGS+=--without-exscalibar \
--with-mp4v2 \
- --with-mp4v2-dir=${PREFIX} \
- --without-libvisual
+ --with-mp4v2-dir=${PREFIX}
.if !defined(WITH_GPOD)
PLIST_SUB+= GPOD="@comment "
@@ -71,6 +72,13 @@ CONFIGURE_ARGS+=--with-libmtp
PLIST_SUB+= MTP=""
.endif
+.if defined(WITHOUT_LIBVISUAL)
+CONFIGURE_ARGS+=--without-libvisual
+.else
+LIB_DEPENDS+= visual-0.4:${PORTSDIR}/graphics/libvisual04
+USE_GNOME+= gnomelibs
+.endif
+
.if defined(WITHOUT_OPENGL)
CONFIGURE_ARGS+=--without-opengl
.endif
diff --git a/audio/amarok/Makefile b/audio/amarok/Makefile
index 3dc5e1a83bbe..1831514158d1 100644
--- a/audio/amarok/Makefile
+++ b/audio/amarok/Makefile
@@ -28,11 +28,13 @@ USE_GETTEXT= yes
USE_SDL= sdl
USE_RUBY= yes
USE_LDCONFIG= yes
+USE_GNOME=
INSTALLS_ICONS= yes
OPTIONS= GPOD "iPod support" on \
NJB "Creative Nomad and Dell support" on \
MTP "MTP device support" on \
+ LIBVISUAL "libvisual support" off \
OPENGL "OpenGL support" on \
AMAZON "Amazon cover fetching support" on \
MYSQL "Use MySQL as collection backend" off \
@@ -43,8 +45,7 @@ OPTIONS= GPOD "iPod support" on \
CONFIGURE_ARGS+=--without-exscalibar \
--with-mp4v2 \
- --with-mp4v2-dir=${PREFIX} \
- --without-libvisual
+ --with-mp4v2-dir=${PREFIX}
.if !defined(WITH_GPOD)
PLIST_SUB+= GPOD="@comment "
@@ -71,6 +72,13 @@ CONFIGURE_ARGS+=--with-libmtp
PLIST_SUB+= MTP=""
.endif
+.if defined(WITHOUT_LIBVISUAL)
+CONFIGURE_ARGS+=--without-libvisual
+.else
+LIB_DEPENDS+= visual-0.4:${PORTSDIR}/graphics/libvisual04
+USE_GNOME+= gnomelibs
+.endif
+
.if defined(WITHOUT_OPENGL)
CONFIGURE_ARGS+=--without-opengl
.endif