aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2015-07-28 04:19:33 +0800
committerkwm <kwm@FreeBSD.org>2015-07-28 04:19:33 +0800
commitf3a030abc46a4b0256ee69dd4918b96f535a295d (patch)
tree0d276f72ec80621ae31f35239a1c27ae16c21bba /audio
parentc0e75495d2db694b13f48fd2ce73094f2affcc17 (diff)
downloadfreebsd-ports-gnome-f3a030abc46a4b0256ee69dd4918b96f535a295d.tar.gz
freebsd-ports-gnome-f3a030abc46a4b0256ee69dd4918b96f535a295d.tar.zst
freebsd-ports-gnome-f3a030abc46a4b0256ee69dd4918b96f535a295d.zip
Update MATE DE to 1.10.0.
This MATE is still build agains GTK+2. Sort USES here and there. Replace mate-dialogs with zenity and mate-calc with galculator. This update fixes the following PR's: PR: 193942, 191885 Submitted by: Gustau Perez <gustau.perez@gmail.com> via Gnome devel repo Obtained from: gnome devel repo.
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/libmatemixer/Makefile32
-rw-r--r--audio/libmatemixer/distinfo2
-rw-r--r--audio/libmatemixer/pkg-descr6
-rw-r--r--audio/libmatemixer/pkg-plist52
-rw-r--r--audio/mate-media/Makefile19
-rw-r--r--audio/mate-media/distinfo4
-rw-r--r--audio/mate-media/pkg-plist158
8 files changed, 141 insertions, 133 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 27d5cf017b5b..6573224dea4c 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -370,6 +370,7 @@
SUBDIR += liblo
SUBDIR += liblscp
SUBDIR += libmad
+ SUBDIR += libmatemixer
SUBDIR += libmikmod
SUBDIR += libmodplug
SUBDIR += libmp3-archive-perl
diff --git a/audio/libmatemixer/Makefile b/audio/libmatemixer/Makefile
new file mode 100644
index 000000000000..c7c9210a8b10
--- /dev/null
+++ b/audio/libmatemixer/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= libmatemixer
+PORTVERSION= 1.10.0
+CATEGORIES= audio mate
+MASTER_SITES= MATE
+DIST_SUBDIR= mate
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Mixer library for MATE desktop
+
+LICENSE= LGPL21
+
+USES= gettext libtool pathfix pkgconfig tar:xz
+USE_GNOME= glib20 intltool
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-null \
+ --enable-oss \
+ --disable-gtk-doc \
+ --disable-gtk-doc-html \
+ --disable-gtk-doc-pdf
+INSTALL_TARGET= install-strip
+
+OPTIONS_DEFINE= PULSEAUDIO ALSA
+OPTIONS_SUB= yes
+
+PULSEAUDIO_CONFIGURE_ENABLE= pulseaudio
+PULSEAUDIO_LIB_DEPENDS= libpulse.so:${PORTSDIR}/audio/pulseaudio
+ALSA_CONFIGURE_ENABLE= alsa
+ALSA_LIB_DEPENDS= libasound.so:${PORTSDIR}/audio/alsa-lib
+
+.include <bsd.port.mk>
diff --git a/audio/libmatemixer/distinfo b/audio/libmatemixer/distinfo
new file mode 100644
index 000000000000..b72f0caa0425
--- /dev/null
+++ b/audio/libmatemixer/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mate/libmatemixer-1.10.0.tar.xz) = a4edc285fa07e6f556a3d6e384c7535f26d3a0bbe1cdc56eadd4f0c034ee5551
+SIZE (mate/libmatemixer-1.10.0.tar.xz) = 380208
diff --git a/audio/libmatemixer/pkg-descr b/audio/libmatemixer/pkg-descr
new file mode 100644
index 000000000000..6ea6ce6c0270
--- /dev/null
+++ b/audio/libmatemixer/pkg-descr
@@ -0,0 +1,6 @@
+libmatemixer is a mixer library for MATE desktop.
+
+It provides an abstract API allowing access to mixer functionality available
+in the PulseAudio, ALSA and OSS sound systems.
+
+WWW: https://github.com/mate-desktop/libmatemixer
diff --git a/audio/libmatemixer/pkg-plist b/audio/libmatemixer/pkg-plist
new file mode 100644
index 000000000000..0c64f2bc2e05
--- /dev/null
+++ b/audio/libmatemixer/pkg-plist
@@ -0,0 +1,52 @@
+include/mate-mixer/libmatemixer/matemixer-app-info.h
+include/mate-mixer/libmatemixer/matemixer-context.h
+include/mate-mixer/libmatemixer/matemixer-device-switch.h
+include/mate-mixer/libmatemixer/matemixer-device.h
+include/mate-mixer/libmatemixer/matemixer-enum-types.h
+include/mate-mixer/libmatemixer/matemixer-enums.h
+include/mate-mixer/libmatemixer/matemixer-stored-control.h
+include/mate-mixer/libmatemixer/matemixer-stream-control.h
+include/mate-mixer/libmatemixer/matemixer-stream-switch.h
+include/mate-mixer/libmatemixer/matemixer-stream-toggle.h
+include/mate-mixer/libmatemixer/matemixer-stream.h
+include/mate-mixer/libmatemixer/matemixer-switch-option.h
+include/mate-mixer/libmatemixer/matemixer-switch.h
+include/mate-mixer/libmatemixer/matemixer-types.h
+include/mate-mixer/libmatemixer/matemixer-version.h
+include/mate-mixer/libmatemixer/matemixer.h
+lib/libmatemixer.a
+lib/libmatemixer.so
+lib/libmatemixer.so.0
+lib/libmatemixer.so.0.0.0
+%%ALSA%%lib/libmatemixer/libmatemixer-alsa.a
+%%ALSA%%lib/libmatemixer/libmatemixer-alsa.so
+lib/libmatemixer/libmatemixer-oss.a
+lib/libmatemixer/libmatemixer-oss.so
+%%PULSEAUDIO%%lib/libmatemixer/libmatemixer-pulse.a
+%%PULSEAUDIO%%lib/libmatemixer/libmatemixer-pulse.so
+libdata/pkgconfig/libmatemixer.pc
+share/gtk-doc/html/libmatemixer/MateMixerAppInfo.html
+share/gtk-doc/html/libmatemixer/MateMixerContext.html
+share/gtk-doc/html/libmatemixer/MateMixerDevice.html
+share/gtk-doc/html/libmatemixer/MateMixerDeviceSwitch.html
+share/gtk-doc/html/libmatemixer/MateMixerStoredControl.html
+share/gtk-doc/html/libmatemixer/MateMixerStream.html
+share/gtk-doc/html/libmatemixer/MateMixerStreamControl.html
+share/gtk-doc/html/libmatemixer/MateMixerStreamSwitch.html
+share/gtk-doc/html/libmatemixer/MateMixerStreamToggle.html
+share/gtk-doc/html/libmatemixer/MateMixerSwitch.html
+share/gtk-doc/html/libmatemixer/MateMixerSwitchOption.html
+share/gtk-doc/html/libmatemixer/api-index-full.html
+share/gtk-doc/html/libmatemixer/ch01.html
+share/gtk-doc/html/libmatemixer/home.png
+share/gtk-doc/html/libmatemixer/index.html
+share/gtk-doc/html/libmatemixer/index.sgml
+share/gtk-doc/html/libmatemixer/left-insensitive.png
+share/gtk-doc/html/libmatemixer/left.png
+share/gtk-doc/html/libmatemixer/libmatemixer-MateMixer.html
+share/gtk-doc/html/libmatemixer/libmatemixer.devhelp2
+share/gtk-doc/html/libmatemixer/right-insensitive.png
+share/gtk-doc/html/libmatemixer/right.png
+share/gtk-doc/html/libmatemixer/style.css
+share/gtk-doc/html/libmatemixer/up-insensitive.png
+share/gtk-doc/html/libmatemixer/up.png
diff --git a/audio/mate-media/Makefile b/audio/mate-media/Makefile
index 26cebfae8d7e..09bb1829d06d 100644
--- a/audio/mate-media/Makefile
+++ b/audio/mate-media/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mate-media
-PORTVERSION= 1.8.0
+PORTVERSION= 1.10.0
CATEGORIES= audio mate
MASTER_SITES= MATE
DIST_SUBDIR= mate
@@ -11,7 +11,9 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= Multimedia applications for the MATE desktop
BUILD_DEPENDS= itstool:${PORTSDIR}/textproc/itstool
-LIB_DEPENDS= libcanberra-gtk.so:${PORTSDIR}/audio/libcanberra
+LIB_DEPENDS= libcanberra-gtk.so:${PORTSDIR}/audio/libcanberra \
+ libmatemixer.so:${PORTSDIR}/audio/libmatemixer \
+ libunique-1.0.so:${PORTSDIR}/x11-toolkits/unique
PORTSCOUT= limitw:1,even
@@ -21,21 +23,10 @@ USE_GNOME= glib20 gtk20 intlhack libxml2
USE_LDCONFIG= yes
USE_GSTREAMER= good
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-gtk=2.0
INSTALLS_ICONS= yes
-CONFIGURE_ARGS= --disable-pulseaudio \
- --enable-gst-mixer-applet
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
-GLIB_SCHEMAS= org.mate.panel.applet.mixer.gschema.xml \
- org.mate.volume-control.gschema.xml
-
-post-patch:
- @${REINPLACE_CMD} -e 's|mixer_applet2|mate_mixer_applet2|g' \
- ${WRKSRC}/gst-mixer-applet/Makefile.in \
- ${WRKSRC}/gst-mixer-applet/load.c \
- ${WRKSRC}/gst-mixer-applet/org.mate.panel.applet.MixerAppletFactory.service.in \
- ${WRKSRC}/gst-mixer-applet/org.mate.applets.MixerApplet.mate-panel-applet.in.in
-
.include <bsd.port.mk>
diff --git a/audio/mate-media/distinfo b/audio/mate-media/distinfo
index de01a8e6fd2e..a208f6c3ef1b 100644
--- a/audio/mate-media/distinfo
+++ b/audio/mate-media/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mate/mate-media-1.8.0.tar.xz) = a264f9afcae7dff50aefb813616857db10ed62ac30c4071e690485ee9c6e5f61
-SIZE (mate/mate-media-1.8.0.tar.xz) = 939728
+SHA256 (mate/mate-media-1.10.0.tar.xz) = c8e57bf169a2687319a6ddb1c6db6e256b9edeb15ce3a3cc2762a76c96ed18fc
+SIZE (mate/mate-media-1.10.0.tar.xz) = 506300
diff --git a/audio/mate-media/pkg-plist b/audio/mate-media/pkg-plist
index 0d93d9d9d665..e3fdb3a3dff8 100644
--- a/audio/mate-media/pkg-plist
+++ b/audio/mate-media/pkg-plist
@@ -1,119 +1,9 @@
bin/mate-volume-control
-libexec/mate_mixer_applet2
+bin/mate-volume-control-applet
+etc/xdg/autostart/mate-volume-control-applet.desktop
+man/man1/mate-volume-control-applet.1.gz
man/man1/mate-volume-control.1.gz
-share/MateConf/gsettings/mate-volume-control.convert
share/applications/mate-volume-control.desktop
-share/dbus-1/services/org.mate.panel.applet.MixerAppletFactory.service
-share/help/C/mate-mixer_applet2/figures/volumecontrol_applet.png
-share/help/C/mate-mixer_applet2/index.docbook
-share/help/C/mate-mixer_applet2/legal.xml
-share/help/C/mate-volume-control/figures/mate-volume-control_window.png
-share/help/C/mate-volume-control/index.docbook
-share/help/C/mate-volume-control/legal.xml
-share/help/ca/mate-mixer_applet2/figures/volumecontrol_applet.png
-share/help/ca/mate-mixer_applet2/index.docbook
-share/help/ca/mate-mixer_applet2/legal.xml
-share/help/ca/mate-volume-control/figures/mate-volume-control_window.png
-share/help/ca/mate-volume-control/index.docbook
-share/help/ca/mate-volume-control/legal.xml
-share/help/cs/mate-mixer_applet2/figures/volumecontrol_applet.png
-share/help/cs/mate-mixer_applet2/index.docbook
-share/help/cs/mate-mixer_applet2/legal.xml
-share/help/cs/mate-volume-control/figures/mate-volume-control_window.png
-share/help/cs/mate-volume-control/index.docbook
-share/help/cs/mate-volume-control/legal.xml
-share/help/da/mate-mixer_applet2/figures/volumecontrol_applet.png
-share/help/da/mate-mixer_applet2/index.docbook
-share/help/da/mate-mixer_applet2/legal.xml
-share/help/da/mate-volume-control/figures/mate-volume-control_window.png
-share/help/da/mate-volume-control/index.docbook
-share/help/da/mate-volume-control/legal.xml
-share/help/de/mate-mixer_applet2/figures/volumecontrol_applet.png
-share/help/de/mate-mixer_applet2/index.docbook
-share/help/de/mate-mixer_applet2/legal.xml
-share/help/de/mate-volume-control/figures/mate-volume-control_window.png
-share/help/de/mate-volume-control/index.docbook
-share/help/de/mate-volume-control/legal.xml
-share/help/el/mate-mixer_applet2/figures/volumecontrol_applet.png
-share/help/el/mate-mixer_applet2/index.docbook
-share/help/el/mate-mixer_applet2/legal.xml
-share/help/el/mate-volume-control/figures/mate-volume-control_window.png
-share/help/el/mate-volume-control/index.docbook
-share/help/el/mate-volume-control/legal.xml
-share/help/en_GB/mate-mixer_applet2/figures/volumecontrol_applet.png
-share/help/en_GB/mate-mixer_applet2/index.docbook
-share/help/en_GB/mate-mixer_applet2/legal.xml
-share/help/en_GB/mate-volume-control/figures/mate-volume-control_window.png
-share/help/en_GB/mate-volume-control/index.docbook
-share/help/en_GB/mate-volume-control/legal.xml
-share/help/es/mate-mixer_applet2/figures/volumecontrol_applet.png
-share/help/es/mate-mixer_applet2/index.docbook
-share/help/es/mate-mixer_applet2/legal.xml
-share/help/es/mate-volume-control/figures/mate-volume-control_window.png
-share/help/es/mate-volume-control/index.docbook
-share/help/es/mate-volume-control/legal.xml
-share/help/eu/mate-mixer_applet2/figures/volumecontrol_applet.png
-share/help/eu/mate-mixer_applet2/index.docbook
-share/help/eu/mate-mixer_applet2/legal.xml
-share/help/fi/mate-mixer_applet2/figures/volumecontrol_applet.png
-share/help/fi/mate-mixer_applet2/index.docbook
-share/help/fi/mate-mixer_applet2/legal.xml
-share/help/fr/mate-mixer_applet2/figures/volumecontrol_applet.png
-share/help/fr/mate-mixer_applet2/index.docbook
-share/help/fr/mate-mixer_applet2/legal.xml
-share/help/fr/mate-volume-control/figures/mate-volume-control_window.png
-share/help/fr/mate-volume-control/index.docbook
-share/help/fr/mate-volume-control/legal.xml
-share/help/hu/mate-mixer_applet2/figures/volumecontrol_applet.png
-share/help/hu/mate-mixer_applet2/index.docbook
-share/help/hu/mate-mixer_applet2/legal.xml
-share/help/it/mate-mixer_applet2/figures/volumecontrol_applet.png
-share/help/it/mate-mixer_applet2/index.docbook
-share/help/it/mate-mixer_applet2/legal.xml
-share/help/it/mate-volume-control/figures/mate-volume-control_window.png
-share/help/it/mate-volume-control/index.docbook
-share/help/it/mate-volume-control/legal.xml
-share/help/ko/mate-mixer_applet2/figures/volumecontrol_applet.png
-share/help/ko/mate-mixer_applet2/index.docbook
-share/help/ko/mate-mixer_applet2/legal.xml
-share/help/oc/mate-mixer_applet2/figures/volumecontrol_applet.png
-share/help/oc/mate-mixer_applet2/index.docbook
-share/help/oc/mate-mixer_applet2/legal.xml
-share/help/oc/mate-volume-control/figures/mate-volume-control_window.png
-share/help/oc/mate-volume-control/index.docbook
-share/help/oc/mate-volume-control/legal.xml
-share/help/pa/mate-mixer_applet2/figures/volumecontrol_applet.png
-share/help/pa/mate-mixer_applet2/index.docbook
-share/help/pa/mate-mixer_applet2/legal.xml
-share/help/pt_BR/mate-mixer_applet2/figures/volumecontrol_applet.png
-share/help/pt_BR/mate-mixer_applet2/index.docbook
-share/help/pt_BR/mate-mixer_applet2/legal.xml
-share/help/ru/mate-mixer_applet2/figures/volumecontrol_applet.png
-share/help/ru/mate-mixer_applet2/index.docbook
-share/help/ru/mate-mixer_applet2/legal.xml
-share/help/ru/mate-volume-control/figures/mate-volume-control_window.png
-share/help/ru/mate-volume-control/index.docbook
-share/help/ru/mate-volume-control/legal.xml
-share/help/sv/mate-mixer_applet2/figures/volumecontrol_applet.png
-share/help/sv/mate-mixer_applet2/index.docbook
-share/help/sv/mate-mixer_applet2/legal.xml
-share/help/sv/mate-volume-control/figures/mate-volume-control_window.png
-share/help/sv/mate-volume-control/index.docbook
-share/help/sv/mate-volume-control/legal.xml
-share/help/uk/mate-mixer_applet2/figures/volumecontrol_applet.png
-share/help/uk/mate-mixer_applet2/index.docbook
-share/help/uk/mate-mixer_applet2/legal.xml
-share/help/zh_CN/mate-mixer_applet2/figures/volumecontrol_applet.png
-share/help/zh_CN/mate-mixer_applet2/index.docbook
-share/help/zh_CN/mate-mixer_applet2/legal.xml
-share/help/zh_CN/mate-volume-control/figures/mate-volume-control_window.png
-share/help/zh_CN/mate-volume-control/index.docbook
-share/help/zh_CN/mate-volume-control/legal.xml
-share/icons/mate/16x16/devices/gvc-3d-sound.png
-share/icons/mate/16x16/devices/gvc-headphones.png
-share/icons/mate/16x16/devices/gvc-line-in.png
-share/icons/mate/16x16/devices/gvc-tone.png
-share/icons/mate/16x16/status/audio-input-microphone-muted.png
share/locale/af/LC_MESSAGES/mate-media.mo
share/locale/am/LC_MESSAGES/mate-media.mo
share/locale/ar/LC_MESSAGES/mate-media.mo
@@ -206,11 +96,45 @@ share/locale/xh/LC_MESSAGES/mate-media.mo
share/locale/zh_CN/LC_MESSAGES/mate-media.mo
share/locale/zh_HK/LC_MESSAGES/mate-media.mo
share/locale/zh_TW/LC_MESSAGES/mate-media.mo
-share/mate-2.0/ui/mixer-applet-menu.xml
-%%DATADIR%%/pixmaps/chain-broken.png
-%%DATADIR%%/pixmaps/chain.png
+%%DATADIR%%/icons/mate/16x16/status/audio-input-microphone-high.png
+%%DATADIR%%/icons/mate/16x16/status/audio-input-microphone-low.png
+%%DATADIR%%/icons/mate/16x16/status/audio-input-microphone-medium.png
+%%DATADIR%%/icons/mate/16x16/status/audio-input-microphone-muted.png
+%%DATADIR%%/icons/mate/22x22/status/audio-input-microphone-high.png
+%%DATADIR%%/icons/mate/22x22/status/audio-input-microphone-low.png
+%%DATADIR%%/icons/mate/22x22/status/audio-input-microphone-medium.png
+%%DATADIR%%/icons/mate/22x22/status/audio-input-microphone-muted.png
+%%DATADIR%%/icons/mate/24x24/status/audio-input-microphone-high.png
+%%DATADIR%%/icons/mate/24x24/status/audio-input-microphone-low.png
+%%DATADIR%%/icons/mate/24x24/status/audio-input-microphone-medium.png
+%%DATADIR%%/icons/mate/24x24/status/audio-input-microphone-muted.png
+%%DATADIR%%/icons/mate/32x32/status/audio-input-microphone-high.png
+%%DATADIR%%/icons/mate/32x32/status/audio-input-microphone-low.png
+%%DATADIR%%/icons/mate/32x32/status/audio-input-microphone-medium.png
+%%DATADIR%%/icons/mate/32x32/status/audio-input-microphone-muted.png
+%%DATADIR%%/icons/mate/48x48/devices/audio-speaker-center-back-testing.svg
+%%DATADIR%%/icons/mate/48x48/devices/audio-speaker-center-back.svg
+%%DATADIR%%/icons/mate/48x48/devices/audio-speaker-center-testing.svg
+%%DATADIR%%/icons/mate/48x48/devices/audio-speaker-center.svg
+%%DATADIR%%/icons/mate/48x48/devices/audio-speaker-left-back-testing.svg
+%%DATADIR%%/icons/mate/48x48/devices/audio-speaker-left-back.svg
+%%DATADIR%%/icons/mate/48x48/devices/audio-speaker-left-side-testing.svg
+%%DATADIR%%/icons/mate/48x48/devices/audio-speaker-left-side.svg
+%%DATADIR%%/icons/mate/48x48/devices/audio-speaker-left-testing.svg
+%%DATADIR%%/icons/mate/48x48/devices/audio-speaker-left.svg
+%%DATADIR%%/icons/mate/48x48/devices/audio-speaker-right-back-testing.svg
+%%DATADIR%%/icons/mate/48x48/devices/audio-speaker-right-back.svg
+%%DATADIR%%/icons/mate/48x48/devices/audio-speaker-right-side-testing.svg
+%%DATADIR%%/icons/mate/48x48/devices/audio-speaker-right-side.svg
+%%DATADIR%%/icons/mate/48x48/devices/audio-speaker-right-testing.svg
+%%DATADIR%%/icons/mate/48x48/devices/audio-speaker-right.svg
+%%DATADIR%%/icons/mate/48x48/devices/audio-subwoofer-testing.svg
+%%DATADIR%%/icons/mate/48x48/devices/audio-subwoofer.svg
+%%DATADIR%%/icons/mate/scalable/status/audio-input-microphone-high.svg
+%%DATADIR%%/icons/mate/scalable/status/audio-input-microphone-low.svg
+%%DATADIR%%/icons/mate/scalable/status/audio-input-microphone-medium.svg
+%%DATADIR%%/icons/mate/scalable/status/audio-input-microphone-muted.svg
%%DATADIR%%/sounds/mate-sounds-default.xml
-share/mate-panel/applets/org.mate.applets.MixerApplet.mate-panel-applet
share/sounds/mate/default/alerts/bark.ogg
share/sounds/mate/default/alerts/drip.ogg
share/sounds/mate/default/alerts/glass.ogg