aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-10-06 05:17:04 +0800
committermiwi <miwi@FreeBSD.org>2007-10-06 05:17:04 +0800
commit0764c82720f35410fb715cf16170dd9553e70dfa (patch)
treea3e4d0208a95469543a745bc9d65a5805aa7a1a6 /audio
parentdf5b0809ee94417f77f48f773a4a8d320f02299e (diff)
downloadfreebsd-ports-gnome-0764c82720f35410fb715cf16170dd9553e70dfa.tar.gz
freebsd-ports-gnome-0764c82720f35410fb715cf16170dd9553e70dfa.tar.zst
freebsd-ports-gnome-0764c82720f35410fb715cf16170dd9553e70dfa.zip
MP3Unicode is a command line utility to convert ID3 tags in mp3
files between different encodings. WWW: http://mp3unicode.sourceforge.net/ PR: ports/116739 Submitted by: Max Brazhnikov <makc at issp.ac.ru>
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/mp3unicode/Makefile29
-rw-r--r--audio/mp3unicode/distinfo3
-rw-r--r--audio/mp3unicode/files/patch-mp3unicode.cpp12
-rw-r--r--audio/mp3unicode/pkg-descr4
5 files changed, 49 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 52b98fcdfa35..57bd12223a6e 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -403,6 +403,7 @@
SUBDIR += mp3splt
SUBDIR += mp3stat
SUBDIR += mp3towav-bundle
+ SUBDIR += mp3unicode
SUBDIR += mp3wrap
SUBDIR += mpc
SUBDIR += mpdcon
diff --git a/audio/mp3unicode/Makefile b/audio/mp3unicode/Makefile
new file mode 100644
index 000000000000..dc945c15b09b
--- /dev/null
+++ b/audio/mp3unicode/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: mp3unicode
+# Date created: 2007-09-29
+# Whom: Max Brazhnikov <makc@issp.ac.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mp3unicode
+PORTVERSION= 1.2
+CATEGORIES= audio
+MASTER_SITES= SF
+
+MAINTAINER= makc@issp.ac.ru
+COMMENT= ID3 tags charset converter
+
+LIB_DEPENDS= tag.5:${PORTSDIR}/audio/taglib/
+
+USE_BZIP2= yes
+USE_ICONV= yes
+USE_GNOME= pkgconfig
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= ICONV_CFLAGS="-I${LOCALBASE}/include" \
+ ICONV_LIBS="-L${LOCALBASE}/lib -liconv"
+
+MAN1= mp3unicode.1
+PLIST_FILES= bin/mp3unicode
+PORTDOCS= COPYING README
+
+.include <bsd.port.mk>
diff --git a/audio/mp3unicode/distinfo b/audio/mp3unicode/distinfo
new file mode 100644
index 000000000000..0486fd10e52b
--- /dev/null
+++ b/audio/mp3unicode/distinfo
@@ -0,0 +1,3 @@
+MD5 (mp3unicode-1.2.tar.bz2) = 36665ee3ed71585e377f46fda6124a09
+SHA256 (mp3unicode-1.2.tar.bz2) = 7788dde056204d003f32f07aa99ed46b1599ecfc0e9e12c8b559fa1072ffb74b
+SIZE (mp3unicode-1.2.tar.bz2) = 95372
diff --git a/audio/mp3unicode/files/patch-mp3unicode.cpp b/audio/mp3unicode/files/patch-mp3unicode.cpp
new file mode 100644
index 000000000000..9cb405af1513
--- /dev/null
+++ b/audio/mp3unicode/files/patch-mp3unicode.cpp
@@ -0,0 +1,12 @@
+--- ./mp3unicode.cpp.orig 2007-09-25 14:57:33.000000000 +0400
++++ ./mp3unicode.cpp 2007-09-29 15:16:49.000000000 +0400
+@@ -200,9 +200,6 @@
+ if (
+ iconv (
+ cd,
+-#if !defined(_LIBICONV_VERSION) || _LIBICONV_VERSION < 0x010B
+- (char **)
+-#endif
+ &from,
+ &from_size,
+ &to,
diff --git a/audio/mp3unicode/pkg-descr b/audio/mp3unicode/pkg-descr
new file mode 100644
index 000000000000..bc0b65e3ca62
--- /dev/null
+++ b/audio/mp3unicode/pkg-descr
@@ -0,0 +1,4 @@
+MP3Unicode is a command line utility to convert ID3 tags in mp3
+files between different encodings.
+
+WWW: http://mp3unicode.sourceforge.net/