aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-04-06 09:29:15 +0800
committeredwin <edwin@FreeBSD.org>2003-04-06 09:29:15 +0800
commit3922b75bc64942b36657c87990495f0fe0dab237 (patch)
tree6ff2d554ae304f2902720330955e59fd8a66b5ce /audio
parent399266fc4f792f1d3596d74a3cb7f9be29da2b39 (diff)
downloadfreebsd-ports-gnome-3922b75bc64942b36657c87990495f0fe0dab237.tar.gz
freebsd-ports-gnome-3922b75bc64942b36657c87990495f0fe0dab237.tar.zst
freebsd-ports-gnome-3922b75bc64942b36657c87990495f0fe0dab237.zip
audio/beep: beep for a pitch and duration
PR: ports/39062 Submitted by: Tyler Spivey <tspivey8@telus.net>
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/beep/Makefile21
-rw-r--r--audio/beep/distinfo1
-rw-r--r--audio/beep/pkg-descr5
-rw-r--r--audio/beep/pkg-plist1
5 files changed, 29 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 6064eeeb4d28..ad904decdbfa 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -22,6 +22,7 @@
SUBDIR += autools
SUBDIR += autozen
SUBDIR += baudline
+ SUBDIR += beep
SUBDIR += bladeenc
SUBDIR += blop
SUBDIR += bonk
diff --git a/audio/beep/Makefile b/audio/beep/Makefile
new file mode 100644
index 000000000000..75eb07a0d1a6
--- /dev/null
+++ b/audio/beep/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: beep
+# Date Created: June 9, 2002
+# Whom: Tyler Spivey
+#
+# $FreeBSD$
+
+PORTNAME= beep
+PORTVERSION= 1.0
+CATEGORIES= audio
+MASTER_SITES= ftp://ftp.ugh.net.au/pub/unix/beep/ \
+ ftp://ftp.megamirror.com/pub/ugh/unix/beep/ \
+ http://ftp.megamirror.com/pub/ugh/unix/beep/
+
+MAINTAINER= tspivey8@telus.net
+COMMENT= Beeps a certain duration and pitch out of the PC Speaker
+
+MAN1= beep.1
+MANCOMPRESSED= maybe
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/audio/beep/distinfo b/audio/beep/distinfo
new file mode 100644
index 000000000000..33477ee4b314
--- /dev/null
+++ b/audio/beep/distinfo
@@ -0,0 +1 @@
+MD5 (beep-1.0.tar.gz) = 4e473b0922445d8dbd7103c24f47dc23
diff --git a/audio/beep/pkg-descr b/audio/beep/pkg-descr
new file mode 100644
index 000000000000..2dfb3070f06f
--- /dev/null
+++ b/audio/beep/pkg-descr
@@ -0,0 +1,5 @@
+This program will beep, using a
+duration and pitch specified on the command line or the program's defaults.
+
+- Tyler Spivey
+tspivey8@telus.net
diff --git a/audio/beep/pkg-plist b/audio/beep/pkg-plist
new file mode 100644
index 000000000000..bca01666f23c
--- /dev/null
+++ b/audio/beep/pkg-plist
@@ -0,0 +1 @@
+bin/beep