aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2006-06-16 20:37:11 +0800
committerdanfe <danfe@FreeBSD.org>2006-06-16 20:37:11 +0800
commit670067dc4b6a4d804059c882a2aab55d1fd1e543 (patch)
tree2409232e3b3bf244e1dd80ecb93b5ab7a89b7e1e /audio
parented23d1f11cbd48a043d055af7cf5b8e95d9acac3 (diff)
downloadfreebsd-ports-gnome-670067dc4b6a4d804059c882a2aab55d1fd1e543.tar.gz
freebsd-ports-gnome-670067dc4b6a4d804059c882a2aab55d1fd1e543.tar.zst
freebsd-ports-gnome-670067dc4b6a4d804059c882a2aab55d1fd1e543.zip
Fix the build with older GCC.
Reported by: krismail
Diffstat (limited to 'audio')
-rw-r--r--audio/libgpod/Makefile21
1 files changed, 17 insertions, 4 deletions
diff --git a/audio/libgpod/Makefile b/audio/libgpod/Makefile
index e2250d4ed48d..3a71231e3574 100644
--- a/audio/libgpod/Makefile
+++ b/audio/libgpod/Makefile
@@ -22,10 +22,23 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-post-extract:
- @${REINPLACE_CMD} -e \
+.include <bsd.port.pre.mk>
+
+post-extract: .SILENT
+ ${REINPLACE_CMD} -e \
's,libdir)/pkgconfig,prefix)/libdata/pkgconfig,' \
${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} '19323,19345d' ${WRKSRC}/configure
+ ${REINPLACE_CMD} '19323,19345d' ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e '25s,^,#include <sys/types.h>,' \
+ ${WRKSRC}/src/db-parse-context.c
+.if defined(GCCVERSION)
+. if ${GCCVERSION} < 030000
+ ${REINPLACE_CMD} -e 's,\[\],[0],' ${WRKSRC}/src/db-itunes-parser.h
+. endif
+.else
+. if ${OSVERSION} < 500035
+ ${REINPLACE_CMD} -e 's,\[\],[0],' ${WRKSRC}/src/db-itunes-parser.h
+. endif
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>