aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2017-11-12 02:26:15 +0800
committeryuri <yuri@FreeBSD.org>2017-11-12 02:26:15 +0800
commit82094d2c3a7a7d97ff407a906cec3829ed77f2a1 (patch)
tree4634c71ccb3c324b71b016e0bf64cc73c993ab4e /audio
parenta41f61f9173a7b53875f0f5ce5f99a54c7f04511 (diff)
downloadfreebsd-ports-gnome-82094d2c3a7a7d97ff407a906cec3829ed77f2a1.tar.gz
freebsd-ports-gnome-82094d2c3a7a7d97ff407a906cec3829ed77f2a1.tar.zst
freebsd-ports-gnome-82094d2c3a7a7d97ff407a906cec3829ed77f2a1.zip
New port: audio/abgate-lv2: Noise gate LV2 plugin
PR: 221683 Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D12986
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/abgate-lv2/Makefile41
-rw-r--r--audio/abgate-lv2/distinfo3
-rw-r--r--audio/abgate-lv2/pkg-descr3
-rw-r--r--audio/abgate-lv2/pkg-plist9
5 files changed, 57 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 90a34e067fda..589ace7b0587 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -10,6 +10,7 @@
SUBDIR += abcde
SUBDIR += abcmidi
SUBDIR += abcselect
+ SUBDIR += abgate-lv2
SUBDIR += abraca
SUBDIR += acoustid-fingerprinter
SUBDIR += adplay
diff --git a/audio/abgate-lv2/Makefile b/audio/abgate-lv2/Makefile
new file mode 100644
index 000000000000..f719465878a0
--- /dev/null
+++ b/audio/abgate-lv2/Makefile
@@ -0,0 +1,41 @@
+# $FreeBSD$
+
+PORTNAME= abGate
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.1.9
+CATEGORIES= audio
+PKGNAMESUFFIX= -lv2
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Noise gate LV2 plugin
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= lv2>0:audio/lv2
+
+USES= gmake pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= antanasbruzas
+USE_CXXSTD= c++11
+USE_QT4= corelib gui moc_build rcc_build qmake_build uic_build
+USE_GNOME= atkmm gtk20 gtkmm24 libsigc++20
+USE_LDCONFIG= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e ' \
+ s|PREFIX = |PREFIX ?= |; \
+ s|g++|$$(CXX)|; \
+ s|CPPFLAGS|CXXFLAGS|; \
+ s| -g -O3||; \
+ s|cd abGateQt; qmake; make|cd abGateQt; qmake \&\& $$(MAKE)|' \
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -E ' \
+ s|^QMAKE_CXXFLAGS (.*)|QMAKE_CXXFLAGS = ${CXXFLAGS}|; \
+ s|^QMAKE_LFLAGS (.*)|QMAKE_LFLAGS = ${LDFLAGS}|' \
+ ${WRKSRC}/abGateQt/abGateQt.pro
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lv2/abGate.lv2/*.so
+
+.include <bsd.port.mk>
diff --git a/audio/abgate-lv2/distinfo b/audio/abgate-lv2/distinfo
new file mode 100644
index 000000000000..ec70f8eee183
--- /dev/null
+++ b/audio/abgate-lv2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1510096119
+SHA256 (antanasbruzas-abGate-v1.1.9_GH0.tar.gz) = 898b50cce44dffedd82ec0e6d6d043a9d26534fbf07898d099575ea4c1057721
+SIZE (antanasbruzas-abGate-v1.1.9_GH0.tar.gz) = 814739
diff --git a/audio/abgate-lv2/pkg-descr b/audio/abgate-lv2/pkg-descr
new file mode 100644
index 000000000000..5cda8c072662
--- /dev/null
+++ b/audio/abgate-lv2/pkg-descr
@@ -0,0 +1,3 @@
+abGate is LV2 noise gate plugin.
+
+WWW: https://github.com/antanasbruzas/abGate
diff --git a/audio/abgate-lv2/pkg-plist b/audio/abgate-lv2/pkg-plist
new file mode 100644
index 000000000000..8b32c7ede50a
--- /dev/null
+++ b/audio/abgate-lv2/pkg-plist
@@ -0,0 +1,9 @@
+lib/lv2/abGate.lv2/background.png
+lib/lv2/abGate.lv2/bypass_off.png
+lib/lv2/abGate.lv2/bypass_on.png
+lib/lv2/abGate.lv2/gate.so
+lib/lv2/abGate.lv2/gate.ttl
+lib/lv2/abGate.lv2/gate_gui.so
+lib/lv2/abGate.lv2/knob.png
+lib/lv2/abGate.lv2/libabGateQt.so
+lib/lv2/abGate.lv2/manifest.ttl