aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2001-12-21 03:05:37 +0800
committerlioux <lioux@FreeBSD.org>2001-12-21 03:05:37 +0800
commit91aa58154f15d93f74c98dc19ba03b0b4a959c6b (patch)
treec2fe2423403a9c13555eb6eb563547abd4f3d9d4 /audio
parent85fc508328bc0f23b1b6df87c24fa145574e2a7c (diff)
downloadfreebsd-ports-gnome-91aa58154f15d93f74c98dc19ba03b0b4a959c6b.tar.gz
freebsd-ports-gnome-91aa58154f15d93f74c98dc19ba03b0b4a959c6b.tar.zst
freebsd-ports-gnome-91aa58154f15d93f74c98dc19ba03b0b4a959c6b.zip
o If either WITH_LIBARTS or WITH_VORBIS were defined, LIB_DEPENDS
information was being lost. Fix this o Also, correctly LIB_DEPENDS on artsc.0 Approved by: maintainer
Diffstat (limited to 'audio')
-rw-r--r--audio/freeamp/Makefile4
-rw-r--r--audio/zinf/Makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/audio/freeamp/Makefile b/audio/freeamp/Makefile
index 88d85a04da6c..95fc9570ef56 100644
--- a/audio/freeamp/Makefile
+++ b/audio/freeamp/Makefile
@@ -43,7 +43,7 @@ PLIST_SUB+= ESOUND="@comment "
.endif
.if defined(WITH_LIBARTS) || defined(WITH_ALL_PLUGINS)
-LIB_DEPENDS= libartsc.0:${PORTSDIR}/x11/kdelibs2
+LIB_DEPENDS+= artsc.0:${PORTSDIR}/x11/kdelibs2
PLIST_SUB+= LIBARTS=""
.else
CONFIGURE_ARGS+= --disable-arts
@@ -51,7 +51,7 @@ PLIST_SUB+= LIBARTS="@comment "
.endif
.if defined(WITH_VORBIS) || defined(WITH_ALL_PLUGINS)
-LIB_DEPENDS= vorbis.0:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS+= vorbis.0:${PORTSDIR}/audio/libvorbis
PLIST_SUB+= VORBIS=""
.else
CONFIGURE_ARGS+= --disable-vorbis
diff --git a/audio/zinf/Makefile b/audio/zinf/Makefile
index 88d85a04da6c..95fc9570ef56 100644
--- a/audio/zinf/Makefile
+++ b/audio/zinf/Makefile
@@ -43,7 +43,7 @@ PLIST_SUB+= ESOUND="@comment "
.endif
.if defined(WITH_LIBARTS) || defined(WITH_ALL_PLUGINS)
-LIB_DEPENDS= libartsc.0:${PORTSDIR}/x11/kdelibs2
+LIB_DEPENDS+= artsc.0:${PORTSDIR}/x11/kdelibs2
PLIST_SUB+= LIBARTS=""
.else
CONFIGURE_ARGS+= --disable-arts
@@ -51,7 +51,7 @@ PLIST_SUB+= LIBARTS="@comment "
.endif
.if defined(WITH_VORBIS) || defined(WITH_ALL_PLUGINS)
-LIB_DEPENDS= vorbis.0:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS+= vorbis.0:${PORTSDIR}/audio/libvorbis
PLIST_SUB+= VORBIS=""
.else
CONFIGURE_ARGS+= --disable-vorbis