aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2003-06-10 23:43:13 +0800
committernaddy <naddy@FreeBSD.org>2003-06-10 23:43:13 +0800
commitb9e7317ea825a5989898a849e787cac12e457ffd (patch)
tree935f5b5fa56b7c2eba4e144a3e04a0ff7488fd04 /audio
parenta9ad0fb855684603f41b366457fd612fe688df04 (diff)
downloadfreebsd-ports-gnome-b9e7317ea825a5989898a849e787cac12e457ffd.tar.gz
freebsd-ports-gnome-b9e7317ea825a5989898a849e787cac12e457ffd.tar.zst
freebsd-ports-gnome-b9e7317ea825a5989898a849e787cac12e457ffd.zip
Spin off the XMMS FLAC plugin into its proper port.
PR: 52456 Suggested by: David Yeske <dyeske@yahoo.com>
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/xmms-flac/Makefile38
-rw-r--r--audio/xmms-flac/distinfo2
-rw-r--r--audio/xmms-flac/files/Makefile8
-rw-r--r--audio/xmms-flac/files/patch-configure40
-rw-r--r--audio/xmms-flac/files/patch-src_plugin__xmms_Makefile.in25
-rw-r--r--audio/xmms-flac/pkg-descr5
-rw-r--r--audio/xmms-flac/pkg-plist2
8 files changed, 121 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 10948dd19ba2..d525b4428868 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -333,6 +333,7 @@
SUBDIR += xmms-crystality
SUBDIR += xmms-faad
SUBDIR += xmms-fc
+ SUBDIR += xmms-flac
SUBDIR += xmms-kde
SUBDIR += xmms-ladspa
SUBDIR += xmms-liveice
diff --git a/audio/xmms-flac/Makefile b/audio/xmms-flac/Makefile
new file mode 100644
index 000000000000..a045c2a33767
--- /dev/null
+++ b/audio/xmms-flac/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: xmms-flac
+# Date created: 2003-06-10
+# Whom: Christian Weisgerber <naddy@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmms-flac
+PORTVERSION= 1.1.0
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= flac
+DISTNAME= flac-${PORTVERSION}
+
+PATCH_SITES= ${MASTER_SITE_DEBIAN}
+PATCH_SITE_SUBDIR= pool/main/f/flac
+PATCHFILES= flac_1.1.0-3.diff.gz
+PATCH_DIST_STRIP= -p1
+
+MAINTAINER= naddy@FreeBSD.org
+COMMENT= XMMS input plugin for playing FLAC files
+
+LIB_DEPENDS= xmms.3:${PORTSDIR}/multimedia/xmms \
+ FLAC.5:${PORTSDIR}/audio/flac
+
+USE_X_PREFIX= yes
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= --with-libiconv-prefix="${LOCALBASE}" \
+ --with-ogg="${LOCALBASE}" \
+ --with-xmms-prefix="${X11BASE}"
+
+MAKEFILE= ${FILESDIR}/Makefile
+
+# "obj" is magic to our make(1)
+post-configure:
+ @${RM} -rf ${WRKSRC}/obj
+
+.include <bsd.port.mk>
diff --git a/audio/xmms-flac/distinfo b/audio/xmms-flac/distinfo
new file mode 100644
index 000000000000..9cba2f63ef9b
--- /dev/null
+++ b/audio/xmms-flac/distinfo
@@ -0,0 +1,2 @@
+MD5 (flac-1.1.0.tar.gz) = 19b456a27b5fcf502c76cc33f33e1490
+MD5 (flac_1.1.0-3.diff.gz) = 28443cf10cbc7fc29ddfa5df48474b06
diff --git a/audio/xmms-flac/files/Makefile b/audio/xmms-flac/files/Makefile
new file mode 100644
index 000000000000..070ccdf5cdec
--- /dev/null
+++ b/audio/xmms-flac/files/Makefile
@@ -0,0 +1,8 @@
+# $FreeBSD$
+
+SUBDIRS= src/share src/plugin_common src/plugin_xmms
+
+all install:
+ @for d in ${SUBDIRS}; do \
+ (cd $$d; ${MAKE} $@); \
+ done
diff --git a/audio/xmms-flac/files/patch-configure b/audio/xmms-flac/files/patch-configure
new file mode 100644
index 000000000000..b16793a26fae
--- /dev/null
+++ b/audio/xmms-flac/files/patch-configure
@@ -0,0 +1,40 @@
+
+$FreeBSD$
+
+--- configure.orig Sun Feb 23 01:11:25 2003
++++ configure Sun Feb 23 01:11:27 2003
+@@ -7817,6 +7817,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+@@ -9818,6 +9819,8 @@
+ fi
+
+
++# Disable id3lib detection
++if false; then
+
+ # Check whether --with-id3lib or --without-id3lib was given.
+ if test "${with_id3lib+set}" = set; then
+@@ -10006,6 +10009,8 @@
+
+ rm -f conf.id3libtest
+
++fi
++have_id3lib=no
+
+
+ if test x$have_id3lib = xyes; then
+@@ -11713,7 +11718,7 @@
+ if test x$debug = xtrue; then
+ OUR_CFLAGS_HEAD="$OUR_CFLAGS_HEAD -g -O0 -DDEBUG"
+ else
+- OUR_CFLAGS_HEAD="$OUR_CFLAGS_HEAD -O3 -DNDEBUG"
++ OUR_CFLAGS_HEAD="$OUR_CFLAGS_HEAD -DNDEBUG"
+ if test x$GCC = xyes; then
+ OUR_CFLAGS_HEAD="$OUR_CFLAGS_HEAD -fomit-frame-pointer -funroll-loops -finline-functions -Wall -W -Winline -DFLaC__INLINE=__inline__"
+ fi
diff --git a/audio/xmms-flac/files/patch-src_plugin__xmms_Makefile.in b/audio/xmms-flac/files/patch-src_plugin__xmms_Makefile.in
new file mode 100644
index 000000000000..7c784eaa96b1
--- /dev/null
+++ b/audio/xmms-flac/files/patch-src_plugin__xmms_Makefile.in
@@ -0,0 +1,25 @@
+
+$FreeBSD$
+
+--- src/plugin_xmms/Makefile.in.orig Tue Jun 10 00:24:23 2003
++++ src/plugin_xmms/Makefile.in Tue Jun 10 00:25:16 2003
+@@ -173,8 +173,7 @@
+ $(top_builddir)/src/share/grabbag/libgrabbag.la \
+ $(top_builddir)/src/share/gain_analysis/libgain_analysis.la \
+ $(top_builddir)/src/share/utf8/libutf8.la \
+- $(top_builddir)/src/libFLAC/libFLAC.la \
+- -L$(top_builddir)/src/libFLAC/.libs \
++ -lFLAC \
+ @XMMS_LIBS@ \
+ @ID3LIB_LIBS@
+
+@@ -189,8 +188,7 @@
+ $(top_builddir)/src/plugin_common/libplugin_common.la \
+ $(top_builddir)/src/share/grabbag/libgrabbag.la \
+ $(top_builddir)/src/share/gain_analysis/libgain_analysis.la \
+- $(top_builddir)/src/share/utf8/libutf8.la \
+- $(top_builddir)/src/libFLAC/libFLAC.la
++ $(top_builddir)/src/share/utf8/libutf8.la
+ am__objects_1 = charset.lo configure.lo plugin.lo wrap_id3.lo \
+ fileinfo.lo
+ @FLaC__HAS_ID3LIB_TRUE@am_libxmms_flac_la_OBJECTS = $(am__objects_1)
diff --git a/audio/xmms-flac/pkg-descr b/audio/xmms-flac/pkg-descr
new file mode 100644
index 000000000000..3de8dcdd0c2d
--- /dev/null
+++ b/audio/xmms-flac/pkg-descr
@@ -0,0 +1,5 @@
+FLAC stands for Free Lossless Audio Codec.
+
+This is an XMMS input plugin for FLAC files.
+
+WWW: http://flac.sourceforge.net/
diff --git a/audio/xmms-flac/pkg-plist b/audio/xmms-flac/pkg-plist
new file mode 100644
index 000000000000..86f5f1c65107
--- /dev/null
+++ b/audio/xmms-flac/pkg-plist
@@ -0,0 +1,2 @@
+@comment $FreeBSD$
+lib/xmms/Input/libxmms-flac.so