aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-02-18 06:47:16 +0800
committerpav <pav@FreeBSD.org>2005-02-18 06:47:16 +0800
commitee9de4209c04b0e251eaf379588c83581e52f6ae (patch)
treeb4690fd81f8f8d8b530c7cde9b60340a679241db /audio
parent6fb6dcc1cf657960756605b27861c4fcff6cec76 (diff)
downloadfreebsd-ports-gnome-ee9de4209c04b0e251eaf379588c83581e52f6ae.tar.gz
freebsd-ports-gnome-ee9de4209c04b0e251eaf379588c83581e52f6ae.tar.zst
freebsd-ports-gnome-ee9de4209c04b0e251eaf379588c83581e52f6ae.zip
- Unbreak
PR: ports/77612 Submitted by: Johan van Selst <johans@stack.nl>
Diffstat (limited to 'audio')
-rw-r--r--audio/xsidplay/Makefile4
-rw-r--r--audio/xsidplay/files/patch-src-songlendb-File.cpp22
2 files changed, 22 insertions, 4 deletions
diff --git a/audio/xsidplay/Makefile b/audio/xsidplay/Makefile
index 6d3e680156c6..5d40ad9021b1 100644
--- a/audio/xsidplay/Makefile
+++ b/audio/xsidplay/Makefile
@@ -38,10 +38,6 @@ MAN1= xsidplay.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
.if ${MACHINE_ARCH} == "alpha"
CFLAGS+= -O0
.endif
diff --git a/audio/xsidplay/files/patch-src-songlendb-File.cpp b/audio/xsidplay/files/patch-src-songlendb-File.cpp
new file mode 100644
index 000000000000..b6b8df16cae9
--- /dev/null
+++ b/audio/xsidplay/files/patch-src-songlendb-File.cpp
@@ -0,0 +1,22 @@
+--- src/songlendb/File.cpp.orig Sun Mar 3 19:00:03 2002
++++ src/songlendb/File.cpp Thu Feb 17 22:46:43 2005
+@@ -29,6 +29,7 @@
+ #endif
+ using namespace std;
+
++#include <sys/types.h>
+ #include "File.h"
+
+ // String comparison functor for sort function.
+@@ -126,9 +127,9 @@
+ streampos fileLen = myIn.tellg();
+ #endif
+ #ifdef XSID_HAVE_NOTHROW
+- pDB = new(std::nothrow) char[fileLen+1L];
++ pDB = new(std::nothrow) char[(off_t)fileLen+1L];
+ #else
+- pDB = new char[fileLen+1L];
++ pDB = new char[(off_t)fileLen+1L];
+ #endif
+ if ( pDB == 0 )
+ {