aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2002-07-04 01:33:24 +0800
committerlioux <lioux@FreeBSD.org>2002-07-04 01:33:24 +0800
commit097a62797d4241e3e5fac68147f5752908ce8387 (patch)
tree65dd488d056694ad5c1ed71ec6f77c8643874684 /audio
parent528ac22874229eaf736519e6ebd6478459c0bd35 (diff)
downloadfreebsd-ports-gnome-097a62797d4241e3e5fac68147f5752908ce8387.tar.gz
freebsd-ports-gnome-097a62797d4241e3e5fac68147f5752908ce8387.tar.zst
freebsd-ports-gnome-097a62797d4241e3e5fac68147f5752908ce8387.zip
USE_REINPLACE
Diffstat (limited to 'audio')
-rw-r--r--audio/liba52-devel/Makefile5
-rw-r--r--audio/liba52/Makefile5
-rw-r--r--audio/toolame/Makefile7
3 files changed, 10 insertions, 7 deletions
diff --git a/audio/liba52-devel/Makefile b/audio/liba52-devel/Makefile
index e08ca119a9c0..245a00ffb9db 100644
--- a/audio/liba52-devel/Makefile
+++ b/audio/liba52-devel/Makefile
@@ -15,6 +15,7 @@ DISTNAME= a52dec-${PORTVERSION:S/.b/b/}
MAINTAINER= lioux@FreeBSD.org
USE_GMAKE= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-oss --enable-shared
USE_LIBTOOL= yes
@@ -48,11 +49,11 @@ pre-everything::
post-patch:
.ifndef(WITH_OPTIMIZED_CFLAGS)
- @${PERL} -pi.orig -e 's!-O3!${CFLAGS}!;s!-mcpu=[^"]+"!"!' \
+ @${REINPLACE_CMD} -E -e 's!-O3!${CFLAGS}!' -e 's!-mcpu=[^"]+"!"!' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
.endif
.ifndef(WITHOUT_DJBFFT)
- @${PERL} -pi -e 's|(fftc4.h)|djbfft/\1|' ${WRKSRC}/liba52/imdct.c
+ @${REINPLACE_CMD} -E -e 's|(fftc4.h)|djbfft/\1|' ${WRKSRC}/liba52/imdct.c
.endif
post-configure:
diff --git a/audio/liba52/Makefile b/audio/liba52/Makefile
index e08ca119a9c0..245a00ffb9db 100644
--- a/audio/liba52/Makefile
+++ b/audio/liba52/Makefile
@@ -15,6 +15,7 @@ DISTNAME= a52dec-${PORTVERSION:S/.b/b/}
MAINTAINER= lioux@FreeBSD.org
USE_GMAKE= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-oss --enable-shared
USE_LIBTOOL= yes
@@ -48,11 +49,11 @@ pre-everything::
post-patch:
.ifndef(WITH_OPTIMIZED_CFLAGS)
- @${PERL} -pi.orig -e 's!-O3!${CFLAGS}!;s!-mcpu=[^"]+"!"!' \
+ @${REINPLACE_CMD} -E -e 's!-O3!${CFLAGS}!' -e 's!-mcpu=[^"]+"!"!' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
.endif
.ifndef(WITHOUT_DJBFFT)
- @${PERL} -pi -e 's|(fftc4.h)|djbfft/\1|' ${WRKSRC}/liba52/imdct.c
+ @${REINPLACE_CMD} -E -e 's|(fftc4.h)|djbfft/\1|' ${WRKSRC}/liba52/imdct.c
.endif
post-configure:
diff --git a/audio/toolame/Makefile b/audio/toolame/Makefile
index ea4e2ea51f0c..36ef768bea4d 100644
--- a/audio/toolame/Makefile
+++ b/audio/toolame/Makefile
@@ -16,6 +16,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= lioux@FreeBSD.org
USE_GMAKE= yes
+USE_REINPLACE= yes
ALL_TARGET= ${PORTNAME}
DOC_FILES= CHANGES COPYING FUTURE GPL HISTORY README README.VBR
@@ -35,14 +36,14 @@ pre-everything::
post-patch:
.ifndef(WITH_OPTIMIZED_CFLAGS)
- @${PERL} -pi -e 's|\$$\(TWEAKS\)||' \
+ @${REINPLACE_CMD} -E -e 's|\$$\(TWEAKS\)||' \
${WRKSRC}/Makefile
.endif
.ifndef(WITH_PROFILED)
- @${PERL} -pi -e 's|\$$\(PG\)||' \
+ @${REINPLACE_CMD} -E -e 's|\$$\(PG\)||' \
${WRKSRC}/Makefile
.endif
- @${PERL} -pi.orig -e \
+ @${REINPLACE_CMD} -E -e \
's@^CC\s.+|\$$\((ARCH|DMALLOCLIB|DMAL|OPTIM|WARNING)\)@@g' \
${WRKSRC}/Makefile