aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2003-08-21 04:20:42 +0800
committernaddy <naddy@FreeBSD.org>2003-08-21 04:20:42 +0800
commit5697e6d8be152fd0441a6cadc13c2d5ef2d68a7f (patch)
tree3ccf51dc6e4715f8e60d2c451c08601a125ebc11 /audio
parentedc091d78195ef339a298caa33d28c12f9bc1b87 (diff)
downloadfreebsd-ports-gnome-5697e6d8be152fd0441a6cadc13c2d5ef2d68a7f.tar.gz
freebsd-ports-gnome-5697e6d8be152fd0441a6cadc13c2d5ef2d68a7f.tar.zst
freebsd-ports-gnome-5697e6d8be152fd0441a6cadc13c2d5ef2d68a7f.zip
Update to 0.9.1, unbreak.
Submitted by: Volker Stolz <vs@foldr.org> Revamped by yours truly. Closes PR: 53239 Approved by: (maintainer timeout)
Diffstat (limited to 'audio')
-rw-r--r--audio/xmms-speex/Makefile21
-rw-r--r--audio/xmms-speex/distinfo2
-rw-r--r--audio/xmms-speex/files/patch-Makefile14
-rw-r--r--audio/xmms-speex/files/patch-libspeex.c20
4 files changed, 19 insertions, 38 deletions
diff --git a/audio/xmms-speex/Makefile b/audio/xmms-speex/Makefile
index 30b02ffb3803..fc1e5f123cbd 100644
--- a/audio/xmms-speex/Makefile
+++ b/audio/xmms-speex/Makefile
@@ -6,19 +6,16 @@
#
PORTNAME= xmms-speex
-PORTVERSION= 0.6.0
-PORTREVISION= 1
+PORTVERSION= 0.9.1
CATEGORIES= audio
-MASTER_SITES= http://jzb.rapanden.dk/speex/
+MASTER_SITES= http://jzb.rapanden.dk/pub/
DISTNAME= speex-xmms-${PORTVERSION}
MAINTAINER= dyeske@yahoo.com
COMMENT= XMMS input plugin to play speex files
-BROKEN= Broken dependency
-
BUILD_DEPENDS= xmms-config:${PORTSDIR}/multimedia/xmms
-LIB_DEPENDS= speex.1:${PORTSDIR}/audio/speex
+LIB_DEPENDS= speex.2:${PORTSDIR}/audio/speex
RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
WRKSRC= ${WRKDIR}/speex-xmms
@@ -26,17 +23,7 @@ WRKSRC= ${WRKDIR}/speex-xmms
USE_X_PREFIX= yes
USE_GNOME= gtk12
USE_GMAKE= yes
-USE_REINPLACE= yes
-pre-build:
- @${REINPLACE_CMD} -e 's|^main|all|; \
- s|-lgtk|${CFLAGS} `${GTK_CONFIG} --cflags` `${GTK_CONFIG} --libs` |; \
- s|-I/usr/include/xmms||; \
- s|^install: libspeex.o|install:|; \
- s|-I/usr/lib/glib/include||; \
- s|-I/usr/include/glib-1.2||; \
- s|-I/usr/include/gtk-1.2||; \
- s|/usr/lib/xmms/Input|${X11BASE}/lib/xmms/Input|' \
- ${WRKSRC}/Makefile
+MAKE_FLAGS= CC="${CC}" CFLAGS="${CFLAGS}"
.include <bsd.port.mk>
diff --git a/audio/xmms-speex/distinfo b/audio/xmms-speex/distinfo
index 6fa78ad5d89f..a0bafb419f41 100644
--- a/audio/xmms-speex/distinfo
+++ b/audio/xmms-speex/distinfo
@@ -1 +1 @@
-MD5 (speex-xmms-0.6.0.tar.gz) = b4014356ef929706444ff98639550460
+MD5 (speex-xmms-0.9.1.tar.gz) = 223a8c8fc7f073c7a7bd4fe6736ed0ee
diff --git a/audio/xmms-speex/files/patch-Makefile b/audio/xmms-speex/files/patch-Makefile
new file mode 100644
index 000000000000..056a63e7edb1
--- /dev/null
+++ b/audio/xmms-speex/files/patch-Makefile
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- Makefile.orig Sun Aug 3 18:18:42 2003
++++ Makefile Thu Aug 14 18:08:45 2003
+@@ -14,7 +14,7 @@
+ $(MAKE) -C $(@D) all
+
+ libspeex.so: libspeex.c libspeex.h $(OBJS) $(GUIOBJS)
+- $(CC) -shared -logg -lspeex -lgtk -lpthread -lxmms $(INCDIRS) $(CFLAGS) -DVERSION=$(VERSION) -DPACKAGE=\"libspeex\" -o libspeex.so libspeex.c $(OBJS) $(GUIOBJS)
++ $(CC) -shared $(INCDIRS) $(CFLAGS) -DVERSION=$(VERSION) -DPACKAGE=\"libspeex\" -o libspeex.so libspeex.c $(OBJS) $(GUIOBJS) `xmms-config --libs` -logg -lspeex
+
+ #utf8.o: utf8.c utf8.h
+ # $(CC) -c $(INCDIRS) $(CFLAGS) -DHAVE_ICONV -DICONV_CONST= -o utf8.o utf8.c
diff --git a/audio/xmms-speex/files/patch-libspeex.c b/audio/xmms-speex/files/patch-libspeex.c
deleted file mode 100644
index 6bfc4c4e7ccf..000000000000
--- a/audio/xmms-speex/files/patch-libspeex.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- libspeex.c.orig Sat Sep 21 13:18:53 2002
-+++ libspeex.c Sat Sep 21 13:23:14 2002
-@@ -385,7 +385,7 @@
- #endif
-
- speex_bits_rewind(&sbits);
-- speex_decode(spx_decoder, &sbits, outbuff, 1);
-+ speex_decode(spx_decoder, &sbits, outbuff);
-
- // Converting and clipping check
- for (i = 0; i < speex_fs->framesize; i++) {
-@@ -455,7 +455,7 @@
- // For multiple frames within packets
- for (j=0; j < speex_fs->nframes; j++)
- {
-- speex_decode(spx_decoder, &sbits, outbuff, 0);
-+ speex_decode(spx_decoder, &sbits, outbuff);
-
- // Converting and clipping check
- for (i = 0; i < speex_fs->framesize; i++) {