aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2006-05-30 21:50:27 +0800
committerehaupt <ehaupt@FreeBSD.org>2006-05-30 21:50:27 +0800
commit848678ab1a3db002fbf4e247c42a192da67cfdcd (patch)
treeca79577341b38776883953096540b0045821905c /audio
parentc84b44ebc7670813cdcd010b09d1d04639ca67f4 (diff)
downloadfreebsd-ports-gnome-848678ab1a3db002fbf4e247c42a192da67cfdcd.tar.gz
freebsd-ports-gnome-848678ab1a3db002fbf4e247c42a192da67cfdcd.tar.zst
freebsd-ports-gnome-848678ab1a3db002fbf4e247c42a192da67cfdcd.zip
- Fix a bug in id3lib that causes UTF-16 characters to be broken when writing
tags - Pass maintainer-ship to submitter PR: 98061 Submitted by: Khairil Yusof <kaeru@inigo-tech.com> Obtained from: Fedora (CVS)
Diffstat (limited to 'audio')
-rw-r--r--audio/id3lib/Makefile6
-rw-r--r--audio/id3lib/files/patch-io_helpers.cpp14
2 files changed, 17 insertions, 3 deletions
diff --git a/audio/id3lib/Makefile b/audio/id3lib/Makefile
index aba762e7f90f..c2450726e148 100644
--- a/audio/id3lib/Makefile
+++ b/audio/id3lib/Makefile
@@ -7,16 +7,16 @@
PORTNAME= id3lib
PORTVERSION= 3.8.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= kaeru@inigo-tech.com
COMMENT= Library for manipulating ID3v1/v1.1 and ID3v2 tags
USE_ICONV= yes
-GNU_CONFIGURE= yes
+GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
INSTALLS_SHLIB= yes
diff --git a/audio/id3lib/files/patch-io_helpers.cpp b/audio/id3lib/files/patch-io_helpers.cpp
new file mode 100644
index 000000000000..e42abcb85525
--- /dev/null
+++ b/audio/id3lib/files/patch-io_helpers.cpp
@@ -0,0 +1,14 @@
+--- src/io_helpers.cpp.orig Sun Mar 2 07:23:00 2003
++++ src/io_helpers.cpp Mon May 29 01:23:33 2006
+@@ -363,9 +363,10 @@
+ // Write the BOM: 0xFEFF
+ unicode_t BOM = 0xFEFF;
+ writer.writeChars((const unsigned char*) &BOM, 2);
++ const unsigned char* pdata = (const unsigned char*)data.c_str();
+ for (size_t i = 0; i < size; i += 2)
+ {
+- unicode_t ch = (data[i] << 8) | data[i+1];
++ unicode_t ch = (pdata[i] << 8) | pdata[i+1];
+ writer.writeChars((const unsigned char*) &ch, 2);
+ }
+ }