aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-03-19 00:27:35 +0800
committerpav <pav@FreeBSD.org>2004-03-19 00:27:35 +0800
commit9582367febf421c5552f4f0f391dc78f30b6aa66 (patch)
treeae45439790d8bafa92c64bdb2a33222d16ad990e /audio
parentb73eac4377a8a171663712b3539ea517f0fb30c2 (diff)
downloadfreebsd-ports-gnome-9582367febf421c5552f4f0f391dc78f30b6aa66.tar.gz
freebsd-ports-gnome-9582367febf421c5552f4f0f391dc78f30b6aa66.tar.zst
freebsd-ports-gnome-9582367febf421c5552f4f0f391dc78f30b6aa66.zip
- Fix build with modern gcc
Add placeholder strstream.h file in the workdir, and patch some of the Makefile.in's to use the workdir in their include path. Rewriting this port to use ISO C++ would maybe be better, but will make the diff a lot larger. Also, the tclmidi program doesn't really seem to be actively maintained anyway. PR: ports/64310 Submitted by: Dimitry Andric <dimitry@andric.com>
Diffstat (limited to 'audio')
-rw-r--r--audio/tclmidi/Makefile5
-rw-r--r--audio/tclmidi/files/smf.patch12
-rw-r--r--audio/tclmidi/files/song.patch11
-rw-r--r--audio/tclmidi/files/strstream.h44
4 files changed, 71 insertions, 1 deletions
diff --git a/audio/tclmidi/Makefile b/audio/tclmidi/Makefile
index 22fff38a8913..54c554241970 100644
--- a/audio/tclmidi/Makefile
+++ b/audio/tclmidi/Makefile
@@ -36,7 +36,10 @@ MANN= midiconf.n midievnt.n midifree.n midiget.n midigrep.n \
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 502000
-BROKEN= "Does not compile"
+EXTRA_PATCHES= ${PATCHDIR}/smf.patch ${PATCHDIR}/song.patch
+
+post-extract:
+ @${CP} -f ${FILESDIR}/strstream.h ${WRKSRC}
.endif
post-install:
diff --git a/audio/tclmidi/files/smf.patch b/audio/tclmidi/files/smf.patch
new file mode 100644
index 000000000000..af1a63d8f89c
--- /dev/null
+++ b/audio/tclmidi/files/smf.patch
@@ -0,0 +1,12 @@
+--- smf/Makefile.in.orig Thu Oct 10 05:32:53 1996
++++ smf/Makefile.in Mon Mar 15 16:30:42 2004
+@@ -14,7 +14,8 @@
+ VPATH = @srcdir@
+
+ CFLAGS = @CFLAGS@ @DEFS@
+-CC_SWITCHES = @CFLAGS@ @DEFS@ -I${TCL_GENERIC_DIR} ${SHLIB_CFLAGS}
++CC_SWITCHES = @CFLAGS@ @DEFS@ -I${TCL_GENERIC_DIR} ${SHLIB_CFLAGS} \
++ -I$(srcdir)/../smf -I$(srcdir)/../song -I$(srcdir)/.. -I$(srcdir)
+
+ SMFFILES = SMFUtils.o SMFHead.o SMFTrack.o
+ SMFFILES_SRC = SMFUtils.cxx SMFHead.cxx SMFTrack.cxx
diff --git a/audio/tclmidi/files/song.patch b/audio/tclmidi/files/song.patch
new file mode 100644
index 000000000000..f4cb59a86ebd
--- /dev/null
+++ b/audio/tclmidi/files/song.patch
@@ -0,0 +1,11 @@
+--- song/Makefile.in.orig Thu Oct 10 05:32:55 1996
++++ song/Makefile.in Mon Mar 15 16:39:34 2004
+@@ -15,7 +15,7 @@
+
+ CFLAGS = @CFLAGS@ @DEFS@
+ CC_SWITCHES = @CFLAGS@ @DEFS@ -I${TCL_GENERIC_DIR} ${SHLIB_CFLAGS} \
+- -I$(srcdir)/../events -I$(srcdir)/../rb -I$(srcdir)/../smf -I$(srcdir)
++ -I$(srcdir)/../events -I$(srcdir)/../rb -I$(srcdir)/../smf -I$(srcdir)/.. -I$(srcdir)
+
+ SONGFILES = EvntTree.o Song.o
+ SONGFILES_SRC = EvntTree.cxx Song.cxx
diff --git a/audio/tclmidi/files/strstream.h b/audio/tclmidi/files/strstream.h
new file mode 100644
index 000000000000..8897edb70330
--- /dev/null
+++ b/audio/tclmidi/files/strstream.h
@@ -0,0 +1,44 @@
+// Copyright (C) 2004 Free Software Foundation, Inc.
+//
+// This file is NOT an official part of the GNU ISO C++ Library. This
+// library is free software; you can redistribute it and/or modify it
+// under the terms of the GNU General Public License as published by
+// the Free Software Foundation; either version 2, or (at your option)
+// any later version.
+
+// This library is distributed in the hope that it will be useful,
+// but WITHOUT ANY WARRANTY; without even the implied warranty of
+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+// GNU General Public License for more details.
+
+// You should have received a copy of the GNU General Public License along
+// with this library; see the file COPYING. If not, write to the Free
+// Software Foundation, 59 Temple Place - Suite 330, Boston, MA 02111-1307,
+// USA.
+
+// As a special exception, you may use this file as part of a free software
+// library without restriction. Specifically, if other files instantiate
+// templates or use macros or inline functions from this file, or you compile
+// this file and link it with other files to produce an executable, this
+// file does not by itself cause the resulting executable to be covered by
+// the GNU General Public License. This exception does not however
+// invalidate any other reasons why the executable file might be covered by
+// the GNU General Public License.
+
+#ifndef _CPP_BACKWARD_STRSTREAM_H
+#define _CPP_BACKWARD_STRSTREAM_H 1
+
+// Backward warning isn't needed here, you'll get it from strstream anyway.
+//#include "backward_warning.h"
+#include <strstream>
+
+using std::strstreambuf;
+using std::istrstream;
+using std::ostrstream;
+using std::strstream;
+
+#endif
+
+// Local Variables:
+// mode:C++
+// End: