aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2007-03-28 02:28:08 +0800
committeralepulver <alepulver@FreeBSD.org>2007-03-28 02:28:08 +0800
commit9e34e0fc0f866e1371cb12e34d753018124520c5 (patch)
tree7578d9d7329ebd9f2c8ec227d6e95020f12c5226 /audio
parent3f550fefec68e2345f6675b4d8e4ca7333386283 (diff)
downloadfreebsd-ports-gnome-9e34e0fc0f866e1371cb12e34d753018124520c5.tar.gz
freebsd-ports-gnome-9e34e0fc0f866e1371cb12e34d753018124520c5.tar.zst
freebsd-ports-gnome-9e34e0fc0f866e1371cb12e34d753018124520c5.zip
- Fix building after removal of objformat(1).
Reported by: pointyhat
Diffstat (limited to 'audio')
-rw-r--r--audio/xmms-efxmms/Makefile3
-rw-r--r--audio/xmms-fxt/Makefile4
2 files changed, 7 insertions, 0 deletions
diff --git a/audio/xmms-efxmms/Makefile b/audio/xmms-efxmms/Makefile
index 5de29f5f4cca..39c65b3fb886 100644
--- a/audio/xmms-efxmms/Makefile
+++ b/audio/xmms-efxmms/Makefile
@@ -27,4 +27,7 @@ GNU_CONFIGURE= yes
PLIST_FILES= lib/xmms/Effect/libefx.la \
lib/xmms/Effect/libefx.so
+post-patch:
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/ltconfig
+
.include <bsd.port.mk>
diff --git a/audio/xmms-fxt/Makefile b/audio/xmms-fxt/Makefile
index a3257faa597e..34dad1e9cc21 100644
--- a/audio/xmms-fxt/Makefile
+++ b/audio/xmms-fxt/Makefile
@@ -25,4 +25,8 @@ USE_GNOME= gtk12
PLIST_FILES= lib/xmms/Effect/libfxt.la \
lib/xmms/Effect/libfxt.so
+post-patch:
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|' \
+ ${WRKSRC}/configure ${WRKSRC}/ltconfig
+
.include <bsd.port.mk>