aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-01-21 03:14:56 +0800
committermiwi <miwi@FreeBSD.org>2010-01-21 03:14:56 +0800
commite5b841b77cf3051ef984d25e71965d42e91e30b4 (patch)
tree3704a5e538972917e8b64feda659bc699e5e6b50 /audio
parentde15b8f1396ece225d5a82a9c4dc93b4bf343aed (diff)
downloadfreebsd-ports-gnome-e5b841b77cf3051ef984d25e71965d42e91e30b4.tar.gz
freebsd-ports-gnome-e5b841b77cf3051ef984d25e71965d42e91e30b4.tar.zst
freebsd-ports-gnome-e5b841b77cf3051ef984d25e71965d42e91e30b4.zip
2010-01-08 audio/dino: has been broken for 7 months
2010-01-08 devel/asis-gpl: has been broken for 3 months 2010-01-08 devel/florist-gpl: has been broken for 3 months 2010-01-08 devel/kdesvn: has been broken for 4 months 2010-01-08 devel/radrails: has been broken for 3 months 2010-01-08 devel/rubygem-rtags: has been broken for 5 months 2010-01-12 games/hattrickorganizer: Has been broken for quite some time 2010-01-08 games/laughingman: has been broken for 3 months 2010-01-08 devel/aunit: has been broken for 3 months 2010-01-18 devel/gdb53: has been broken for 3 months 2010-01-08 lang/ccscript: has been broken for 4 months 2010-01-08 lang/gnat-glade: has been broken for 3 months 2010-01-08 lang/xsb: has been broken for 6 months 2010-01-08 multimedia/nmm: has been broken for 3 months 2010-01-08 multimedia/sabbu: has been broken for 3 months 2010-01-08 net/adasockets: has been broken for 3 months 2010-01-08 textproc/bidiv: has been broken for 3 months 2010-01-08 textproc/xmlada-gps: has been broken for 3 months
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/dino/Makefile35
-rw-r--r--audio/dino/distinfo3
-rw-r--r--audio/dino/files/patch-src-libdinoseq-mididbuffer.cpp20
-rw-r--r--audio/dino/files/patch-src-libdinoseq-sequencer.cpp24
-rw-r--r--audio/dino/files/patch-src-libdinoseq-track.hpp23
-rw-r--r--audio/dino/pkg-descr7
-rw-r--r--audio/dino/pkg-plist5
8 files changed, 0 insertions, 118 deletions
diff --git a/audio/Makefile b/audio/Makefile
index f2faf72a1f48..3c4bdf1a5f2e 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -121,7 +121,6 @@
SUBDIR += dcd
SUBDIR += dekagen
SUBDIR += denemo
- SUBDIR += dino
SUBDIR += dir2ogg
SUBDIR += discid
SUBDIR += drumpiler
diff --git a/audio/dino/Makefile b/audio/dino/Makefile
deleted file mode 100644
index 060b45c813ef..000000000000
--- a/audio/dino/Makefile
+++ /dev/null
@@ -1,35 +0,0 @@
-# New ports collection makefile for: dino
-# Date created: 2007-01-13
-# Whom: trasz <trasz@pin.if.uz.zgora.pl>
-#
-# $FreeBSD$
-#
-
-PORTNAME= dino
-PORTVERSION= 0.2.2
-PORTREVISION= 4
-CATEGORIES= audio
-MASTER_SITES= ${MASTER_SITE_SAVANNAH}
-MASTER_SITE_SUBDIR= dino
-
-MAINTAINER= trasz@FreeBSD.org
-COMMENT= A pattern-based MIDI sequencer
-
-LIB_DEPENDS= glademm-2.4:${PORTSDIR}/devel/libglademm24 \
- jack.0:${PORTSDIR}/audio/jack \
- lash.2:${PORTSDIR}/audio/lash \
- xml++:${PORTSDIR}/textproc/libxml++26
-BUILD_DEPENDS= jackit>=0.109.2:${PORTSDIR}/audio/jack
-
-# Between 0.109.0 and earlier versions there was an api change in JACK.
-# However, the library version number was not changed. The line above
-# is supposed to work around that.
-
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
-
-BROKEN= does not compile
-DEPRECATED= has been broken for 7 months
-EXPIRATION_DATE=2010-01-08
-
-.include <bsd.port.mk>
diff --git a/audio/dino/distinfo b/audio/dino/distinfo
deleted file mode 100644
index 58ba098b67bb..000000000000
--- a/audio/dino/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (dino-0.2.2.tar.gz) = d1a9c077f5fee25c99ff48c5aa283275
-SHA256 (dino-0.2.2.tar.gz) = b451bd542c3c3df6ddb7ff8dd57d83ef6cab272351b217938119ed1cccd6e000
-SIZE (dino-0.2.2.tar.gz) = 405842
diff --git a/audio/dino/files/patch-src-libdinoseq-mididbuffer.cpp b/audio/dino/files/patch-src-libdinoseq-mididbuffer.cpp
deleted file mode 100644
index d052388f538a..000000000000
--- a/audio/dino/files/patch-src-libdinoseq-mididbuffer.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/libdinoseq/midibuffer.cpp.orig 2008-07-23 13:26:56.000000000 +0200
-+++ src/libdinoseq/midibuffer.cpp 2008-07-23 13:27:11.000000000 +0200
-@@ -55,7 +55,7 @@
- // XXX optimise this
- jack_nframes_t timestamp = jack_nframes_t((beat - m_start_beat) *
- 60 / (m_bpm * m_samplerate));
-- return jack_midi_event_reserve(m_buffer, timestamp, data_size, m_nframes);
-+ return jack_midi_event_reserve(m_buffer, timestamp, data_size);
- }
-
-
-@@ -65,7 +65,7 @@
- jack_nframes_t timestamp = jack_nframes_t((beat - m_start_beat) *
- 60 / (m_bpm * m_samplerate));
- return jack_midi_event_write(m_buffer, timestamp, (jack_midi_data_t*)data,
-- data_size, m_nframes);
-+ data_size);
- }
-
-
diff --git a/audio/dino/files/patch-src-libdinoseq-sequencer.cpp b/audio/dino/files/patch-src-libdinoseq-sequencer.cpp
deleted file mode 100644
index 7b22c63217d8..000000000000
--- a/audio/dino/files/patch-src-libdinoseq-sequencer.cpp
+++ /dev/null
@@ -1,24 +0,0 @@
---- src/libdinoseq/sequencer.cpp.orig 2008-07-23 13:31:55.000000000 +0200
-+++ src/libdinoseq/sequencer.cpp 2008-07-23 13:33:30.000000000 +0200
-@@ -334,10 +334,10 @@
- jack_port_t* port = m_output_ports[iter->get_id()];
- if (port) {
- void* port_buf = jack_port_get_buffer(port, nframes);
-- jack_midi_clear_buffer(port_buf, nframes);
-+ jack_midi_clear_buffer(port_buf);
- unsigned char all_notes_off[] = { 0xB0, 123, 0 };
- if (!m_sent_all_off)
-- jack_midi_event_write(port_buf, 0, all_notes_off, 3, nframes);
-+ jack_midi_event_write(port_buf, 0, all_notes_off, 3);
- }
- m_sent_all_off = true;
- }
-@@ -361,7 +361,7 @@
- jack_port_t* port = m_output_ports[iter->get_id()];
- if (port) {
- void* port_buf = jack_port_get_buffer(port, nframes);
-- jack_midi_clear_buffer(port_buf, nframes);
-+ jack_midi_clear_buffer(port_buf);
- MIDIBuffer buffer(port_buf, start, pos.beats_per_minute,pos.frame_rate);
- buffer.set_period_size(nframes);
- buffer.set_cc_resolution(m_cc_resolution * pos.beats_per_minute / 60);
diff --git a/audio/dino/files/patch-src-libdinoseq-track.hpp b/audio/dino/files/patch-src-libdinoseq-track.hpp
deleted file mode 100644
index f37bc7e3974f..000000000000
--- a/audio/dino/files/patch-src-libdinoseq-track.hpp
+++ /dev/null
@@ -1,23 +0,0 @@
---- src/libdinoseq/track.hpp.orig Sat Jan 13 16:51:54 2007
-+++ src/libdinoseq/track.hpp Sat Jan 13 16:52:02 2007
-@@ -194,13 +194,13 @@
-
- /// @name Signals
- //@{
-- signal<void, const string&> signal_name_changed;
-- signal<void, int> signal_pattern_added;
-- signal<void, int> signal_pattern_removed;
-- signal<void, int, int, int> signal_sequence_entry_added;
-- signal<void, int, int, int> signal_sequence_entry_changed;
-- signal<void, int> signal_sequence_entry_removed;
-- signal<void, int> signal_length_changed;
-+ sigc::signal<void, const string&> signal_name_changed;
-+ sigc::signal<void, int> signal_pattern_added;
-+ sigc::signal<void, int> signal_pattern_removed;
-+ sigc::signal<void, int, int, int> signal_sequence_entry_added;
-+ sigc::signal<void, int, int, int> signal_sequence_entry_changed;
-+ sigc::signal<void, int> signal_sequence_entry_removed;
-+ sigc::signal<void, int> signal_length_changed;
- //@}
-
- private:
diff --git a/audio/dino/pkg-descr b/audio/dino/pkg-descr
deleted file mode 100644
index 986a7ac61a51..000000000000
--- a/audio/dino/pkg-descr
+++ /dev/null
@@ -1,7 +0,0 @@
-Dino is a pattern-based MIDI sequencer, which means that you write
-small patterns of MIDI events that you can repeat and arrange to
-create a whole song. Each track has its own patterns, so you can
-for example play the same drum pattern over and over again while
-you play different lead synth patterns and basslines.
-
-WWW: http://dino.nongnu.org/
diff --git a/audio/dino/pkg-plist b/audio/dino/pkg-plist
deleted file mode 100644
index 0336153b3545..000000000000
--- a/audio/dino/pkg-plist
+++ /dev/null
@@ -1,5 +0,0 @@
-bin/dino
-%%DATADIR%%/midisaurus.png
-%%DATADIR%%/head.png
-%%DATADIR%%/dino.glade
-@dirrmtry %%DATADIR%%