aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2015-05-31 15:18:00 +0800
committerantoine <antoine@FreeBSD.org>2015-05-31 15:18:00 +0800
commit94dfb30a59dca573ca1abf6775994f5480225b10 (patch)
tree9e22ff8129b95dfd08e9b0a919b6aced0cc56f6e /audio
parent81863b353080e4c12ca5df347a9c5a1671998e98 (diff)
downloadfreebsd-ports-gnome-94dfb30a59dca573ca1abf6775994f5480225b10.tar.gz
freebsd-ports-gnome-94dfb30a59dca573ca1abf6775994f5480225b10.tar.zst
freebsd-ports-gnome-94dfb30a59dca573ca1abf6775994f5480225b10.zip
- Add back part of LDFLAGS removed in r387982, it's needed to link at least
on FreeBSD 9.3: fluid_sys.c:(.text+0xced): undefined reference to `pthread_setschedparam' - While here, fix a typo in an option helper
Diffstat (limited to 'audio')
-rw-r--r--audio/fluidsynth/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/audio/fluidsynth/Makefile b/audio/fluidsynth/Makefile
index c6e3ea74fbf6..575a70ac9f7a 100644
--- a/audio/fluidsynth/Makefile
+++ b/audio/fluidsynth/Makefile
@@ -22,6 +22,8 @@ CMAKE_ARGS= -Denable-ladcca:BOOL=FALSE \
-Denable-midishare:BOOL=FALSE
USE_LDCONFIG= yes
+LDFLAGS+= -lpthread
+
JACK_LIB_DEPENDS= libjack.so:${PORTSDIR}/audio/jack
JACK_CMAKE_OFF= -Denable-jack:BOOL=FALSE
@@ -45,7 +47,7 @@ PULSEAUDIO_LIB_DEPENDS= libpulse.so:${PORTSDIR}/audio/pulseaudio
PULSEAUDIO_CMAKE_OFF= -Denable-pulseaudio:BOOL=FALSE
SNDFILE_LIB_DEPENDS= libsndfile.so:${PORTSDIR}/audio/libsndfile
-SNDFILE_CMAKe_OFF= -Denable-libsndfile:BOOL=FALSE
+SNDFILE_CMAKE_OFF= -Denable-libsndfile:BOOL=FALSE
post-patch:
@${REINPLACE_CMD} -e \