aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorultima <ultima@FreeBSD.org>2017-08-20 01:51:20 +0800
committerultima <ultima@FreeBSD.org>2017-08-20 01:51:20 +0800
commit9f9130dc66129f30c13ebeadef8a360a7d5a88f3 (patch)
tree7b2e1b0917ea34b0c22ed8f6b891b2b4cf9db01c /audio
parentab9035db68d93d32fa676c86a2c380dcb4710cb1 (diff)
downloadfreebsd-ports-gnome-9f9130dc66129f30c13ebeadef8a360a7d5a88f3.tar.gz
freebsd-ports-gnome-9f9130dc66129f30c13ebeadef8a360a7d5a88f3.tar.zst
freebsd-ports-gnome-9f9130dc66129f30c13ebeadef8a360a7d5a88f3.zip
PyJack is a module written in C which exposes the Jack API to Python.
For information about Jack see http://jackit.sourceforge.net. This enables a Python program to connect to and interact with pro-audio applications which use the Jack Audio Server. WWW: https://pypi.python.org/pypi/py-jack PR: 220990 Submitted by: Yuri Victorovich (maintainer) Reviewed by: matthew (mentor) Approved by: matthew (mentor) Differential Revision: https://reviews.freebsd.org/D12079
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/py-jack/Makefile31
-rw-r--r--audio/py-jack/distinfo3
-rw-r--r--audio/py-jack/files/patch-pyjack.c10
-rw-r--r--audio/py-jack/pkg-descr6
5 files changed, 51 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 1ded492c758c..f35bfe6b53f1 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -648,6 +648,7 @@
SUBDIR += py-gmusicproxy
SUBDIR += py-hsaudiotag
SUBDIR += py-id3
+ SUBDIR += py-jack
SUBDIR += py-karaoke
SUBDIR += py-mad
SUBDIR += py-mpd
diff --git a/audio/py-jack/Makefile b/audio/py-jack/Makefile
new file mode 100644
index 000000000000..6c64a9d4fe04
--- /dev/null
+++ b/audio/py-jack/Makefile
@@ -0,0 +1,31 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= jack
+PORTVERSION= 0.5.2
+CATEGORIES= audio python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= py-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= PyJack is a Python bindings for the Jack Audio Server
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libjack.so:audio/jack
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>0:math/py-numpy
+
+USES= python:-2.7 localbase
+USE_PYTHON= distutils autoplist
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|"/usr/local/|"${LOCALBASE}/|; \
+ s|"jack", "dl"|"jack"|; \
+ s|os.system.*|pass|' \
+ ${WRKSRC}/setup.py
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/jack.so
+
+.include <bsd.port.mk>
diff --git a/audio/py-jack/distinfo b/audio/py-jack/distinfo
new file mode 100644
index 000000000000..a18d2137d0b9
--- /dev/null
+++ b/audio/py-jack/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1500938413
+SHA256 (py-jack-0.5.2.tar.gz) = 67951f7b78ded52f3191a5267cd917f1270a6abe28341ccb3575bdd482488590
+SIZE (py-jack-0.5.2.tar.gz) = 13490
diff --git a/audio/py-jack/files/patch-pyjack.c b/audio/py-jack/files/patch-pyjack.c
new file mode 100644
index 000000000000..8cca602a3304
--- /dev/null
+++ b/audio/py-jack/files/patch-pyjack.c
@@ -0,0 +1,10 @@
+--- pyjack.c.orig 2017-07-24 23:24:04 UTC
++++ pyjack.c
+@@ -40,7 +40,6 @@ TODO's:
+ // Global shared data for jack
+
+ /* Uncomment the next line if you have Jack2 */
+-#define JACK2 1
+
+
+ #define PYJACK_MAX_PORTS 256
diff --git a/audio/py-jack/pkg-descr b/audio/py-jack/pkg-descr
new file mode 100644
index 000000000000..f253becb3c34
--- /dev/null
+++ b/audio/py-jack/pkg-descr
@@ -0,0 +1,6 @@
+PyJack is a module written in C which exposes the Jack API to Python.
+For information about Jack see http://jackit.sourceforge.net. This
+enables a Python program to connect to and interact with pro-audio
+applications which use the Jack Audio Server.
+
+WWW: https://pypi.python.org/pypi/py-jack