aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorultima <ultima@FreeBSD.org>2017-09-14 11:01:52 +0800
committerultima <ultima@FreeBSD.org>2017-09-14 11:01:52 +0800
commitc5c9dd76d0638ed9ae443cff24a3f3d6582dc690 (patch)
treedced6b5d558519ca2c0ace44748950c558cc961a /audio
parente277f29356a8dad199ec97790d2d74ae7489bf6e (diff)
downloadfreebsd-ports-gnome-c5c9dd76d0638ed9ae443cff24a3f3d6582dc690.tar.gz
freebsd-ports-gnome-c5c9dd76d0638ed9ae443cff24a3f3d6582dc690.tar.zst
freebsd-ports-gnome-c5c9dd76d0638ed9ae443cff24a3f3d6582dc690.zip
Python bindings to the libopus, IETF low-delay audio codec.
It allows python applications to use the Opus audio codec to encode and decode audio, usually in order to reduce the network bandwidth that is used by the application. WWW: https://github.com/onbeep/opuslib PR: 222038 Submitted by: Yuri Victorovich (maintainer) Reviewed by: lifanov (mentor), matthew (mentor), koobs, sunpoet, mat Approved by: lifanov (mentor), matthew (mentor), koobs Differential Revision: https://reviews.freebsd.org/D12309
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/py-opuslib/Makefile21
-rw-r--r--audio/py-opuslib/distinfo3
-rw-r--r--audio/py-opuslib/pkg-descr7
4 files changed, 32 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 438baa854d1e..837f775f0066 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -657,6 +657,7 @@
SUBDIR += py-mutagen
SUBDIR += py-ogg
SUBDIR += py-openal
+ SUBDIR += py-opuslib
SUBDIR += py-py-jack
SUBDIR += py-pyacoustid
SUBDIR += py-pyaudio
diff --git a/audio/py-opuslib/Makefile b/audio/py-opuslib/Makefile
new file mode 100644
index 000000000000..85dd0628566f
--- /dev/null
+++ b/audio/py-opuslib/Makefile
@@ -0,0 +1,21 @@
+# Created by: Yuri Victorovich
+# $FreeBSD$
+
+PORTNAME= opuslib
+PORTVERSION= 1.1.0
+CATEGORIES= audio python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Python bindings to the libopus, IETF low-delay audio codec
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${LOCALBASE}/lib/libopus.so:audio/opus
+
+USES= python:2.7
+USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/audio/py-opuslib/distinfo b/audio/py-opuslib/distinfo
new file mode 100644
index 000000000000..4a2f8f35f0b4
--- /dev/null
+++ b/audio/py-opuslib/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1504481859
+SHA256 (opuslib-1.1.0.tar.gz) = 342d9693f836cc42a44ae5f8bac51ae17d52e24e8daceb792cb610024f1e341b
+SIZE (opuslib-1.1.0.tar.gz) = 7009
diff --git a/audio/py-opuslib/pkg-descr b/audio/py-opuslib/pkg-descr
new file mode 100644
index 000000000000..b89dc36db8a5
--- /dev/null
+++ b/audio/py-opuslib/pkg-descr
@@ -0,0 +1,7 @@
+Python bindings to the libopus, IETF low-delay audio codec.
+
+It allows python applications to use the Opus audio codec to encode
+and decode audio, usually in order to reduce the network bandwidth
+that is used by the application.
+
+WWW: https://github.com/onbeep/opuslib