aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2011-04-12 18:36:16 +0800
committerbapt <bapt@FreeBSD.org>2011-04-12 18:36:16 +0800
commitc968cb9e3ef44a49b192ea4db04001c4ec011f0c (patch)
tree2c5cd96f1187b4be7def987f7e0169b28c932566 /audio
parentb86f84e54b5a3f757323c1d3f6b82b7eb0c7e63f (diff)
downloadfreebsd-ports-gnome-c968cb9e3ef44a49b192ea4db04001c4ec011f0c.tar.gz
freebsd-ports-gnome-c968cb9e3ef44a49b192ea4db04001c4ec011f0c.tar.zst
freebsd-ports-gnome-c968cb9e3ef44a49b192ea4db04001c4ec011f0c.zip
- chase celt library bump
Diffstat (limited to 'audio')
-rw-r--r--audio/jack/Makefile4
-rw-r--r--audio/jack/files/patch-drivers__netjack__netjack_packet.c23
-rw-r--r--audio/mangler/Makefile4
-rw-r--r--audio/mumble/Makefile6
4 files changed, 32 insertions, 5 deletions
diff --git a/audio/jack/Makefile b/audio/jack/Makefile
index cd86227c542f..bba5903e06e4 100644
--- a/audio/jack/Makefile
+++ b/audio/jack/Makefile
@@ -7,7 +7,7 @@
PORTNAME= jackit
PORTVERSION= 0.118.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio
MASTER_SITES= http://jackaudio.org/downloads/
DISTNAME= jack-audio-connection-kit-${PORTVERSION}
@@ -18,7 +18,7 @@ COMMENT= A low-latency audio server
LIB_DEPENDS= portaudio.0:${PORTSDIR}/audio/portaudio \
sndfile.1:${PORTSDIR}/audio/libsndfile \
samplerate.1:${PORTSDIR}/audio/libsamplerate \
- celt.0:${PORTSDIR}/audio/celt
+ celt0.2:${PORTSDIR}/audio/celt
LATEST_LINK= jack
CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}" LDFLAGS="-L${LOCALBASE}/lib" \
diff --git a/audio/jack/files/patch-drivers__netjack__netjack_packet.c b/audio/jack/files/patch-drivers__netjack__netjack_packet.c
new file mode 100644
index 000000000000..6bdd5ee876d0
--- /dev/null
+++ b/audio/jack/files/patch-drivers__netjack__netjack_packet.c
@@ -0,0 +1,23 @@
+--- ./drivers/netjack/netjack_packet.c.orig 2009-11-12 22:09:39.000000000 +0100
++++ ./drivers/netjack/netjack_packet.c 2011-04-12 11:31:54.221162522 +0200
+@@ -1427,9 +1427,9 @@
+
+ CELTDecoder *decoder = src_node->data;
+ if( !packet_payload )
+- celt_decode_float( decoder, NULL, net_period_down, buf );
++ celt_decode_float( decoder, NULL, net_period_down, buf, 1);
+ else
+- celt_decode_float( decoder, packet_bufX, net_period_down, buf );
++ celt_decode_float( decoder, packet_bufX, net_period_down, buf, 1);
+
+ src_node = jack_slist_next (src_node);
+ }
+@@ -1471,7 +1471,7 @@
+ float *floatbuf = alloca (sizeof(float) * nframes );
+ memcpy( floatbuf, buf, nframes*sizeof(float) );
+ CELTEncoder *encoder = src_node->data;
+- encoded_bytes = celt_encode_float( encoder, floatbuf, NULL, packet_bufX, net_period_up );
++ encoded_bytes = celt_encode_float( encoder, floatbuf, 1, packet_bufX, net_period_up );
+ if( encoded_bytes != net_period_up )
+ printf( "something in celt changed. netjack needs to be changed to handle this.\n" );
+ src_node = jack_slist_next( src_node );
diff --git a/audio/mangler/Makefile b/audio/mangler/Makefile
index cb4add816f76..2ee362355de4 100644
--- a/audio/mangler/Makefile
+++ b/audio/mangler/Makefile
@@ -7,14 +7,14 @@
PORTNAME= mangler
PORTVERSION= 1.2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://www.mangler.org/downloads/
MAINTAINER= janik@hikarihq.com
COMMENT= A Ventrilo VOIP combatible client
-LIB_DEPENDS= celt.0:${PORTSDIR}/audio/celt \
+LIB_DEPENDS= celt0.2:${PORTSDIR}/audio/celt \
speex.1:${PORTSDIR}/audio/speex \
dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24 \
diff --git a/audio/mumble/Makefile b/audio/mumble/Makefile
index fd8f3ac41847..f34c8d8352ca 100644
--- a/audio/mumble/Makefile
+++ b/audio/mumble/Makefile
@@ -61,7 +61,7 @@ PLIST_SUB+= BUNDLECELT=""
.else
CONFIG+= no-bundled-celt
PLIST_SUB+= BUNDLECELT="@comment "
-LIB_DEPENDS+= celt.0:${PORTSDIR}/audio/celt
+LIB_DEPENDS+= celt0.2:${PORTSDIR}/audio/celt
.endif
.if defined(WITHOUT_BONJOUR)
@@ -79,6 +79,10 @@ PLIST_SUB+= MUMBLE11X=""
post-patch:
@${REINPLACE_CMD} -e 's|-ldl||' ${WRKSRC}/overlay_gl/overlay_gl.pro
+ # Fix with celt 0.11
+.if !defined(WITHOUT_SYSCELT)
+ @${REINPLACE_CMD} -e 's/CELT_SET_VBR_RATE/CELT_SET_BITRATE/g' ${WRKSRC}/src/mumble/AudioInput.cpp
+.endif
do-configure:
.if defined(WITHOUT_SYSCELT)