aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-09-17 14:28:07 +0800
committerbapt <bapt@FreeBSD.org>2013-09-17 14:28:07 +0800
commitfde693e93db35fe3bd1a21756278115f8bfa5d96 (patch)
treea2818cc36d7e06c4c64a53b943d25f7b90c450f3 /audio
parent12e20b0674c48f693a78fe456f8afcfb71b9685b (diff)
downloadfreebsd-ports-gnome-fde693e93db35fe3bd1a21756278115f8bfa5d96.tar.gz
freebsd-ports-gnome-fde693e93db35fe3bd1a21756278115f8bfa5d96.tar.zst
freebsd-ports-gnome-fde693e93db35fe3bd1a21756278115f8bfa5d96.zip
Convert to new perl framework
Convert from USE_GMAKE to USES=gmake
Diffstat (limited to 'audio')
-rw-r--r--audio/gnump3d/Makefile9
-rw-r--r--audio/rebot3/Makefile2
2 files changed, 6 insertions, 5 deletions
diff --git a/audio/gnump3d/Makefile b/audio/gnump3d/Makefile
index 22f36087f3ab..5f01b7919ba9 100644
--- a/audio/gnump3d/Makefile
+++ b/audio/gnump3d/Makefile
@@ -11,12 +11,13 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= jadawin@FreeBSD.org
COMMENT= Streaming server for MP3, Ogg Vorbis, and other streamable audio files
-RUN_DEPENDS= lame:${PORTSDIR}/audio/lame \
- sox:${PORTSDIR}/audio/sox \
- oggenc:${PORTSDIR}/audio/vorbis-tools
+RUN_DEPENDS= liblame.so:${PORTSDIR}/audio/lame \
+ libsox.so:${PORTSDIR}/audio/sox \
+ liboggenc.so:${PORTSDIR}/audio/vorbis-tools
USE_BZIP2= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
NO_BUILD= yes
USE_RC_SUBR= gnump3d
SUB_LIST+= PERL=${PERL}
diff --git a/audio/rebot3/Makefile b/audio/rebot3/Makefile
index 5dce0f0bccb4..fb5c336976d2 100644
--- a/audio/rebot3/Makefile
+++ b/audio/rebot3/Makefile
@@ -14,7 +14,7 @@ LICENSE= GPLv2
RUN_DEPENDS= p5-CDDB>=0:${PORTSDIR}/audio/p5-CDDB \
p5-MP3-ID3v1Tag>=0:${PORTSDIR}/audio/p5-MP3-ID3v1Tag
-USE_PERL5= yes
+USES= perl5
NO_BUILD= yes
MAN1= ${PORTNAME}.1